Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-18-09, 07:17 PM   #817
psychok9
Registered User
 
Join Date: Dec 2008
Posts: 55
Default Re: mplayer vdpau

Quote:
Originally Posted by cehoyos View Post
It seems I am the only one affected by this problem so far.

This was fixed by Reimar (and today's compilation issues were also fixed), so I invite everybody interested to test latest mplayer svn with vdpau and report back here.
Many errors with vdpau enabled. No problems with vdpau disabled (./configure --enable-gui).
Same errors with nVidia selected version O_o.
Yesterday i got many errors also with vdpau disabled.
psychok9 is offline   Reply With Quote
Old 02-18-09, 07:38 PM   #818
etlamo
Registered User
 
Join Date: Nov 2008
Posts: 7
Default Re: mplayer vdpau

How can I force deinterlacing with vdpau? (on mpeg1/2 TVrip)
etlamo is offline   Reply With Quote
Old 02-18-09, 09:17 PM   #819
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: mplayer vdpau

The NVIDIA-supplied MPlayer patches don't support de-interlacing. I imagine the same is currently true of the VDPAU support in MPlayer SVN so far.
Stephen Warren is offline   Reply With Quote
Old 02-19-09, 02:02 AM   #820
atckoe
Registered User
 
Join Date: Feb 2009
Posts: 3
Default Re: WVC1 - Is it possible

Quote:
Originally Posted by n88 View Post
A quick one please

would you guys know whether its possible to please WVC1 files with vdpau? Possibly with moving the Win32dll's around?

I'm getting Audio only, I can play the test 264, VC-1 files without any issue.
Cheers.

----------------
mplayer -vc ffvc1vdpau -vo vdpau test.mkv
MPlayer dev-SVN-r28348-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU E4500 @ 2.20GHz (Family: 6, Model: 15, Stepping: 13)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
137 audio & 296 video codecs

Playing test.mkv.
[mkv] Track ID 1: video (V_MS/VFW/FOURCC) "VC-1 remux", -vid 0
[mkv] Track ID 2: audio (A_DTS) "DTS 1536", -aid 0, -alang eng
[mkv] Track ID 3: subtitles (S_TEXT/UTF8), -sid 0, -slang eng
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [WVC1] 1920x1080 0bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
================================================== ========================
Forced video codec: ffvc1vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
[vc1_vdpau @ 0x8951700]Incomplete extradata
Could not open codec.
VDecoder init failed
Cannot find codec matching selected -vo and video format 0x31435657.
Read DOCS/HTML/en/codecs.html!
================================================== ========================
================================================== ========================
Opening audio decoder: [libdca] DTS decoding with libdca
Stream with high frequencies VQ coding
AUDIO: 48000 Hz, 2 ch, s16le, 1536.0 kbit/100.00% (ratio: 192000->192000)
Selected audio codec: [dts] afm: libdca (DTS-libdca)
================================================== ========================
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Video: no video
Starting playback...
A: 1.8 (01.7) of 7557.5 ( 2:05:57.5) 5.5%
Try use codecs.conf from mplayer-vdpau sources
atckoe is offline   Reply With Quote
Old 02-21-09, 08:00 AM   #821
dragilla
Registered User
 
Join Date: Feb 2009
Posts: 12
Default Re: mplayer vdpau

Hi there again.
One short question.
Do you think that playing 1080p60 videos is possible on NV 9300M GS? P mean: is the hardware capable of playing this quality? I tierd and it doesn't seem so so far. 720p60 videos play smoothly now, also 1080p24 ones.

regards,
--
Luke
dragilla is offline   Reply With Quote
Old 02-21-09, 10:33 AM   #822
philipl
Registered User
 
Join Date: May 2003
Location: Sunnyvale, CA
Posts: 116
Default Re: mplayer vdpau

Quote:
Originally Posted by dragilla View Post
Hi there again.
One short question.
Do you think that playing 1080p60 videos is possible on NV 9300M GS? P mean: is the hardware capable of playing this quality? I tierd and it doesn't seem so so far. 720p60 videos play smoothly now, also 1080p24 ones.

regards,
--
Lukd
Maybe 1080p60 mpeg2 videos, but not h.264 - those are a higher level than the hardware is designed for.
__________________
--phil
philipl is offline   Reply With Quote
Old 02-21-09, 10:40 AM   #823
BenBuntu
Registered User
 
Join Date: Sep 2008
Posts: 13
Default Re: mplayer vdpau

Quote:
Originally Posted by dragilla View Post
Hi there again.
One short question.
Do you think that playing 1080p60 videos is possible on NV 9300M GS? P mean: is the hardware capable of playing this quality? I tierd and it doesn't seem so so far. 720p60 videos play smoothly now, also 1080p24 ones.

regards,
--
Lukd
I also have an NV 9300M GS, and I was wondering the same thing. Here's a sample 1080p 60fps H.264 video that almost plays smoothly, but there are some brief stutters here and there:

http://ckworks.sakura.ne.jp/data/xac...207_2a_mp4.zip

Please note that you will want to add the "-really-quiet" option to suppress continuous error messages when playing this video, and to see the stuttering you need to add the "-framedrop" option (or else the video will just play a bit slow and the audio won't stay in sync).

Thanks,
Ben
BenBuntu is offline   Reply With Quote
Old 02-21-09, 12:41 PM   #824
jamiller1110
Registered User
 
Join Date: Feb 2009
Posts: 2
Default Re: WVC1 - Is it possible

Quote:
Originally Posted by n88 View Post
A quick one please

would you guys know whether its possible to please WVC1 files with vdpau? Possibly with moving the Win32dll's around?

I'm getting Audio only, I can play the test 264, VC-1 files without any issue.
Cheers.
I was having the exact same problem, I solved it by adding -demuxer lavf to the mplayer command line and it solved the problem.
jamiller1110 is offline   Reply With Quote

Old 02-21-09, 01:08 PM   #825
dragilla
Registered User
 
Join Date: Feb 2009
Posts: 12
Default Re: WVC1 - Is it possible

Quote:
Originally Posted by jamiller1110 View Post
I was having the exact same problem, I solved it by adding -demuxer lavf to the mplayer command line and it solved the problem.
It doesn't help much if at all. Same with you Ben?

Edit: Oops, I didn't read that well enough. I thought you were refering to Ben's post. Sorry.
--
Luke
dragilla is offline   Reply With Quote
Old 02-21-09, 02:19 PM   #826
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: WVC1 - Is it possible

Quote:
Originally Posted by jamiller1110 View Post
I was having the exact same problem, I solved it by adding -demuxer lavf to the mplayer command line and it solved the problem.
Could you post a link to a sample?
Thank you, Carl Eugen
cehoyos is offline   Reply With Quote
Old 02-21-09, 05:24 PM   #827
jamiller1110
Registered User
 
Join Date: Feb 2009
Posts: 2
Default Re: WVC1 - Is it possible

Quote:
Originally Posted by cehoyos View Post
Could you post a link to a sample?
Thank you, Carl Eugen
Me or n88? If me, they were rips of personally owned blu-rays/hd-dvds so I will not be able to post a sample. They were straight rips of the vc-1 videos, my h264s and ota mpeg1/2 would run fine without the -demuxer switch though.
jamiller1110 is offline   Reply With Quote
Old 02-22-09, 12:37 AM   #828
nullack
Registered User
 
Join Date: Oct 2007
Posts: 74
Default Re: mplayer vdpau

What is the latest vdpau code? Mplayer SVN or Nvidias patches? Thanks i.e. As in which codebase is considered currently best?
nullack is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM
VDPAU and KDE 4.8 compositing = slow Pie-rate NVIDIA Linux 30 05-23-12 07:07 AM
VDPAU testing tool crisalide NVIDIA Linux 392 04-29-12 06:01 PM
mplayer & xmms problems! replys2me NVIDIA Linux 5 09-06-02 02:34 PM

All times are GMT -5. The time now is 04:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.