Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-01-09, 10:47 AM   #1
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default DVI -> HDMI no sound.. how to resolve?

I'm trying to connect a DVI device with analog audio out to a TV that accepts HDMI and will recognize an analog audio signal however the TV is only accepting digital sound over HDMI.

How can I resolve this issue?

Thanks.

AJM,
vbtalent is offline   Reply With Quote
Old 03-01-09, 01:49 PM   #2
klemi
Registered User
 
Join Date: Aug 2008
Posts: 12
Default Re: DVI -> HDMI no sound.. how to resolve?

have same problem here....


klemi
klemi is offline   Reply With Quote
Old 03-01-09, 03:52 PM   #3
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: DVI -> HDMI no sound.. how to resolve?

Kind of a large bug unless Nvidia just assumes everyone is going out to buy new equipment every month...

Using the following option in xorg will get the sound working but jack up the picture...

Option "UseEDID" "False

They need an option:

Option "UseAnlogSound"
vbtalent is offline   Reply With Quote
Old 03-01-09, 05:11 PM   #4
Ankh
Registered User
 
Join Date: May 2005
Location: Leicester, UK
Posts: 36
Default Re: DVI -> HDMI no sound.. how to resolve?

Quote:
Originally Posted by vbtalent View Post
I'm trying to connect a DVI device with analog audio out to a TV that accepts HDMI and will recognize an analog audio signal however the TV is only accepting digital sound over HDMI.

How can I resolve this issue?

Thanks.

AJM,
Write a custom EDID:

http://www.nvnews.net/vbulletin/show...18&postcount=6

Rich.
Ankh is offline   Reply With Quote
Old 03-01-09, 06:53 PM   #5
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: DVI -> HDMI no sound.. how to resolve?

Thanks for the post Rich.

I've done exactly that but with some mixed results when using just a regular xorg.conf with my dektop LCD I can launch for instance Rythmbo and it boots fast and works fine. With my custom EDID the same application locks up my machine so something must be wrong?

I used the application at http://analogbit.com/node/23 to modify the edid.bin other than that I just modified the xorg.conf I'll post in case you might see something.

Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Jan 27 12:47:59 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Samsung"
Modelname "LN-T4665F"
Horizsync 30.0-70.0
Vertrefresh 59.0-71.0
modeline "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
modeline "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
modeline "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
#This should point to the FIXED edid file as described on that webpage after fixing the edid file should
#be 128 bytes. Fix filename and path below accordingly.
Option "CustomEDID" "DFP-0:/etc/X11/edid_mod.bin"
Option "ModeValidation" "AllowNon60HzDFPModes, NoVESAModes, NoXServerModes
Option "ExactModeTimingsDVI" "true"
Option "DPI" "100x100"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Defaultdepth 24
Option "UdeEDID" "False"
Option "RenderAccel" "true"
Option "DynamicTwinView" "False"
Option "TVOverScan" "0.00000"
Option "AllowGLXWithComposite" "true"
Option "NoLogo"
Option "XvmcUsesTextures" "false"
Option "UseEvents" "True"
Option "ConnectedMonitor" "DFP"
SubSection "Display"
Depth 24
Modes "1920x1080" "1280x720" "720x480"
EndSubSection
EndSection
vbtalent is offline   Reply With Quote
Old 03-01-09, 07:01 PM   #6
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: DVI -> HDMI no sound.. how to resolve?

I also wanted to post from xorg.log in case someone is interested or sees something that is missing, etc..

Quote:
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(**) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "NoLogo"
(**) NVIDIA(0): Option "ConnectedMonitor" "DFP"
(**) NVIDIA(0): Option "RenderAccel" "true"
(**) NVIDIA(0): Option "CustomEDID" "DFP-0:/etc/X11/edid_mod.bin"
(**) NVIDIA(0): Option "TVOverScan" "0.00000"
(**) NVIDIA(0): Option "XvMCUsesTextures" "false"
(**) NVIDIA(0): Option "AllowGLXWithComposite" "true"
(**) NVIDIA(0): Option "ExactModeTimingsDVI" "true"
(**) NVIDIA(0): Option "DPI" "100x100"
(**) NVIDIA(0): Option "UseEvents" "True"
(**) NVIDIA(0): Option "ModeValidation" "AllowNon60HzDFPModes, NoVESAModes, NoXServerModes"
(**) NVIDIA(0): Option "DynamicTwinView" "False"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): ConnectedMonitor string: "DFP"
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 8300 (C77) at PCI:2:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 62.77.2a.00.05
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8300 at PCI:2:0:0:
(--) NVIDIA(0): SAMSUNG (DFP-0)
(--) NVIDIA(0): SAMSUNG (DFP-0): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): SAMSUNG (DFP-0): Internal Single Link TMDS
(II) NVIDIA(0): Mode Validation Overrides for SAMSUNG (DFP-0):
(II) NVIDIA(0): AllowNon60HzDFPModes
(II) NVIDIA(0): NoVesaModes
(II) NVIDIA(0): NoXServerModes
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "1920x1080"
(II) NVIDIA(0): "1280x720"
(II) NVIDIA(0): "720x480"
(II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
(**) NVIDIA(0): DPI set to (100, 100); computed from "DPI" X config option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX[b]
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX[b]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Setting mode "1920x1080"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(==) NVIDIA(0): Disabling shared memory pixmaps
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): DPMS enabled
vbtalent is offline   Reply With Quote
Old 03-01-09, 08:43 PM   #7
vbtalent
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Re: DVI -> HDMI no sound.. how to resolve?

Quote:
Originally Posted by klemi View Post
have same problem here....


klemi
Hopefully this will help... I finally got it working.


Firstly I tested the audio was working on my PC before even hooking to the TV and after hooking it to the TV I modified the xorg.conf to test that infact the sound would work by adding the following Option "UseEdid" "FALSE" in the Section "Screen" and opening Rythmbox then selecting a Radiostation to play - the resolution was jacked up but the sound played.

The first part was getting my TV EDID.bin, I did this by booting my computer (Ubuntu) on my TV going to Aplications>System Tools>Nvidia X Server Settings then to the section DFP-0 and clicking on the button "Acquire EDID", saved it and transferred that file to my Windows box.

I downloaded the application Monitor Asset Manager from (http://www.entechtaiwan.com/util/moninfo.shtm - Windows only) launched that program and copied out the modelines for use in the my xorg.conf. I'm sure there are other ways but this was very simple.


Modeline............... "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

Modeline............... "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync

Modeline............... "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync


After acuiring the Modelines, I had to modify the EDID file itself and did this with a cool utility on this site (http://analogbit.com/node/23) it's called edid_disable_exts. It actually did all the modification to the EDID file for me by simply feeding it the input and output file names (./edid_disable_exts [input_file] [output_file] ). The original file was 256bytes and the modified file was 128bytes if I remember correctly.

Once that file was created and saved back on Ubuntu in /etc/X11/ I needed to assemble my xorg.conf and needed to include the following which directs xorg to use the new EDID file I had just created.

Section "Device"
Identifier "nVidia"
Driver "nvidia"
Option "CustomEDID" "DFP-0:/etc/X11/L2410NM-modified.edid"
EndSection

Some important areas of xorg:

Section "Monitor"
...
Vertrefresh 59.0-71.0
modeline "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
modeline "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
modeline "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync

Section "Device"
...
#This should point to the FIXED edid file as described on that webpage after fixing the edid file should
#be 128 bytes. Fix filename and path below accordingly.
Option "CustomEDID" "DFP-0:/etc/X11/edid_mod.bin"
Option "ModeValidation" "AllowNon60HzDFPModes, NoVESAModes, NoXServerModes
Option "ExactModeTimingsDVI" "true"
Option "DPI" "100x100"

Section "Screen"
...
Option "ConnectedMonitor" "DFP"


My completed xorg:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Tue Jan 27 12:47:59 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
Vendorname "Samsung"
Modelname "LN-T4665F"
Horizsync 30.0-70.0
Vertrefresh 59.0-71.0
modeline "1920x1080" 148.500 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync
modeline "1280x720" 74.250 1280 1390 1430 1650 720 725 730 750 +hsync +vsync
modeline "720x480" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync
Gamma 1.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
#This should point to the FIXED edid file as described on that webpage after fixing the edid file should
#be 128 bytes. Fix filename and path below accordingly.
Option "CustomEDID" "DFP-0:/etc/X11/edid_mod.bin"
Option "ModeValidation" "AllowNon60HzDFPModes, NoVESAModes, NoXServerModes
Option "ExactModeTimingsDVI" "true"
Option "DPI" "100x100"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
Defaultdepth 24
Option "UdeEDID" "False"
Option "RenderAccel" "true"
Option "DynamicTwinView" "False"
Option "TVOverScan" "0.00000"
Option "AllowGLXWithComposite" "true"
Option "NoLogo"
Option "XvmcUsesTextures" "false"
Option "UseEvents" "True"
Option "ConnectedMonitor" "DFP"
SubSection "Display"
Depth 24
Modes "1920x1080" "1280x720" "720x480"
EndSubSection
EndSection

A reboot loaded the new xorg.conf and the resolution was set correctly. I would suggest taking a look in xorg.log for any issues that might arise also that you turn off any "Visual Effects" System>Preferences>Appearance, this was important for me, YMMV.
vbtalent is offline   Reply With Quote
Old 03-19-09, 10:09 AM   #8
maaltan
Registered User
 
Join Date: Mar 2009
Posts: 5
Default Re: DVI -> HDMI no sound.. how to resolve?

Quote:
Originally Posted by vbtalent View Post
Kind of a large bug unless Nvidia just assumes everyone is going out to buy new equipment every month...

Using the following option in xorg will get the sound working but jack up the picture...

Option "UseEDID" "False

They need an option:

Option "UseAnlogSound"
yeah really... My TV will not let me use analog sound when the digital stream is present. which is always apparenty, even if it doesn't work in linux.

in which section did you add the UseEDID optoin in xorg.conf? display?

thanks

<edit: sorry i didn't notice there was a second page of posts, i will try these other suggestions>
maaltan is offline   Reply With Quote

Old 05-28-10, 02:09 PM   #9
eNTi
Registered User
 
Join Date: Apr 2003
Posts: 9
Default Re: DVI -> HDMI no sound.. how to resolve?

sorry for thread-necromancy, but i just want to know, how i turn the sound off? my 250 gts sends weird signals via dvd->hdmi cable to my internal monitor speakers!
eNTi is offline   Reply With Quote
Old 05-28-10, 02:43 PM   #10
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: DVI -> HDMI no sound.. how to resolve?

Quote:
Originally Posted by vbtalent View Post
Kind of a large bug unless Nvidia just assumes everyone is going out to buy new equipment every month...
A large bug? Are you being serious? I hope not. I don't see any reason to over exaggerate. It's not as if there are millions of users that want to send video via dvi->hdmi and then use analog audio along with it. If any assumptions are to be made they should be that the vast majority or users aren't still using old outdated hardware -- because they're not.
primerib is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 06:40 PM

All times are GMT -5. The time now is 08:08 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.