Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-11-09, 08:51 AM   #25
KCat
Registered User
 
Join Date: Aug 2004
Posts: 11
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by tzp View Post
Check if PAT is enabled in your kernel:


to see if CONFIG_X86_PAT is set.
PAT is enabled. Was hoping to do without the reboots, but I'll try with it disabled.

Quote:
Originally Posted by Mostrapotski View Post
Is the powermizer reaching high levels ?
How do I tell that?
KCat is offline   Reply With Quote
Old 03-11-09, 09:34 AM   #26
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: glxgears stutters in Fedora, not in Ubuntu

Open a terminal and type in:
nvidia-settings &
On the left, click on the "PowerMizer" thing.

Go back to your terminal and type in:
glxgears

Look at the nvidia tool, the performance level should be the maximum available.
Mine is never going higher than 1 (out of 3).

It means i m using 35 % of my graphic card.

If you are experimenting the same bug, i have a bad new for you, nvidia is ignoring us.
Mostrapotski is offline   Reply With Quote
Old 03-11-09, 09:54 AM   #27
KCat
Registered User
 
Join Date: Aug 2004
Posts: 11
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by Mostrapotski View Post
Open a terminal and type in:
nvidia-settings &
On the left, click on the "PowerMizer" thing.

Go back to your terminal and type in:
glxgears

Look at the nvidia tool, the performance level should be the maximum available.
Mine is never going higher than 1 (out of 3).
Hmm, in that case, apparently I only have one performance level. The displayed Performance Level is 0, and there's only one level (0, 580MHz NV Clock, 800MHz Memory Clock) listed under the Performance Levels section.

Quote:
PAT is enabled. Was hoping to do without the reboots, but I'll try with it disabled.
Well, it was either PAT being on (I added the nopat kernel option), or the tickless kernel being off (somehow it get deselected, even though I had it enabled before, so I re-enabled it). But it seems to work now.
KCat is offline   Reply With Quote
Old 03-11-09, 10:08 AM   #28
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Re: glxgears stutters in Fedora, not in Ubuntu

Hi coelurus.

I do hope the nopat option does work for you.

I had the same issue a while ago and nopat cleared the slowdown for me, I also have a X2 CPU and nvidia 8 series card (8500GT) And that was slowdown in glxgear and games btw....

- Ubuntu's kernel doesn't have pat by default and Fedora's does so it is a likely culprit.

- btw the nopat option is no longer needed for me with 2.6.28 kernel and 180.29 driver - i.e the pat issue no longer effects me.

If the nopat option doesn't fix it for you might it be connected with the way you have installed the Nvidia driver.

I have had issues in the past after installing the nvidia driver manually in Arch linux and Mandriva - i.e not used their distro's package - I believe the issue was a conflict between libGL and the nvidia driver - if any one's interested my solution for arch was to edit the PKGCONFIG file from the nvidia driver from abs .

I really wish some people here wouldn't just let rip at people's post it really helps no one and gives the community a bad name - i've a feeling that certain people here really need to get laid/smoke something green....
interzoneuk is offline   Reply With Quote
Old 03-11-09, 10:13 AM   #29
Mostrapotski
Registered User
 
Join Date: Feb 2009
Posts: 24
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by KCat View Post
Hmm, in that case, apparently I only have one performance level.
Lucky you
Mostrapotski is offline   Reply With Quote
Old 03-18-09, 06:32 AM   #30
tzp
Registered User
 
tzp's Avatar
 
Join Date: Sep 2007
Location: Hungary
Posts: 92
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by mooninite View Post
If the OP needs detailed reasons on why glxgears is useless for even system -> system comparisons, here you go: http://wiki.cchtml.com/index.php/Glx...ot_a_Benchmark
There's another good article on that. It pinpoints what is slower in such cases:
Why glxgears is slower with Kernel Modesetting (and why it doesn't matter)
tzp is offline   Reply With Quote
Old 03-20-09, 05:42 AM   #31
rocktale
Registered User
 
Join Date: Mar 2009
Posts: 6
Default Maybe related?

I'm running Arch64 on my home desktop with KDE4.2. Since the upgrade from 4.1 the performance of displaying any video content (DVB, avi files etc.) with either mplayer/smplayer or kaffeine (xine-backend) went down the drain. However, I'm not entirely sure if things went wrong due to the update or just around the same time.

I can't really tell what it is, it just feels slow, it starts to stutter (and seems to repeat a couple of frames) every time you click somewhere else on the desktop or do something else like moving a window or opening KRunner. This is anoying because I used to put kaffeine on the second monitor to watch some TV (DVB) while working but I can't do that anymore. The sound plays ok, only displaying the video frames seems to be messed up.

Maybe related to that, I can't use any of kaffeine's deinterlacing algorithms anymore. I have the feeling they look worse than before (more like 256 colors) and they drop the video framerate even further.

I used to have a Nvidia Quadro NVS (which exhibited the problem) but replaced it with a GeForce 9500GT which at first seemed to reduce (but not solve) the problem. However, I have the feeling now that things stayed pretty much the same.

Recently, I played around with glxgears and had to realize that the problem exists there as well. As long as nothing else is happening on the desktop, the window gets updated correctly (although smooth is something else... it's more like the video stuff I described above). But as soon as I click somewhere, open a menu or something glxgears starts to stutter just like video does.

I have TwinView enabled but also tried things without it - no change.
I dropped my old xorg.conf in favor of a new (clean) one - no change.
I tried different video outputs (xv, gl, gl2) - no change.
I enabled/disabled desktop effects - no change.
I tried different driver versions (currently using the 180.29-3 from pacman, but also tried 180.22, .27 and .35 in the past) - no change.
Tried the latest beta (185.13) - no change.
Tried the nopat option - no change either.

The funny thing is that everything else works fine... desktop effects are smooth, even the video performance does not drop (further) when moving the video window itself with transparency and all that stuff.

I'm running out of ideas... really.
rocktale is offline   Reply With Quote
Old 03-20-09, 10:46 AM   #32
yeye69
Registered User
 
Join Date: Dec 2008
Posts: 8
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by mooninite View Post
If the OP wants to be taken seriously, I recommend that he try real 3D benchmarks. Download one of the Unigine benchmarks at this link. I recommend the Tropics or Sanctuary benchmark.

http://unigine.com/download/
sorry for offtop.

How to run that benchmark on Fedora 10 with nvidia's 180.35, it's need libopenal.so.0, I didn't find it neither in my system, nor in repo
yeye69 is offline   Reply With Quote

Old 03-20-09, 01:59 PM   #33
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by yeye69 View Post
sorry for offtop.

How to run that benchmark on Fedora 10 with nvidia's 180.35, it's need libopenal.so.0, I didn't find it neither in my system, nor in repo
# yum install openal.i386

I'm guessing you have a 64-bit system. The benchmark is a 32-bit binary.

P.S. You don't need openal installed to run the benchmark. It will work just fine, but without sound.
mooninite is offline   Reply With Quote
Old 03-20-09, 02:07 PM   #34
KCat
Registered User
 
Join Date: Aug 2004
Posts: 11
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by mooninite View Post
# yum install openal.i386

I'm guessing you have a 64-bit system. The benchmark is a 32-bit binary.

P.S. You don't need openal installed to run the benchmark. It will work just fine, but without sound.
I don't know what which Fedora has, but newer OpenAL versions are named libopenal.so.1, not libopenal.so.0. You can try making a symlink (either in /usr/lib or /usr/local/lib) for libopenal.so.0 to point to libopenal.so.1... most apps should work fine with that. You can also put the symlink in with the other libs Unigine has, if you don't want to make it system-wide.
KCat is offline   Reply With Quote
Old 03-20-09, 02:41 PM   #35
mooninite
Registered User
 
Join Date: May 2006
Posts: 477
Default Re: glxgears stutters in Fedora, not in Ubuntu

Quote:
Originally Posted by KCat View Post
I don't know what which Fedora has
Fedora has libopenal.so.0.
mooninite is offline   Reply With Quote
Old 04-01-09, 10:22 PM   #36
PilotJLR
Registered User
 
Join Date: Apr 2009
Posts: 1
Default Re: glxgears stutters in Fedora, not in Ubuntu

I had experienced the exact same issue as the OP... passing "nopat" to the kernel has resolved this problem!

Although I haven't used glxgears, disregarding the OP's direct comparison is asinine. I have used a variety of applications (X-Plane is one) that performed better under Ubuntu 8.X than in Fedora 9/10. Nopat is clearly the reason... adding nopat as a kernel argument has fixed the jitter and poor framerate I previously experienced.

Thank you for those who recommended this fix!
PilotJLR is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linux gaming on the rise: EA arrives on Ubuntu and Valve plans Steam port News Gaming Headlines 0 06-15-12 04:20 PM
Fedora 17: Beefier Than Ubuntu 12.04 LTS? News Archived News Items 0 06-09-12 11:10 AM
Canonical partners with Microsoft to support Ubuntu on Azure News Archived News Items 0 06-08-12 05:20 AM
Ubuntu and Unity, Google reCAPTCHA hacked, and Flame spy malware News Archived News Items 0 06-02-12 09:40 AM
Precision and purpose: Ubuntu 12.04 and the Unity HUD reviewed News Archived News Items 0 05-28-12 02:20 PM

All times are GMT -5. The time now is 05:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.