Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-09-09, 02:07 PM   #1
Jeff91
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Issues with SDL

I have a large number of games installed via the repositories on Ubuntu 8.10 how ever many of them throw an error similar to this upon trying to load them:

Code:
Error : SDL initialization failed
Reason : No available video device
I have a NVidia 9500M GS Graphics card and I am running the 180.xx drivers. Any one have ideas ideas how I can correct this error?

I found this thread which appears to be the same issue I am having... how ever I do not under stand the solution that was posted anyone mind explaining how I can apply this to Ubuntu 8.10

Thanks,
~Jeff
Jeff91 is offline   Reply With Quote
Old 03-09-09, 03:17 PM   #2
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Re: Issues with SDL

Hi.

What version are you running - i.e x86 or 64bit ?

Also please post the output of

sudo dpkg -l | grep -i sdl | grep -i ii

you may be missing some packages ?

Also make sure you are NOT running as root / sudo

cheers
interzoneuk is offline   Reply With Quote
Old 03-10-09, 10:03 PM   #3
Jeff91
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Re: Issues with SDL

64bit Ubuntu and no I am not logged in as root. Will post the output of that command as soon as I get home.

Thanks,
~Jeff
Jeff91 is offline   Reply With Quote
Old 03-10-09, 11:10 PM   #4
Jeff91
Registered User
 
Join Date: Jan 2009
Posts: 11
Default Re: Issues with SDL

Output of sudo dpkg -l | grep -i sdl | grep -i ii
Code:
jeff@jeff-ubuntu:/etc/X11$ sudo dpkg -l | grep -i sdl | grep -i ii
ii  libsdl-console                             1.3-5                                   console that can be added to any SDL applica
ii  libsdl-gfx1.2-4                            2.0.13-4                                drawing and graphical effects extension for 
ii  libsdl-image1.2                            1.2.6-3                                 image loading library for Simple DirectMedia
ii  libsdl-mixer1.2                            1.2.8-4                                 mixer library for Simple DirectMedia Layer 1
ii  libsdl-net1.2                              1.2.7-2                                 network library for Simple DirectMedia Layer
ii  libsdl-pango1                              0.1.2-4                                 text rendering with Pango in SDL application
ii  libsdl-perl                                1.20.3dfsg-3                            SDL bindings for the Perl language
ii  libsdl-ttf2.0-0                            2.0.9-1                                 ttf library for Simple DirectMedia Layer wit
ii  libsdl1.2debian                            1.2.13-2ubuntu1                         Simple DirectMedia Layer
ii  libsdl1.2debian-all                        1.2.13-2ubuntu1                         Simple DirectMedia Layer (with all available
ii  libsmpeg0                                  0.4.5+cvs20030824-2                     SDL MPEG Player Library - shared libraries
ii  python-pygame                              1.8.1release-0ubuntu1                   SDL bindings for games development in Python
Also my xorg.conf output in case it might help:

Code:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildmeister@builder58)  Tue Jan 27 12:48:44 PST 2009

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder58)  Tue Jan 27 12:47:59 PST 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Seiko"
    HorizSync       30.0 - 75.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "WDE WestinghouseSK-32H570D"
    HorizSync       30.0 - 61.0
    VertRefresh     50.0 - 75.0
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500M GS"
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 9500M GS"
    BusID          "PCI:1:0:0"
    Screen          1
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT: 1366x768 +0+0"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Let me know if you need anything else,
~Jeff
Jeff91 is offline   Reply With Quote
Old 03-11-09, 10:40 AM   #5
interzoneuk
Registered User
 
Join Date: Mar 2005
Posts: 81
Default Re: Issues with SDL

Hi.

Can you also confirm

- the game you are trying (also is it 32/64bit game ?)
- does glxgears work ? (type glxgears from command prompt)

Also check if you have these files installed

sudo apt-get install ia32-libs libsdl1.2 ia32-libs-sdl

One other thing - do you have multiple monitors ?

regards
interzoneuk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange RedHat 7.3 issues with A7N266-C nforceuser NVIDIA Linux 8 09-27-02 03:16 PM
Overclocking issues... mcortz_2000 CPUs, Motherboards And Memory 5 09-16-02 03:41 PM
Problem when compiling with SDL on Nvidia/Nforce... superconti NVIDIA Linux 3 09-13-02 12:25 AM
Is there a Microsoft patch for the refresh rate issues yet? Zarich NVIDIA GeForce 7, 8, And 9 Series 22 08-24-02 01:02 PM

All times are GMT -5. The time now is 03:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.