Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-10-09, 03:04 PM   #73
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

Thanks bex.
ggking7 is offline   Reply With Quote
Old 02-10-09, 09:03 PM   #74
Uberman
Registered User
 
Join Date: Feb 2009
Posts: 4
Default Re: Xine vdpau announcement

Quote:
Originally Posted by Stephen Warren View Post
It's certainly on our TODO list, but I can't make specific promises if/when it'll happen right now.

FYI, to get rid of the tearing, you can either:
a) Disable the X composite extension
b) Run a compositing manager, and make sure the compositing manager's rendering is set up to sync-to-VBlank (e.g. via OpenGL settings)
Sorry to be stupid, Stephen, but can you point me at a link that describes how to do these? I'm pretty sure my FC8 is not running a compositing manager (nor has the composite extension enabled), but I don't even know how to see.
Uberman is offline   Reply With Quote
Old 02-10-09, 10:10 PM   #75
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Xine vdpau announcement

I think the driver's README might talk about how to enable/disable X extensions. Otherwise, try "man xorg.conf"
Stephen Warren is offline   Reply With Quote
Old 02-10-09, 10:38 PM   #76
Uberman
Registered User
 
Join Date: Feb 2009
Posts: 4
Default Re: Xine vdpau announcement

Quote:
Originally Posted by Stephen Warren View Post
I think the driver's README might talk about how to enable/disable X extensions. Otherwise, try "man xorg.conf"
Found it:

Code:
nvidia-xconfig --no-composite
Got it from:

Code:
man nvidia-xconfig
Just in case anybody else comes in with the same question.
Uberman is offline   Reply With Quote
Old 02-16-09, 07:38 PM   #77
ggking7
Registered User
 
Join Date: Oct 2006
Posts: 48
Default Re: Xine vdpau announcement

I got 'miro --debug' working. I get "Xine video driver: vdpau" so it's using the vdpau driver, but there isn't any acceleration. Here is what I get when I try to play a "Trading Places" Blu-Ray remux:

[h264 @ 0x5f8c0b0]non-existing PPS referenced
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]non-existing PPS referenced
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]non-existing PPS referenced
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]non-existing PPS referenced
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]no frame!
[h264 @ 0x5f8c0b0]B picture before any references, skipping
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]B picture before any references, skipping
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]B picture before any references, skipping
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]B picture before any references, skipping
[h264 @ 0x5f8c0b0]decode_slice_header error
[h264 @ 0x5f8c0b0]no frame!
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[h264 @ 0x5f8c0b0]number of reference frames exceeds max (probably corrupt input), discarding one
[New LWP 8081]
[h264 @ 0x5f8c0b0]concealing 6240 DC, 6240 AC, 6240 MV errors
ggking7 is offline   Reply With Quote
Old 02-18-09, 12:45 PM   #78
Uberman
Registered User
 
Join Date: Feb 2009
Posts: 4
Default Re: Xine vdpau announcement

Is anybody else getting occasional delays in the playback? I'm not talking about stuttering, but 3-5 second pauses where the picture and audio just stay on the same frame? It's not happening with all movies, but most, and some are worse than others ("Blade Runner" only did it in the end credits, "Dark City" did it pretty frequently, "The Chronicles of Rid****" only did it a couple of times).

This is using mplayer-vdpau under Fedora Core 8. Running 'top', nothing seems to be consuming the CPUs (Core 2 Duo @ 3.0GHz), and the file system where the movies are stored is XFS (supposedly the best performance). I'm using an NVIDIA 8500GT with the 180.29 drivers (latest released), and the composite manager is turned off.
Uberman is offline   Reply With Quote
Old 02-25-09, 03:57 AM   #79
ciaccom
Registered User
 
Join Date: Jan 2009
Posts: 13
Default Re: Xine vdpau announcement

hello,

i just wanted to offer my big compliments to xine-vdpau developers! it's now (i think till r221 - now i'm using r235) working really stable with live TV broadcasts!! thank's a lot!

with my geforce 9400GT (G96) 1080i live material is really fluently with deinterlaceing "bob". using temporal as deint. sometimes its perfect and sometimes it's a little jerked (don't know why it has this behaviour .. maybe the new nvidia driver 180.35 will chenge it)

many greets, ciaccom

Last edited by ciaccom; 03-05-09 at 09:31 AM.
ciaccom is offline   Reply With Quote
Old 03-05-09, 09:40 AM   #80
ciaccom
Registered User
 
Join Date: Jan 2009
Posts: 13
Thumbs up Re: Xine vdpau announcement

Quote:
Originally Posted by ciaccom View Post
with my geforce 9400GT (G96) 1080i live material is really fluently with deinterlaceing "bob". using temporal as deint. sometimes its perfect and sometimes it's a little jerked (don't know why it has this behaviour .. maybe the new nvidia driver 180.35 will change it)
hello again,

to sum it up - with current release of xine-vdpau (actually it's r242) and the new nvidia-driver v180.35 "temporal" as deinterlacing algo is now always(!) working with 1080i broadcast material (ex. Astra-HD+ / 19°E).
Usually it needs some time (approx. 20 sec to 1 minute) till output is getting smooth!

thank's,
ciaccom
ciaccom is offline   Reply With Quote

Old 03-05-09, 10:10 AM   #81
Gregoire.Favre
Registered User
 
Join Date: Nov 2004
Posts: 126
Default Re: Xine vdpau announcement

That's great new, I really hope nvidia will release an updated driver very soon as 180.35 is really unusable here (and they said they have fixed the two issues I have).
Gregoire.Favre is offline   Reply With Quote
Old 03-15-09, 11:19 AM   #82
Lost Dog
Registered User
 
Join Date: Aug 2007
Posts: 151
Default Re: Xine vdpau announcement

I'm having some issues building xine-vdpau from svn. This was as of 03/15/2009. I've tried on both Debian Lenny and Debian Squeeze (both 64 bit).

Here is the error:

Code:
 gcc -DHAVE_CONFIG_H -I. -I../../.. -I../../../include -I../../../include -I../../../src -I../../../src/xine-engine -I../../../src/xine-engine -I../../../src/xine-utils -I../../../src/input -I../../../src/input -I../../../lib -I../../../lib -I../../../src/dxr3 -I/usr/local/include -I/usr/local/include -fvisibility=hidden -D_REENTRANT -D_FILE_OFFSET_BITS=64 -DXINE_COMPILE -O3 -fomit-frame-pointer -fexpensive-optimizations -fschedule-insns2 -ffast-math -finline-functions -Wpointer-arith -g -O2 -Wall -Wchar-subscripts -Wnested-externs -Wcast-align -Wmissing-declarations -Wmissing-prototypes -Wmissing-format-attribute -Wformat=2 -Wno-format-zero-length -Wstrict-aliasing=2 -Werror=implicit-function-declaration -DNDEBUG -MT xineplug_decode_ff_la-ffmpeg_decoder.lo -MD -MP -MF .deps/xineplug_decode_ff_la-ffmpeg_decoder.Tpo -c ffmpeg_decoder.c  -fPIC -DPIC -o .libs/xineplug_decode_ff_la-ffmpeg_decoder.o
ff_video_decoder.c:123: warning: ‘AVPaletteControl’ is deprecated
ff_video_decoder.c: In function ‘ff_convert_frame’:
ff_video_decoder.c:653: error: ‘PIX_FMT_RGBA32’ undeclared (first use in this function)
ff_video_decoder.c:653: error: (Each undeclared identifier is reported only once
ff_video_decoder.c:653: error: for each function it appears in.)
ff_video_decoder.c: In function ‘ff_handle_special_buffer’:
ff_video_decoder.c:1021: warning: ‘AVPaletteControl’ is deprecated
ff_video_decoder.c:1025: warning: ‘AVPaletteControl’ is deprecated
ff_video_decoder.c: In function ‘ff_handle_buffer’:
ff_video_decoder.c:1299: error: ‘PIX_FMT_RGBA32’ undeclared (first use in this function)
ff_video_decoder.c:1355: warning: passing argument 1 of ‘pp_postprocess’ from incompatible pointer type
ff_video_decoder.c: In function ‘init_video_plugin’:
ff_video_decoder.c:1652: warning: dereferencing type-punned pointer might break strict-aliasing rules
make[3]: *** [xineplug_decode_ff_la-ff_video_decoder.lo] Error 1
make[3]: *** Waiting for unfinished jobs....
I've also compiled (with no issue) ffmpeg from the latest svn as well. It appears this xine-vdpau error is somehow related to ffmpeg?

Any suggestions?

Thanks!
Lost Dog is offline   Reply With Quote
Old 03-15-09, 01:16 PM   #83
cthulhu
Great Old One
 
cthulhu's Avatar
 
Join Date: Sep 2002
Posts: 124
Default Re: Xine vdpau announcement

You have to change PIX_FMT_RGBA32 to PIX_FMT_RGB32 in 2 places in ff_video_decoder.c to make it compile.

For me h264 decoding is still broken though.
__________________
Desktop: Asus P5B Deluxe, Core2Duo E8500, 2GB Corsair 800MHz CL4, Gigabyte GTX460 1024MB
HTPC: Asus P5B-E, Core2Duo 6300, 1GB Corsair 533MHz, Asus 9500GT w/ 512MB DDR3
Server: Gigabyte D510UD, Atom D510, 2GB Corsair 800MHz, Hauppauge NOVA-T500 dual DVB-T tuner, 4x 2TB Samsung F3EG (RAID5)
Laptop: Asus U6V, Core2Duo P8400, 3GB DDR2, 9300M GS
OS on all: Gentoo Linux

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
cthulhu is offline   Reply With Quote
Old 03-15-09, 02:03 PM   #84
Lost Dog
Registered User
 
Join Date: Aug 2007
Posts: 151
Default Re: Xine vdpau announcement

Quote:
Originally Posted by cthulhu View Post
You have to change PIX_FMT_RGBA32 to PIX_FMT_RGB32 in 2 places in ff_video_decoder.c to make it compile.

For me h264 decoding is still broken though.
Worked perfect! Thanks!!
Lost Dog is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
NVIDIA VDPAU Reference Benchmarks News Archived News Items 0 06-11-12 05:30 AM

All times are GMT -5. The time now is 02:38 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.