Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-17-09, 09:00 AM   #1
Go7300
Registered User
 
Join Date: Jun 2007
Posts: 38
Default setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

OK, I see this new option explained in the README for 185.13:

Quote:
By default, the NVIDIA GLX implementation will not expose GLX protocol for GL
commands if the protocol is not considered complete. Protocol could be
considered incomplete for a number of reasons. The implementation could still
be under development and contain known bugs, or the protocol specification
itself could be under development or going through review. If users would like
to test the client-side portion of such protocol when using indirect
rendering, they can set the __GL_ALLOW_UNOFFICIAL_PROTOCOL environment
variable to a non-zero value before starting their GLX application. When an
NVIDIA GLX server is used, the related X Config option
"AllowUnofficialGLXProtocol" will need to be set as well to enable support in
the server.
I assume this is an option to reduce the crashes of kde4 desktop effects, since they're the source of so many complaints on this forum. So, I thought I'd give it a test. It's easy enough to add the option to xorg.conf, and I can see that putting something like this on the command line to start an individual application:

__GL_ALLOW_UNOFFICIAL_PROTOCOL=1 ; googleearth

should work.

But how does one go about setting the __GL_ALLOW_UNOFFICIAL_PROTOCOL environment
variable before starting "desktop effects" on kde4? Desktop Effects are started by checking a box in the kde4 settings manager (ubuntu 9.04 alpha), not by a command line.

Any ideas?

(BTW since upgrading to 185.13, I have not yet had any problems on my Go 7300 to force me back to previous version .. as always, I do have powermizer disabled, and I know it's early yet).
Go7300 is offline   Reply With Quote
Old 03-17-09, 09:28 AM   #2
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Add
Quote:
export __GL_ALLOW_UNOFFICIAL_PROTOCOL=1
to ~/.bash_profile but I doubt that this option will fix anything KDE related.
Dragoran is offline   Reply With Quote
Old 03-17-09, 07:40 PM   #3
damentz
Registered User
 
Join Date: Jan 2009
Posts: 59
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Quote:
Originally Posted by Dragoran View Post
Add to ~/.bash_profile but I doubt that this option will fix anything KDE related.
Well that's a dumb assumption.

Quote:
If users would like
to test the client-side portion of such protocol when using indirect
rendering
, they can set the __GL_ALLOW_UNOFFICIAL_PROTOCOL environment
variable to a non-zero value before starting their GLX application
Anyway, as an attempt to add substance to this thread, I tried this out with KDE4 + desktop effects. On a clean boot into the desktop environment with no outstanding applications open, desktop compositing works. Opening windows and moving them around with translucency is slow though. Scrolling pages with desktop compositing is also slow (firefox).

Both using the option in xorg.conf and the __GL_ALLOW_UNOFFICIAL_PROTOCOL option exported in ~/.profile set to '1'. Enabling these options had no effect on performance for this.
damentz is offline   Reply With Quote
Old 03-18-09, 01:19 AM   #4
xbobmx
Registered User
 
Join Date: May 2003
Posts: 191
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Quote:
Originally Posted by Go7300 View Post
I assume this is an option to reduce the crashes of kde4 desktop effects, since they're the source of so many complaints on this forum.
I don't follow that logic, and I don't think the option will have any effect whatsoever with KDE desktop effects.

The documentation for the option says it enables experimental GLX _protocol_ (as does the name of the option). As in indirect rendering protocol. So unless you're using indirect rendering (which you probably aren't, unless you're using a remote machine), it will do absolutely nothing.
xbobmx is offline   Reply With Quote
Old 03-18-09, 04:37 AM   #5
tzp
Registered User
 
tzp's Avatar
 
Join Date: Sep 2007
Location: Hungary
Posts: 92
Wink Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Quote:
__GL_ALLOW_UNOFFICIAL_PROTOCOL=1 ; googleearth
I guess you mean to do that without the semicolon.
tzp is offline   Reply With Quote
Old 03-18-09, 05:27 AM   #6
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Quote:
Originally Posted by damentz View Post
Well that's a dumb assumption.



Anyway, as an attempt to add substance to this thread, I tried this out with KDE4 + desktop effects. On a clean boot into the desktop environment with no outstanding applications open, desktop compositing works. Opening windows and moving them around with translucency is slow though. Scrolling pages with desktop compositing is also slow (firefox).

Both using the option in xorg.conf and the __GL_ALLOW_UNOFFICIAL_PROTOCOL option exported in ~/.profile set to '1'. Enabling these options had no effect on performance for this.
You should be using direct rendering if you want performance, so no this is not a "dump assumption"
Dragoran is offline   Reply With Quote
Old 03-19-09, 09:59 AM   #7
Go7300
Registered User
 
Join Date: Jun 2007
Posts: 38
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Thanks for the feedback. I see I was wrong on my assumption.
Go7300 is offline   Reply With Quote
Old 03-19-09, 03:29 PM   #8
Thunderbird
 
Join Date: Jul 2002
Location: Netherlands, Europe
Posts: 2,105
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

The purpose of this option is not to fix kde4 desktop effect issues or so but it would help compiz / kde4 desktop effects though in cases.

In short when using a gl compositor in combination with 3d apps you use indirect rendering (unless you disable that for the app). Indirect rendering can still be accelerated but not all opengl extensions are available using indirect rendering (e.g. compare the output of glxinfo with glxinfo -i). Mainly modern opengl like glsl, FBOs and so aren't available. This option will unlock more 3d features.
Thunderbird is offline   Reply With Quote

Old 03-19-09, 03:42 PM   #9
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: setting __GL_ALLOW_UNOFFICIAL_PROTOCOL for kde4 desktop effects

Quote:
Originally Posted by Thunderbird View Post
The purpose of this option is not to fix kde4 desktop effect issues or so but it would help compiz / kde4 desktop effects though in cases.

In short when using a gl compositor in combination with 3d apps you use indirect rendering (unless you disable that for the app).
Only if you run it in indirect rendering mode (compiz --indirect-rendeirng), because else it will run in redirected direct rendering (and have access to all extensions just if it was running without a CM).
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
NVIDIA Maximus Fires Up Visual Effects In Men in Black 3 News Archived News Items 0 06-26-12 07:00 PM
CSS filter effects get GPU-accelerated in Chrome News Archived News Items 0 06-05-12 02:20 PM
OpenGL apps crashing in NVIDIA driver when switching desktop dinosaur NVIDIA Linux 0 06-01-12 08:09 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
3DNA 3d desktop prydah General Software 2 08-01-02 11:59 AM

All times are GMT -5. The time now is 07:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.