Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-19-09, 12:06 AM   #1
maaltan
Registered User
 
Join Date: Mar 2009
Posts: 5
Default working hdmi sound or completely disable it

This has been an incredibly annoying night. My old hd tv died and was replaced with a new Samsung A550. I am running mythtv and everything was working beautifully before i changed tv's. I was running hdmi with sound coming from the line out port.

Unfortunately, the new TV is too smart for its own good. Apparently the linux nvidia driver (180.29) is sending a false audio signal. This makes the TV use that instead of the line out cable. (i swear if they make things much smarter NOTHING will work)

I talked to samsung and told me they know the problem but its Nvidia's fault. I tried finding contact information on nvidia's site and they send me to Asus's site. talking to Asus is pointless since this is clearly a software/driver issue.

there appears to be a driver hotfix out for this issue... for windows.

My question is, how do i make the hdmi audio out work in linux (tried about everything already mentioned in this forum)? Or if its easier, how do i keep it from detecting the hdmi out chip so it wont send the ghost signal. I'm not looking for hi-def here. I'm also not above mutilating a hdmi cable assuming the sound channels are carried on separate wires and are not multiplexed into the video signal.

I just want to get back to where i was before this nightmare.

my machine is set up as follows:

Mythbuntu (ubuntu) 8.10
M3n78 PRO with nvidia 8300 chipset.
AMD x2 64bit 6000+
Pinnicle 800i tuner
PVR-150 tuner.
maaltan is offline   Reply With Quote
Old 03-19-09, 06:08 AM   #2
Qwerted
Registered User
 
Join Date: Mar 2009
Location: Russia
Posts: 19
Default Re: working hdmi sound or completely disable it

Try latest alsa-driver snapshot. I finally got coaxial digital out working with these drivers
__________________
Nvidia 8300 mGPU (Asus M3N78 PRO)
Debian lenny, 2.6.29.2
Qwerted is offline   Reply With Quote
Old 03-19-09, 10:00 AM   #3
davelaser
Registered User
 
Join Date: Oct 2008
Posts: 86
Default Re: working hdmi sound or completely disable it

I have a samsung plasma TV with three hdmi inputs on the back.

One of them is intended specifically for use with a pc via a dvi/hdmi adapter and so does not expect audio on that port. Of course you could also try a vga connection?

Sam
davelaser is offline   Reply With Quote
Old 03-19-09, 10:05 AM   #4
maaltan
Registered User
 
Join Date: Mar 2009
Posts: 5
Default Re: working hdmi sound or completely disable it

Quote:
Originally Posted by davelaser View Post
I have a samsung plasma TV with three hdmi inputs on the back.

One of them is intended specifically for use with a pc via a dvi/hdmi adapter and so does not expect audio on that port. Of course you could also try a vga connection?

Sam
Yeah, I am using this port (hdmi2/DVI). I contacted samsung they said it will use the hdmi audio stream if present. They also said the Nvidia card is sending a false audio stream and they were not willing to fix it on their end.

I want the audio stream gone. I tried disabling "hdmi audio" in the bios, but the driver still inserts the stream.

Also, i just tried upgrading to newest also, no luck so far.
maaltan is offline   Reply With Quote
Old 03-19-09, 01:05 PM   #5
Qwerted
Registered User
 
Join Date: Mar 2009
Location: Russia
Posts: 19
Default Re: working hdmi sound or completely disable it

Quote:
Originally Posted by maaltan View Post
Also, i just tried upgrading to newest also, no luck so far.
Show your output from
Code:
aplay -l
And even if your soundcard is recognized properly, you need to configure alsa to use hdmi audio out as default device
__________________
Nvidia 8300 mGPU (Asus M3N78 PRO)
Debian lenny, 2.6.29.2
Qwerted is offline   Reply With Quote
Old 03-19-09, 03:50 PM   #6
maaltan
Registered User
 
Join Date: Mar 2009
Posts: 5
Default Re: working hdmi sound or completely disable it

Quote:
Originally Posted by Qwerted View Post
Show your output from
Code:
aplay -l
And even if your soundcard is recognized properly, you need to configure alsa to use hdmi audio out as default device
<edit, sorry im at work so i do not have the exact strings aplay return>

I see an Nvidia something 888 digital , always have. I have added various options flags to /etc/modprobe.d/alsa-base without luck.

How would i tell alsa to use hdmi as default device?
maaltan is offline   Reply With Quote
Old 03-19-09, 07:37 PM   #7
motd2k
Registered User
 
Join Date: Jan 2009
Posts: 27
Default Re: working hdmi sound or completely disable it

Maybe using a DVI->HDMI dongle might help, just as a workaround.
motd2k is offline   Reply With Quote
Old 03-20-09, 04:00 AM   #8
Qwerted
Registered User
 
Join Date: Mar 2009
Location: Russia
Posts: 19
Default Re: working hdmi sound or completely disable it

Quote:
Originally Posted by maaltan View Post
I see an Nvidia something 888 digital , always have. I have added various options flags to /etc/modprobe.d/alsa-base without luck.
How would i tell alsa to use hdmi as default device?
what is exactly version of installed drivers? With recent Snapshot From ALSA GIT repositories your card must be shown as ALC1200 (without that it useless to configure alsa).
There was a bug with digital outputs, but it was fixed in GIT repository

And this is another bug https://bugtrack.alsa-project.org/al...ew.php?id=4281
__________________
Nvidia 8300 mGPU (Asus M3N78 PRO)
Debian lenny, 2.6.29.2
Qwerted is offline   Reply With Quote

Old 03-25-09, 09:46 PM   #9
maaltan
Registered User
 
Join Date: Mar 2009
Posts: 5
Default Re: working hdmi sound or completely disable it

Quote:
Originally Posted by Qwerted View Post
what is exactly version of installed drivers? With recent Snapshot From ALSA GIT repositories your card must be shown as ALC1200 (without that it useless to configure alsa).
There was a bug with digital outputs, but it was fixed in GIT repository

And this is another bug https://bugtrack.alsa-project.org/al...ew.php?id=4281
cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.19.
Compiled on Mar 19 2009 for kernel 2.6.27-11-generic (SMP).

I do see ALC1200 now. I got an annoying chirp to come out of speakers about ever 20 seconds while visiting www.khaaan.com (yeah annoying pointless webpage, but provides a constant sound stream at a high level (vs lower levels some programs might use for optimization.. then again i don't really know what I'm talking about here but its easy to access )

according to scraping the internet i am close to getting it to work, but i found this thread here(where i promptly stuck my foot in my mouth):
http://www.nvnews.net/vbulletin/showthread.php?t=129247

this tells you how to turn of the digital stream allowing the "smart" T to hear the analog stream. It involves downloading the ID file (essid? cant remember acronym), hacking it, forcing the nvidia driver to use that file instead of the one sent by the TV, then hard coding video modes back into the xorg.conf file. then everyone (at least me) is happy!. I don't have a high def system ready to plug into so analog sound is fine with me.

also, on a side note, if you have an issue with tinny or thin sound, make sure that its not just that your tv's speakers suck. apparently that is where alot of midrange hdtvs are skimping on quality since "most" people connect them to a surround sound system anyway. go dig an old pair of computer speakers out of your basement and it will probably sound better.

anyway thanks for everyone's help. If anyone knows what i should do to get digital audio working, that would be great, but its not a priority for me anymore.
maaltan is offline   Reply With Quote
Old 03-26-09, 03:45 AM   #10
Qwerted
Registered User
 
Join Date: Mar 2009
Location: Russia
Posts: 19
Default Re: working hdmi sound or completely disable it

does

Code:
aplay -d hw:0,3 some_wave_file.wav
works?
__________________
Nvidia 8300 mGPU (Asus M3N78 PRO)
Debian lenny, 2.6.29.2
Qwerted is offline   Reply With Quote
Old 04-04-09, 05:51 AM   #11
milomak
Registered User
 
Join Date: Apr 2009
Posts: 1
Default Re: working hdmi sound or completely disable it

Is this consistent?

Code:
mythtv-debian:~# cat /proc/asound/version
Advanced Linux Sound Architecture Driver Version 1.0.18a.
mythtv-debian:~# dpkg -l alsa* | grep ii
ii  alsa-base                            1.0.19.dfsg-2                     ALSA driver configuration files
ii  alsa-utils                           1.0.19-1                          ALSA utilities
ii  alsaplayer-alsa                      0.99.80-3                         PCM player designed for ALSA (ALSA output mo
ii  alsaplayer-common                    0.99.80-3                         PCM player designed for ALSA (common files)
ii  alsaplayer-gtk                       0.99.80-3                         PCM player designed for ALSA (GTK version)
milomak is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
IOGEAR 3D Complete+ 4-Port HDMI Switcher with 2D/3D Video Processor News Archived News Items 0 06-28-12 06:40 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-31-02 12:59 AM
nForce sound locking up system shroom NVIDIA Linux 4 09-16-02 02:50 AM

All times are GMT -5. The time now is 06:17 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.