Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-01-09, 10:27 PM   #1
alisonnic
Registered User
 
Join Date: Jan 2008
Posts: 4
Unhappy Desktop Effects/Compiz stopped working on 6800XT/Ubuntu 8.10/nVidia 177

I'm running the nVidia 177 drivers on Ubuntu 8.10 on a 6800XT.

A problem with Desktop Effects/Compiz cropped up today when I booted. I have been using "Extra" Visual Effects, four Workspaces, and Compiz special effects, but today upon booting I had only two Workspaces and Visual Effects had been reset to None.

Adding back the two Workspaces was easy but I haven't been able to get special desktop effects back.

I've tried switching Extra Visual Effects back on (by right-clicking on the desktop and choosing Change Desktop Background, then Visual Effects and clicking the Extra radio button) but this fails. I get two popups in succession. First:

Quote:
Searching for available drivers
The screen goes blank for a moment, then the desktop returns and a second popup appears with this message:

Quote:
Desktop effects could not be enabled
I've tried deactivating and then re-installing the nVidia driver (System->Administration->Hardware Drivers) but this made no difference. I'm running the NVIDIA driver version 177 and it shows as activated and currently in use.

I installed compiz-settings-manager a couple of weeks ago and enabled the cube and assorted effects with no problem. Everything worked fine.

Since then, the only thing I've changed on this machine that I can imagine might have an impact on the desktop was to install VirtualBox (first the OSE version and then the PUEL version).

I've also installed Firefox, Thunderbird, xpdf, Foxit Reader, and a printer driver since I started using compiz, but it's hard to see how any of these might be affecting the desktop's ability to detect the nVidia drivers. One other thing I did was switch from a 1024x768 monitor to a 1360x768 monitor, but Compiz and Extra Visual Effects were working fine on this (as was VirtualBox) when I last booted the machine a few days ago.

Any suggestions?

--------------

Here's my system configuration:

Asus A7N8X Deluxe
AMD Athlon XP 3000+ Barton
1 GB RAM (2x512)
EVGA GeForce 6800XT
300 GB SATA hard drive
Asus DVD burner
floppy
Thermaltake 430W
KDE monitor, 1360x768
(60 Hz in System->Administration->NVIDIA X Server Settings but
52 Hz in System->Preferences->Monitor Resolution Settings;
the monitor itself reports 60 Hz.)

Ubuntu 8.10
Kernel Linux 2.6.27-11-generic
GNOME 2.24.1
NVIDIA driver version: 177.86
X Server version Number: 11.0

-----

compiz check returns these results:
Checking for Xgl: present.
Checking for nVidia: present.
Checking for Xgl: present.
Enabling Xgl with nVidia drivers...
/usr/bin/compiz.real (core) - Fatal: Root visual is not a GL visual
/usr/bin/compiz.real (core) - Error: Failed to manage screen: 0
/usr/bin/compiz.real (core) - Fatal: No manageable screens found on display :0.0

After this, compiz check hangs and I have to hit Ctl-C and then log out and log back in to recover.

-----

An nvidia-bug-report.log is attached.

Thanks in advance for any help you can provide!
Attached Files
File Type: log nvidia-bug-report.log (108.8 KB, 111 views)
alisonnic is offline   Reply With Quote
Old 03-02-09, 11:03 AM   #2
alisonnic
Registered User
 
Join Date: Jan 2008
Posts: 4
Default Re: Desktop Effects/Compiz stopped working on 6800XT/Ubuntu 8.10/nVidia 177

I've also posted about this issue here:

http://ubuntuforums.org/showthread.p...08#post6824508

So far two people have made suggestions, which I've tried without success.
alisonnic is offline   Reply With Quote
Old 03-27-09, 06:20 PM   #3
alisonnic
Registered User
 
Join Date: Jan 2008
Posts: 4
Unhappy Re: Desktop Effects/Compiz stopped working on 6800XT/Ubuntu 8.10/nVidia 177

This problem has remained unsolved.

Regretfully, I've decided to pull the plug on my Ubuntu experiment and rebuild the machine with XP Pro. Details here:

http://ubuntuforums.org/showthread.p...25#post6968825

Thanks to everyone here who made suggestions.
alisonnic is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.