Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-28-09, 04:28 AM   #1
lillis
Registered User
 
Join Date: Mar 2009
Posts: 1
Default nvidia-driver crashes computer on X start

Hi. I've asked around a bit on freebsd.org and they thought I should ask for help here. And so that's what I'm doing.

My problem is this: X.org will not start whenever I load the drivers installed from the latest nvidia-drivers port. The error also happens with the older versions of said drivers. The error doesn't occur with the normal "nv" drivers.

What happens:

1) $ startx
2) The normal startup stuff flickers by on screen. I'm not sure exactly what it says as the screen goes black to load up X in less than a second (it always does this).
3) It then switches display mode or something like that. It goes from proper "this screen is currently not showing anything at all"-black to "this screen is on and is rendering black pixels"-black. It might sound strange but I can't describe it any better. The black gets a different hue which isn't displayed when I start X with the default nv drivers.
4) Everything just locks up. The "new black" stays. I can't switch to another terminal with CTRL+ALT+F#, I can-t CTRL+ALT+BACKSPACE nor CTRL+ALT+DELETE. I was playing music with the CLI player "herrie" once and it repeated the same millisecond of sound over and over and over. A proper lock-up.
5) I hit the reboot button.

Now the bad thing is that I can't find any logs of what happens. I removed Xorg.0.log and Xorg.0.log.old before running startx once and no log is produced as far as I can see. "messages" show nothing in particular, same with the "all.log" that I set up - unless I'm missing something very obvious, but I don't really think so. The only log I find is the one created on /var/log/Xorg.0.log when I run X -configure. There is no log created when I run startx. The X -configure log looks like this:

Quote:

X.Org X Server 1.5.3
Release Date: 5 November 2008
X Protocol Version 11, Revision 0
Build Operating System: FreeBSD 7.1-RELEASE i386
Current Operating System: FreeBSD sino.plas.se 7.1-RELEASE FreeBSD 7.1-RELEASE #0: Thu Jan 1 14:37:25 UTC 2009 root@logan.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
Build Date: 27 March 2009 01:00:57AM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Mar 28 09:46:07 2009
(II) Loader magic: 0x81bcde0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 4.1
X.Org XInput driver : 2.1
X.Org Server Extension : 1.1
X.Org Font Renderer : 0.6
(II) Loader running on freebsd
(--) Using syscons driver with X support (version 2.0)
(--) using VT number 9

(--) PCI:*(0@1:0:0) nVidia Corporation GeForce 8800 GTS 512 rev 162, Mem @ 0xfd000000/0, 0xd0000000/0, 0xfa000000/0, I/O @ 0x0000bc00/0, BIOS @ 0x????????/131072
List of video drivers:
nvidia
(II) LoadModule: "nvidia"

(II) Loading /usr/local/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) System resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) Primary Device is: PCI 01@00:00:0
(II) NVIDIA dlloader X Driver 180.29 Tue Feb 3 10:12:46 PST 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs

(++) Using config file: "/home/lillis/xorg.conf.new"
(==) ServerLayout "X.org Configured"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Card0"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(==) Automatically adding devices
(==) Automatically enabling devices
(==) Including the default font path /usr/local/lib/X11/fonts/misc/,/usr/local/lib/X11/fonts/TTF/,/usr/local/lib/X11/fonts/OTF,/usr/local/lib/X11/fonts/Type1/,/usr/local/lib/X11/fonts/100dpi/,/usr/local/lib/X11/fonts/75dpi/.
(**) FontPath set to:
/usr/local/lib/X11/fonts/misc/,
/usr/local/lib/X11/fonts/TTF/,
/usr/local/lib/X11/fonts/OTF,
/usr/local/lib/X11/fonts/Type1/,
/usr/local/lib/X11/fonts/100dpi/,
/usr/local/lib/X11/fonts/75dpi/,
/usr/local/lib/X11/fonts/misc/,
/usr/local/lib/X11/fonts/TTF/,
/usr/local/lib/X11/fonts/OTF,
/usr/local/lib/X11/fonts/Type1/,
/usr/local/lib/X11/fonts/100dpi/,
/usr/local/lib/X11/fonts/75dpi/
(**) ModulePath set to "/usr/local/lib/xorg/modules"
(WW) AllowEmptyInput is on, devices using drivers 'kbd' or 'mouse' will be disabled.
(WW) Disabling Mouse0
(WW) Disabling Keyboard0
(II) Loading sub module "fb"
(II) LoadModule: "fb"

(II) Loading /usr/local/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.5.3, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"

(II) Loading /usr/local/lib/xorg/modules//libwfb.so
(II) Module wfb: vendor="X.Org Foundation"
compiled for 1.5.3, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.4
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Module "ramdac" already built-in
(II) resource ranges after probing:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]


Xorg detected your mouse at device /dev/sysmouse.
Please check your config if the mouse is still not
operational, as by default Xorg tries to autodetect
the protocol.

Your xorg.conf file is /home/lillis/xorg.conf.new

To test the server, run 'X -config /home/lillis/xorg.conf.new'
uname-a output:
Quote:
FreeBSD sino.######### 7.1-RELEASE FreeBSD 7.1-RELEASE #0: Thu Jan 1 14:37:25 UTC 2009 root@logan.cse.buffalo.edu:/usr/obj/usr/src/sys/GENERIC i386
And this is the relevant (?) output from dmesg.boot:

Quote:
nvidia0: <GeForce 8800 GTS 512> on vgapci0
vgapci0: child nvidia0 requested pci_enable_busmaster
vgapci0: child nvidia0 requested pci_enable_io
vgapci0: child nvidia0 requested pci_enable_io
nvidia0: [GIANT-LOCKED]
nvidia0: [ITHREAD]
I have tried reinstalling xorg-server and nvidia-driver many times. I've also had the same problem on a completely different FreeBSD install on the same computer, before a broken HDD forced me to reinstall completely. It was the same version.

I've made sure that the driver is actually loaded with kldstat, and have not used "kldload nvidia" as it's said that it's best to put an entry in /boot/loader.conf and restart instead. This is what I have done.

/dev/nvidia0 and /dev/nvidiactl show up after the drivers are installed and the computer rebooted.

My card is an nVidia GeForce 8800 GTS 512 MB, and is supported by the drivers.

xorg.conf:
Quote:
Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/local/lib/xorg/modules"
FontPath "/usr/local/lib/X11/fonts/misc/"
FontPath "/usr/local/lib/X11/fonts/TTF/"
FontPath "/usr/local/lib/X11/fonts/OTF"
FontPath "/usr/local/lib/X11/fonts/Type1/"
FontPath "/usr/local/lib/X11/fonts/100dpi/"
FontPath "/usr/local/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "extmod"
Load "record"
Load "dbe"
Load "glx"
Load "xtrap"
Load "dri"
Load "freetype"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/sysmouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GeForce 8800 GTS 512"
BusID "PCI:1:0:0"
Option "NvAGP" "1"
EndSection


Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
This xorg.conf was generated with X -configure after having installed nvidia-drivers. I added the Option "NvAGP" "1" part manually to try NvAGP (after having disabled FreeBSD AGP at boot and also reinstalled the port without the FreeBSD agp option). This didn't change a thing unfortunately.

My guess is that there's something conflicting with the nvidia drivers in my system that's on by default. Unfortunately I have no idea what this could be. If I have failed to include any relevant info, please let me know and I'll see what I can do.

Thanks for reading (and hopefully helping!).

Related threads:
http://forums.freebsd.org/showthread.php?t=2666
http://forums.pcbsd.org/viewtopic.php?f=25&t=13185
http://forums.pcbsd.org/viewtopic.ph...=10019&p=64357
http://forums.freebsd.org/showthread.php?p=18046
lillis is offline   Reply With Quote
Old 03-28-09, 08:24 AM   #2
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: nvidia-driver crashes computer on X start

This sounds like you are running more than 2GB of memory as that is the same symptoms I got with that much memory. I never got to test that, but the suggestion is adding this to /boot/loader.conf

machdep.disable_mtrrs=1

Reboot and then try to launch X. Or of course, you can do like I did and just reduce your memory.

Sincerely,
Rusty Nejdl
rnejdl is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia driver quality decrease? legluondunet NVIDIA Linux 17 06-26-12 10:03 AM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 08:35 PM
Getting the proprietary nvidia driver to run with Debian 3.0 r0 (woody) Katchina404 NVIDIA Linux 9 01-12-03 08:49 AM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-01-02 11:58 PM
NVIDIA 3123 driver on SuSE 8.0 Ok , but slow to start X Gabolander NVIDIA Linux 3 09-27-02 07:41 AM

All times are GMT -5. The time now is 10:19 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.