Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-29-09, 12:58 PM   #25
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Hi

I've compiled SVN# 290095 for Ubuntu 8.10 and 8.04.

Also includes an updated version of libx264.

Compiled with VDPAU and ASS support.

Result of configure:
Enabled optional drivers:
Input: dvdnav(internal) ftp pvr radio tv-teletext tv-v4l2 tv-v4l tv live555 cddb cdda dvdread(internal) vcd dvb smb network
Codecs: libschroedinger libdirac x264 xvid libdv libamr_wb libamr_nb libavcodec(internal) qtx real xanim win32 faad2(internal) faac musepack libdca libmpeg2(internal) liba52(internal) mp3lib(internal) libtheora speex libvorbis twolame libmad liblzo gif
Audio output: alsa openal jack pulse nas esd arts oss v4l2 sdl mpegpes(dvb)
Video output: v4l2 dxr3 sdl gif89a pnm jpeg png mpegpes(dvb) fbdev svga caca aa ggi xmga mga xvidix cvidix opengl 3dfx dga vdpau xvmc xv x11 xover dfbmga directfb yuv4mpeg md5sum tga tdfxfb

Disabled optional drivers:
Input: vstream tv-dshow nemesi libdvdcss(internal)
Codecs: toolame
Audio output: sun ivtv dxr2
Video output: zr zr2 ivtv dxr2 vesa winvidix bl xvr100 tdfx_vid wii s3fb

To use my repo:
http://www.avenard.org/media/Ubuntu_...epository.html
jyavenard is offline   Reply With Quote
Old 03-29-09, 04:41 PM   #26
Duran
Registered User
 
Join Date: Nov 2008
Posts: 28
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

why exactly is the 'mencoder' disabled?
Duran is offline   Reply With Quote
Old 03-29-09, 06:30 PM   #27
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Quote:
Originally Posted by Duran View Post
why exactly is the 'mencoder' disabled?
At a guess: the x264 package that comes with Ubuntu is too old and won't compile with newer version of mplayer/ffmpeg.

disabling mencoder prevents using x264.

doing --disable-x264 would have achieved the same thing and you could include mencoder
jyavenard is offline   Reply With Quote
Old 03-29-09, 06:48 PM   #28
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

My builds of mplayer on Ubuntu Jaunty with x264 and mencoder have worked fine...
thefirstm is offline   Reply With Quote
Old 06-03-09, 06:30 AM   #29
Cletus
Registered User
 
Join Date: Jun 2009
Posts: 3
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Nice work, thanks.

I just tried it, and yes: The CPU load is very low.

But I got bad images: While action scenes are shown, the image sometimes seems to be cutted, like interlace (with only one line)...

Do you have the same problem?
Cletus is offline   Reply With Quote
Old 06-03-09, 06:45 AM   #30
Cletus
Registered User
 
Join Date: Jun 2009
Posts: 3
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Quote:
Originally Posted by Cletus View Post
But I got bad images: While action scenes are shown, the image sometimes seems to be cutted, like interlace (with only one line)...
Adding

Quote:
Section "Extensions"
Option "Composite" "Disable"
EndSection
to xorg.conf helped...
Cletus is offline   Reply With Quote
Old 06-03-09, 10:23 AM   #31
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Cletus, please try the 185.* drivers; they should fix this tearing issue.
Stephen Warren is offline   Reply With Quote
Old 06-03-09, 10:32 AM   #32
Cletus
Registered User
 
Join Date: Jun 2009
Posts: 3
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Quote:
Originally Posted by Stephen Warren View Post
Cletus, please try the 185.* drivers; they should fix this tearing issue.
Ah, ok.

But I'll wait until 185 is added to the ubuntu repos.

With the section in my xorg.conf, the error is fixed anyway, so it's perfect.

Thanks for your work!
Cletus is offline   Reply With Quote

Old 06-03-09, 10:37 AM   #33
biasquez
Registered User
 
Join Date: Mar 2009
Posts: 15
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

i'm using 185.* but i have this issue (tearing) watching video with mplayer and vdpau. with vlc all works fine.
biasquez is offline   Reply With Quote
Old 06-03-09, 11:27 AM   #34
dk75
Registered User
 
Join Date: Jan 2009
Posts: 171
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Quote:
Originally Posted by Cletus View Post
Ah, ok.
But I'll wait until 185 is added to the ubuntu repos.
With the section in my xorg.conf, the error is fixed anyway, so it's perfect.
Thanks for your work!
You will wait to Ubuntu 9.10 then due to version release lock policy of Ubuntu developers, unless you use unofficial repository from http://www.avenard.org/files/ubuntu-repos/ but still, there are only stable releases ( 180 series now )
__________________
  • Linux Debian Sid x86_64/ 3.2.0
  • Lenovo T61p
  • NVIDIA driver 295.33
  • Xorg/XServer 7.6+12/1.11.4
  • GNOME 3.2.2
dk75 is offline   Reply With Quote
Old 06-03-09, 07:55 PM   #35
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Quote:
Originally Posted by dk75 View Post
You will wait to Ubuntu 9.10 then due to version release lock policy of Ubuntu developers, unless you use unofficial repository from http://www.avenard.org/files/ubuntu-repos/ but still, there are only stable releases ( 180 series now )
If you use my testing repository; I have mythtv and mplayer build against nvidia 185.18.14 as well as the nvidia drivers ...

Instructions on how to upgrade from 180.x to 185.x
http://www.avenard.org/media/Ubuntu_...185.18.14.html

I've seen tearing issues with 185.x
jyavenard is offline   Reply With Quote
Old 06-04-09, 11:53 AM   #36
Lemmiwinks
Registered User
 
Join Date: Apr 2009
Location: Germany
Posts: 75
Default Re: HOTWO: compile mplayer with VDPAU under Ubuntu (x86 or x86_64)

Has anyone else tested the mplayer packages from
http://ppa.launchpad.net/rvm/mplayer...ain/m/mplayer/ ??

I'm not sure whether vdpau really works as supposed to with this svn as I have got pretty high cpu usage, about 20-25% with an 1920x1200px video file.

Code:
andy@andy-laptop:~$ mplayer -vo vdpau -vc ffwmv3vdpau /home/andy/Desktop/Alexander_Trailer_1080p.wmv
MPlayer SVN-r29139-4.3.3 (C) 2000-2009 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing /home/andy/Desktop/Alexander_Trailer_1080p.wmv.
ASF file format detected.
[asfheader] Audio stream found, -aid 1
[asfheader] Video stream found, -vid 2
VIDEO:  [WMV3]  1920x1080  24bpp  1000.000 fps  9600.0 kbps (1171.9 kbyte/s)
==========================================================================
Forced video codec: ffwmv3vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] Trying pixfmt=0.
VDec: vo config request - 1920 x 1080 (preferred colorspace: WMV3 VDPAU acceleration)
VDec: using WMV3 VDPAU acceleration as output csp (no 0)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1920x1080 => 1920x1080 WMV3 VDPAU acceleration 
[ASPECT] Warning: No suitable new res found!
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffwmv3vdpau] vfm: ffmpeg (FFmpeg WMV3/WMV9 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [dmo] Win32/DMO decoders
AUDIO: 48000 Hz, 2 ch, s16le, 440.0 kbit/28.65% (ratio: 55002->192000)
Selected audio codec: [wma9dmo] afm: dmo (Windows Media Audio 9 DMO)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
A: 122.9 V: 123.2 A-V: -0.329 ct:  0.324 2358/2358 28%  2%  8.1% 3 0 

Exiting... (End of file)
Driver is 185.18.14 on GF8600m GT, Mobile Core 2 Duo @ 1.8 GHz
Lemmiwinks is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.