Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-04-09, 01:22 AM   #1
Ux64
Registered User
 
Ux64's Avatar
 
Join Date: Aug 2008
Posts: 11
Default [Solved] Nvidia 8500 secondary screen tearing

Hi!

I have been writing about this topic earlier.

So if there is thread which provides fix, please let me know. We have been unable to find it. And we have also tried X.org, displaydriver and VLC (and other players) to solve the problem unsuccessfully.

I'm wishing that someone with real driver experience would take a look, replicate the problem and fix it.

- Thank you

-- It finally started to work --

Hey! I did attack this problem once more as "final try". And I did get it to work.

So I did reset xorg.conf, deleted all nvidia related settings, deleted all VNC settings . Uninstalled and reinstall driver 180.44 and updated VLC to 1.0 pre-release. And guess what, now it's working.

Reason for my problem might have been some "legacy payload" from way old Ubuntu versions, I haven't instlalled from scratch for three years. I also tried as start multiple different X configurations and I had to fight with VNC to get full screen mode working at all on secondary screen. So there might have been multiple overlapping reasons why it didn't work out and some misconfiguration. It's normal that when you try to fix something by trying everything, you'll probably end up just messing up your system more.

So if you're suffering from same problem with VLC I can tell you that now it's working with 8500gt after all. I'm also using realtime priority for VLC. But I haven't tried if that option really plays any significant role with this case.

- Thank you!

P.S. Also full hd x264 1080p stuff is running nicely on both screens simultaneously.

Last edited by Ux64; 05-03-09 at 03:45 AM.
Ux64 is offline   Reply With Quote
Old 04-04-09, 09:35 AM   #2
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: Nvidia 8500 secondary screen tearing

For starters you need to read the forums on how to post a bug report. Now if what you are referring to as a "bug" is tearing on a second monitor (whereas the other works fine), then this is not a bug in the NVIDIA driver, but a limitation of X.org itself.

In `nvidia-settings`, Go to "X Server XVideo Settings", and at the bottom you will see both your monitors and an option to "Sync to this display device". Simply sync to the monitor you are watching. You can only sync on one screen at a time. If both your monitors have the same refresh rate you shouldnt see tearing on either.
Big P is offline   Reply With Quote
Old 04-07-09, 01:48 AM   #3
Ux64
Registered User
 
Ux64's Avatar
 
Join Date: Aug 2008
Posts: 11
Default Re: Nvidia 8500 secondary screen tearing

Quote:
Originally Posted by Big P View Post
Simply sync to the monitor you are watching. You can only sync on one screen at a time. If both your monitors have the same refresh rate you shouldnt see tearing on either.
But you're first one to state it CLEARLY. Nobody else has mentioned those key restrictions. I'll try your suggestion. And if it helps, thank you so much.

First I'll try modifying refreshrates and test secondary screen only sync. Now I have both screen checked. At least driver allows me to do that. Clearly with arbitary results.

Screenshots my previous config. So I had same refresh rate for both screens and I did still experience tearing, but only on secondary screen. Now I have disabled sync for primary screen and only secondary screen is synced. I'll try that.

But old config:


I think I'll try OpenGL also with these new settings, if it would help.
Ux64 is offline   Reply With Quote
Old 05-01-09, 09:43 AM   #4
Ux64
Registered User
 
Ux64's Avatar
 
Join Date: Aug 2008
Posts: 11
Default Re: Nvidia 8500 secondary screen tearing

Just reporting that I updated to Jaunty hoping it would fix this issue. Now I'm using VLC 0.9.4, Nvidia driver 180.44 and Ubuntu 9.04 64bit. But no luck yet. Tearing is still big issue on secondary screen. Not with main screen. And yes, I still have vblack sync enabled for both screens and both screens are using same refresh rate.

As far as I know, anyone hasn't managed yet to get this to work properly. I have been googling a lot, and I haven't seen any success reports. But multiple problem reports.

It seems that it's just better to get used to tearing. It's not a major issue, but it's still very annoying.
Ux64 is offline   Reply With Quote
Old 05-01-09, 10:08 AM   #5
Big P
Registered User
 
Join Date: Dec 2004
Posts: 180
Default Re: Nvidia 8500 secondary screen tearing

You still haven't posted a bug report, so you are severely limiting the amount of information anyone can gather about your system.

Is there a reason why you are not using twinview, and instead are using separate X screens? With twinview you are given the option of *only* syncing to one monitor at a time. Also when I said the refresh rate needs to be the same on both screens, I mean exactly the same. This is usually best with two identical monitors.

Try twinview and sync to only your TV, and report back.
Big P is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
[9800gt] Xorg black screen after installing nvidia driver HacKurx NVIDIA Linux 1 06-07-12 02:29 PM
Need Help Installing NVIDIA Tesla M2070Q in Linux RHEL5 Ferianto85 NVIDIA Linux 0 05-18-12 09:35 PM
nvidia + 2.4.19 gentoo = messed up ulukay NVIDIA Linux 18 11-02-02 12:58 AM

All times are GMT -5. The time now is 10:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.