Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-07-09, 12:43 PM   #1
mdoerner
Registered User
 
mdoerner's Avatar
 
Join Date: Sep 2008
Posts: 62
Default 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Hi All,

New issue. Since 185.19 does not work with BOINC due to CUDA issues, I had to re-install 180.44. Now video playback (all formats - mpeg, wmv, avi, etc.) only plays audio, no video. Re-installing 185.19 brings back the video playback, but screws up CUDA for BOINC. I'm assuming something was set in the 185.19 that is not being un-set in the 180.44 re-install. Here's the bug report for 180.44.

Mike Doerner
Attached Files
File Type: gz nvidia-bug-report-180.44.log.gz (30.2 KB, 62 views)
mdoerner is offline   Reply With Quote
Old 04-07-09, 12:47 PM   #2
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

What application are you using to play back video? What command-line are you using?
Stephen Warren is offline   Reply With Quote
Old 04-07-09, 12:51 PM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Oh, and please provide any error messages or log files produced by your application. Thanks.
Stephen Warren is offline   Reply With Quote
Old 04-07-09, 01:30 PM   #4
ppurka
Registered User
 
Join Date: May 2005
Posts: 39
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Just noticed the same thing on my machine. This is a T61, with NVS 140m graphics card. I downgraded from 185.19 to 180.44.

I tried x11, gl and xv. x11 and gl (as well as gl2) work properly. xv doesn't work,- I get a black video window.
The mplayer logs are produced by:
Code:
mplayer -msglevel all=9 -vo <xv|x11|gl>
Also my ~/.mplayer/config:
Code:
ao = alsa,oss
vo = xv
softvol = "yes"
font = "DejaVu Sans Mono"
hue = 0
Attached Files
File Type: bz2 nvidia-bug-report.log.bz2 (25.9 KB, 63 views)
File Type: bz2 mplayer_logs.tar.bz2 (10.1 KB, 56 views)
ppurka is offline   Reply With Quote
Old 04-07-09, 01:33 PM   #5
ppurka
Registered User
 
Join Date: May 2005
Posts: 39
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Output of xvinfo with the 180.44 driver:
Code:
X-Video Extension version 2.2
screen #0
  Adaptor #0: "NV17 Video Texture"
    number of ports: 32
    port base: 280
    operations supported: PutImage 
    supported visuals:
      depth 24, visualID 0x21
      depth 24, visualID 0x24
      depth 24, visualID 0x25
      depth 24, visualID 0x26
      depth 24, visualID 0x27
      depth 24, visualID 0x28
      depth 24, visualID 0x29
      depth 24, visualID 0x2a
      depth 24, visualID 0x2b
      depth 24, visualID 0x2c
      depth 24, visualID 0x2d
      depth 24, visualID 0x2e
      depth 24, visualID 0x2f
      depth 24, visualID 0x30
      depth 24, visualID 0x31
      depth 24, visualID 0x32
      depth 24, visualID 0x33
      depth 24, visualID 0x34
      depth 24, visualID 0x35
      depth 24, visualID 0x36
      depth 24, visualID 0x37
      depth 24, visualID 0x38
      depth 24, visualID 0x39
      depth 24, visualID 0x3a
      depth 24, visualID 0x3b
      depth 24, visualID 0x3c
      depth 24, visualID 0x3d
      depth 24, visualID 0x3e
      depth 24, visualID 0x22
      depth 24, visualID 0x3f
      depth 24, visualID 0x40
      depth 24, visualID 0x41
      depth 24, visualID 0x42
      depth 24, visualID 0x43
      depth 24, visualID 0x44
      depth 24, visualID 0x45
      depth 24, visualID 0x46
      depth 24, visualID 0x47
      depth 24, visualID 0x48
      depth 24, visualID 0x49
      depth 24, visualID 0x4a
      depth 24, visualID 0x4b
      depth 24, visualID 0x4c
      depth 24, visualID 0x4d
      depth 24, visualID 0x4e
      depth 24, visualID 0x4f
      depth 24, visualID 0x50
      depth 24, visualID 0x51
      depth 24, visualID 0x52
      depth 24, visualID 0x53
      depth 24, visualID 0x54
      depth 24, visualID 0x55
      depth 24, visualID 0x56
      depth 24, visualID 0x57
      depth 24, visualID 0x58
      depth 24, visualID 0x59
    number of attributes: 7
      "XV_SET_DEFAULTS" (range 0 to 0)
              client settable attribute
      "XV_ITURBT_709" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SYNC_TO_VBLANK" (range 0 to 1)
              client settable attribute
              client gettable attribute (current value is 1)
      "XV_BRIGHTNESS" (range -512 to 511)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_CONTRAST" (range 0 to 8191)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_SATURATION" (range 0 to 8191)
              client settable attribute
              client gettable attribute (current value is 0)
      "XV_HUE" (range 0 to 360)
              client settable attribute
              client gettable attribute (current value is 0)
    maximum XvImage size: 2046 x 2046
    Number of image formats: 4
      id: 0x32595559 (YUY2)
        guid: 59555932-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x32315659 (YV12)
        guid: 59563132-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
      id: 0x59565955 (UYVY)
        guid: 55595659-0000-0010-8000-00aa00389b71
        bits per pixel: 16
        number of planes: 1
        type: YUV (packed)
      id: 0x30323449 (I420)
        guid: 49343230-0000-0010-8000-00aa00389b71
        bits per pixel: 12
        number of planes: 3
        type: YUV (planar)
ppurka is offline   Reply With Quote
Old 04-07-09, 02:03 PM   #6
razor1394
Random user
 
razor1394's Avatar
 
Join Date: Mar 2006
Posts: 13
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

My 9500GT and XBMC seems to run better with 185.19 than with 185.13. There is still tearing but not as much as before. Picture quality also seems to be equivalent with Windows and MPC HC. Maybe this could be because I'm watching different videos, maybe not. xbmc.bin cpu usage seems to be better as well.
razor1394 is offline   Reply With Quote
Old 04-07-09, 02:50 PM   #7
mdoerner
Registered User
 
mdoerner's Avatar
 
Join Date: Sep 2008
Posts: 62
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Quote:
Originally Posted by Stephen Warren View Post
What application are you using to play back video? What command-line are you using?
I'm using mplayer and Kaffeine both downloaded from the Packman site (http://packman.links2linux.org/) on Suse 11.1 and KDE 4.2.2 release 111. I'm a Linux lightweight so I use the GUI....;-)

Mike Doerner
mdoerner is offline   Reply With Quote
Old 04-07-09, 02:51 PM   #8
mdoerner
Registered User
 
mdoerner's Avatar
 
Join Date: Sep 2008
Posts: 62
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Quote:
Originally Posted by Stephen Warren View Post
Oh, and please provide any error messages or log files produced by your application. Thanks.
No error messages, just a black screen with audio. No video.

Mike Doerner
mdoerner is offline   Reply With Quote

Old 04-07-09, 03:32 PM   #9
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

mdoerner,

Are you using VDPAU output, or Xv? (ppurka who reports the same issue is using Xv).

Can you try adjusting the brightness/contrast/saturation/hue settings in your video application? Alternatively, do this using nvidia-settings after your video player application has started running.
Stephen Warren is offline   Reply With Quote
Old 04-07-09, 03:40 PM   #10
Kirurgs
Registered User
 
Join Date: Jul 2007
Posts: 165
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

Hi,

I had the same issue with 180.44, after of couple of days usage I open mplayer with vo=xv and I get either B&W picture or blank screen with audio, I downgraded to 180.29 and everything worked...
Now I'm on 185.19, I hope there will be no such problem... In case it will appear, I'll post the logs...
However I remember to try CLI method after I got black screen and I saw nothing strange out of mplayer. Kinda weird...
__________________
** Laptop T500: C2D 2.53Ghz, 4Gb RAM, Radeon Mobility HD3650, ArchLinux x86_64, Gnome, custom 2.6.35.7, Catalyst 10.10...
** Homebrew router/media server: Intel Celeron 1.2GHz 256Mb RAM, Intel Integrated Video, ArchLinux i686, no GUI, 2.6.33.4
** Homebrew desktop: AMD Phenom X4 9950 Black Edition, 4Gb RAM, integrated Radeon HD3300 + discrete Radeon 4850 512M, Windows 7 Ultimate (for games), ArchLinux i686, Gnome, 2.6.29, catalyst 9.4... (this now just rocks in lunix, really! )
Kirurgs is offline   Reply With Quote
Old 04-07-09, 03:43 PM   #11
karolbe
Registered User
 
Join Date: Dec 2007
Posts: 18
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

I had the same issue with 180.44, in case of mplayer only -vo gl or gl2 worked and xv resulted with black screen (the same totem), vlc just crashed when selected opengl output instead of xv/x11. Now I have the latest beta (185.19) and video is fine again.

I can install 180.44 version again if you want proper bug report.
karolbe is offline   Reply With Quote
Old 04-07-09, 04:12 PM   #12
G3R
Registered User
 
Join Date: May 2008
Posts: 5
Default Re: 185.19 to 180.44 screwes up WMV, AVI, MPG video playback....

I had a similar problem, try opening nvidia-settings select "X Server XVideo Settings" and click on "Reset Hardware Defaults"
G3R is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
can i only use TV for video playback gulo NVIDIA Windows Graphics Drivers 4 09-13-05 05:21 PM

All times are GMT -5. The time now is 09:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.