Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-08-09, 03:47 AM   #25
opiz
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Maybe you are right regarding the DDR3 theory.

My ASUS 8600GT 512MB uses DDR3 and works fine.
My Gainward 9500GT 512MB uses DDR2 and does not work.

I have also tried the driver version 185.19 with no luck.

Can it really be that the linux drivers does not support VDPAU correct on the DDR2 based 9500GT cards?
opiz is offline   Reply With Quote
Old 04-08-09, 11:29 AM   #26
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

opiz,

Cards with DDR2 should be supported as far as I know.

Can you try a couple of things:

1) Before running either XBMC or xine, please run the following command in the same shell:

Code:
export VDPAU_NVIDIA_DEBUG=3
That might produce some extra useful information for us.

2) For the xine case, I assume you're using the overlay presentation queue by default. Can you please test the blit-based presentation queue, by running the following command before xine, in the same shell:

Code:
export VDPAU_NVIDIA_NO_OVERLAY=1
Thanks.
Stephen Warren is offline   Reply With Quote
Old 04-08-09, 02:12 PM   #27
opiz
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

XBMC hangs after line 07 below, but this is the relevant lines before this happens.
I am trying to play a H.264 sample.
---------------------
VDPAU nvidia: Error detected 0 2440
VDPAU nvidia: Backtrace:
01: /usr/lib/libvdpau_nvidia.so [0xb24a431e]
02: /usr/lib/libvdpau_nvidia.so [0xb24a43e9]
03: /usr/lib/libvdpau_nvidia.so [0xb24abf13]
04: ./xbmc.bin(_ZN6CVDPAU21SpewHardwareAvailableEv+0xa3) [0x85d7be3]
05: ./xbmc.bin(_ZN6CVDPAU11ConfigVDPAUEP14AVCodecContext i+0x25e) [0x85d7e9e]
06: ./xbmc.bin(_ZN6CVDPAU11FFDrawSliceEP14AVCodecContext PK7AVFramePiiii+0xcb) [0x85d86eb]
07: /home/arj/htpc/xbmc/vdpau/xbmc-vdpau/xbmc-vdpau/XBMC/system/players/dvdplayer/avcodec-52-i486-linux.so(ff_draw_horiz_band+0xe4) [0xae048094]

------------------------------
xine-log attached (I am not sure that it helps)

Thank you for looking at this!!!
Attached Files
File Type: txt xine.log.9500gt_VDPAU_NVIDIA_NO_OVERLAY.txt (26.5 KB, 125 views)
opiz is offline   Reply With Quote
Old 04-08-09, 03:20 PM   #28
Teme
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Quote:
Originally Posted by yumcimil View Post
I'm encountering similar difficulties with a 9500GT (Palit, DDR2 512MB) under XBMC on Ubuntu 8.10.
I just registered to let you know that I think I'm experiencing the same problem.
I also have Palit 9500GT 512MB DDR2 and never got VDPAU working. I've tried XBMC (many builds) with Ubuntu 8.04 and 8.10 using 185.13 drivers.

Basically XBMC just freezes when I try to start any h264 encoded video with VDPAU enabled. Sometimes I get some "blocks" on screen though, but no video/audio. The videos play fine using software decoding.

I'm not very familiar with Linux, so I don't know if I'm able to provide any crash logs etc.

But it would be nice to know if anyone with 9500GT DDR2 has had any success with VDPAU.
Teme is offline   Reply With Quote
Old 04-08-09, 04:35 PM   #29
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Quote:
Originally Posted by opiz View Post
XBMC hangs after line 07 below, but this is the relevant lines before this happens.
I am trying to play a H.264 sample.
This error implies that XBMC is supplying an invalid or unsupported decoder profile value to VDPAU. Are you 100% sure that you used the same xbmc binary (and libraries and plugins and X configuration) and the exact same test file when testing xbmc on the two different cards?

The xine log doesn't really show anything. It doesn't look like it's a VDPAU issue.
Stephen Warren is offline   Reply With Quote
Old 04-08-09, 04:58 PM   #30
opiz
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

My fault, sorry for that!
I rebooted the box as I became unsure of the status when I did my previous test.
The log below is from a clean boot and then running XBMC and it seems to say a bit more.

In my first post with the logs for 8600GT and 9500GT I am sure that nothing else but the card was changed.
Attached Files
File Type: txt xbmc_bug_report_01.txt (26.7 KB, 126 views)
opiz is offline   Reply With Quote
Old 04-08-09, 05:04 PM   #31
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Teme,

Can you please do the following:

In a command-shell/terminal, type:

export VDPAU_NVIDIA_DEBUG=3
xbmc

Now, reproduce your XBMC issue, and quit the application. Cut and paste everything that was output to the command shell into a file, and attach it here.

Also, please run the following command as root, and attach the resulting file here.

nvidia-bug-report.sh

You can either use sudo:

sudo nvidia-bug-report.sh

or use "su -" to change to root, then run the command.

Thanks.
Stephen Warren is offline   Reply With Quote
Old 04-08-09, 05:06 PM   #32
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

opiz,
Your issue is very similar to the issues I've aggregated into this thread:
http://www.nvnews.net/vbulletin/showthread.php?t=130690
It's not exactly the same, but very similar. I'll post any updates there.
Stephen Warren is offline   Reply With Quote

Old 04-10-09, 10:41 AM   #33
Teme
Registered User
 
Join Date: Apr 2009
Posts: 4
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Ok, thanks Stephen.

Here are the logs you asked. I had problems uploading the crash-log, maybe it was too big. I managed to attach it zipped.
Attached Files
File Type: log nvidia-bug-report.log (125.7 KB, 78 views)
File Type: zip crashlog.zip (2.9 KB, 84 views)
Teme is offline   Reply With Quote
Old 04-10-09, 11:01 AM   #34
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: vdpau fails - 180.37 - MPlayer SVN-r28942-4.3.3

Teme, You have exactly the same issue as opiz. Please see the link in my previous post for any status updates. Thanks.
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:30 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.