Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-18-03, 01:46 PM   #1
vlurk
Registered User
 
Join Date: Sep 2003
Posts: 1
Default How do I...

I successfully compiled the kernel module for my nvidia, but cannot seem to successfully startx while using it. I tried the noapic solution but the computer still lock-up while loading XFree86. All I get is a black screen. But I think I know why: at boot time my kernel use and configure vesafb. And using to different driver for the same device should be avoided, right?

How do I tell the kernel to forget about vesafb (to not enable that frame buffer device) and load nvidia fb driver instead? I compiled my kernel (2.4.22) with vesafb not being a module...

I tried to gather some info from tldp but got no luck, yet...
vlurk is offline   Reply With Quote
Old 09-18-03, 02:55 PM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default

Change your boot loader configuration to pass video=vesa:off vga=normal to the kernel.
zander is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.