Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-13-03, 08:33 AM   #1
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Question Newbie prob with GeF4 & suse 8.2

Hi, you're help would be much appreciated.
My computer is

AMD Athlon XP 1800
Asrock K7S8X
Geforce 4 MX440 8x
Geforce driver for IA32 "NVIDIA-Linux-x86-1.0-4496-pkg2.run
Suse 8.2 personal edition

can't work out my video bios revision-no /nvidia/ in proc/driver/
I've attached xfree86.0.log and XF86Config

The problem is, i've installed the drivers but open GL programs just close. When I try to enable the openGL/3d acceleration, the screen goes blank.

What am i doing wrong?!
Thanks,
Billythekidgoat
Attached Files
File Type: txt xf86config.txt (4.6 KB, 200 views)
billythekidgoat is offline   Reply With Quote
Old 09-13-03, 08:36 AM   #2
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Default

don't know how to attach to attachments, so here's the second!
Attached Files
File Type: log xfree86.0.log (31.0 KB, 168 views)
billythekidgoat is offline   Reply With Quote
Old 09-14-03, 02:12 PM   #3
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

Just read the FAQ (README from nvidia)
answer to your question is here
Pwipwi is offline   Reply With Quote
Old 09-17-03, 01:11 PM   #4
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Default

Thanks for your reply.
I'm probably being really stupid but I still can't get the thing to work!
I've read the FAQ section in the readme but I can't find the answer.What am I missing? looking at the log the problem seems to be to do with

(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)

But I don't know how to rectify this. I reinstalled the drivers but this has not helped.
Again any help is great!
Billy the kid goat
billythekidgoat is offline   Reply With Quote
Old 09-17-03, 03:08 PM   #5
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

This is indeed a newbie question
in your /etc/X11/XF86Config file, in the section "Device", change the driver from "nv" to "nvidia" (supposing you installed the driver already, right )

But you know, don't rush when reading FAQs and READMEs, cause stuff said in here is REALLY important (ie: the thing that you missed is in fact really obvious and told in the FAQ even in the "for the impatient" instruction )

here is the fixed file:
Attached Files
File Type: txt xf86config.txt (4.7 KB, 178 views)
Pwipwi is offline   Reply With Quote
Old 09-18-03, 01:54 PM   #6
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Default

Thanks for your reply again!

i've actually already tried doing this-manually editing the XF86Config file and replacing "nv" with "nvidia" and then rebooting but when X loads I just get a black screen. This had happened both times i've tried it.

When I tick the "enable 3d" box on the Sax2 console and then test the setting the same thing happens- I just get a black screen and have to restart with the old settings.

What am I doing wrong?
I've reinstalled the drivers and that all seems to go fine. This is on a new system with just Suse 8.2 installed along with the programs that came with the program.

Billy the kid goat
billythekidgoat is offline   Reply With Quote
Old 09-18-03, 02:30 PM   #7
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

aha. this one is a bit trickier
Just that you know, you won't get any 3d acceleration if you don't use the nvidia driver. The nv driver doesn't handle it at all. Have you tried the FAQ thingies with the nvidia driver on ? If not, I encourage you to do so.
Anyway, this could come from the ACPI on (again!) ! At least, it wouldn't surprise me if you had a nforce chipset on your motherboard . It could come from the AGP thing, either way, so you should give a try to the NvAGP 0 ( or option "NvAGP" "0") in the Device section of your XF86Config file. Could you try everything of the faq again with the nvidia driver on, then tell me the results or particular things you noticed ?

Have fun
Pwipwi is offline   Reply With Quote
Old 09-18-03, 03:32 PM   #8
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Default

Thanks for the swift reply!

With the nvidia driver on i can't load x so have to work from the command line which is a new experience for me!
I'll try as you suggested and post the results.
Cheers!
Billy the kid goat
billythekidgoat is offline   Reply With Quote

Old 09-18-03, 04:00 PM   #9
billythekidgoat
Registered User
 
Join Date: Sep 2003
Location: suffolk, Britain
Posts: 6
Talking


IT WORKS!!!

I added in "NvAGP" "0" into the devices section and it worked 1st time!

Thanks for all your help genius!

Billy the kid goat
billythekidgoat is offline   Reply With Quote
Old 09-19-03, 02:54 PM   #10
Pwipwi
Registered User
 
Join Date: Sep 2003
Posts: 15
Default

you're welcome
Pwipwi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie - Compiling my own for SuSe 8.0 jocephus19 NVIDIA Linux 5 09-01-02 09:38 PM

All times are GMT -5. The time now is 03:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.