Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-09, 10:58 AM   #1
spitzb
Registered User
 
Join Date: Mar 2009
Posts: 4
Default Need help with HDTV output

I am completely lost. I have a GForce 9500 connected to either a Samsung Monitor or a hitachi Plasma TV. With both devices i was unable to force the graphics card to 1080i mode.

Here the relevant sections of my xorg.conf:

Section "Monitor"
DisplaySize 510 330
HorizSync 28-51
Identifier "Monitor2"
ModelName "SYNCMASTER 240T"
Option "PreferredMode" "1080i"
VendorName "SAMSUNG"
VertRefresh 50-60
Option "UseEDIDDpi" "FALSE"
EndSection


Section "Screen"
DefaultDepth 24
Option "TVOutFormat" "COMPONENT"
Option "TVStandard" "HD1080i"
Option "TVOverScan" "0.0"
Option "ModeValidation" "NoEdidModes"
SubSection "Display"
Depth 24
Modes "nvidia-auto-select"
EndSubSection

Device "NVidia"
Identifier "Screen2"
Monitor "Monitor2"
EndSection


Section "Device"
BoardName "GeForce 9500 GT"
BusID "1:0:0"
Driver "nvidia"
Identifier "NVidia"
Option "TvOutFormat" "COMPONENT"
Option "TVStandard" "HD1080i"
Option "UseEDIDFreqs" "FALSE"
Option "ModeValidation" "NoEdidModes"
Screen 0
VendorName "NVidia"
EndSection

Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
Screen 0 "Screen2" 0 0
Screen 1 "Screen1" RightOf "Screen1"
EndSection


and here an extract from the Xorg.log file

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TVStandard" "HD1080i"
(**) NVIDIA(0): Option "TVOutFormat" "COMPONENT"
(**) NVIDIA(0): Option "UseEdidFreqs" "FALSE"
(**) NVIDIA(0): Option "TVOverScan" "0.0"
(**) NVIDIA(0): Option "UseEdidDpi" "FALSE"
(**) NVIDIA(0): Option "ModeValidation" "NoEdidModes"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): Forcing COMPONENT output
(**) NVIDIA(0): TV Standard string: "HD1080i"
(**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID has been
(**) NVIDIA(0): disabled on all display devices.
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(II) NVIDIA(0): NVIDIA GPU GeForce 9500 GT (G96) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 1048576 kBytes
(--) NVIDIA(0): VideoBIOS: 62.94.3c.00.00
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 9500 GT at PCI:1:0:0:
(--) NVIDIA(0): Samsung SyncMaster (DFP-1)
(--) NVIDIA(0): Samsung SyncMaster (DFP-1): 165.0 MHz maximum pixel clock
(--) NVIDIA(0): Samsung SyncMaster (DFP-1): Internal Single Link TMDS
(II) NVIDIA(0): Mode Validation Overrides for Samsung SyncMaster (DFP-1):
(II) NVIDIA(0): NoEdidModes
(II) NVIDIA(0): Assigned Display Device: DFP-1
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 640 x 480
(**) NVIDIA(0): DPI set to (31, 36); computed from "DisplaySize" Monitor
(**) NVIDIA(0): section option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"

Can anybody help me please. All What i want is a fixed mode 1080i for my TV

Thanks
Falk
spitzb is offline   Reply With Quote
Old 04-17-09, 01:59 PM   #2
BitJam
Registered User
 
Join Date: Apr 2006
Posts: 47
Default Re: Need help with HDTV output

I think the problem may be that you are using the DVI connector (because the log file says DFP-1). AFAIK the TVOut... options don't affect what goes out through that connector.

You haven't specified any modes and EDID has been disabled so the Nvidia driver has to guess at the max resolution of the monitor. It made the most conservative guess possible.

I think there are probably two different solution. One would be to use the TV-Out connector instead of the DVI connector and leave your xorg.conf as is. The other option would be to keep using the DVI connector and either enable EDID (if that is possible) or if that is not possible, specify what resolutions your monitor is capable of in your xorg.conf. The Nvidia README will tell you how to do this.

You could also try using nvidia-xconfig to see if it can automatically create an xorg.conf for you. I always use the "-o some-file" option so it doesn't try to overwrite my xorg.conf. You can also try to temporarily move your xorg.conf file elsewhere before running nvidia-xconfig to see what it can figure out on its own.
BitJam is offline   Reply With Quote
Old 04-17-09, 02:41 PM   #3
spitzb
Registered User
 
Join Date: Mar 2009
Posts: 4
Default Re: Need help with HDTV output

Quote:
I think the problem may be that you are using the DVI connector
No, the monitor is connected to the HDMI output

Quote:
The other option would be to keep using the DVI connector and either enable EDID
I've disabled EDID, because the driver reads the PC modes from my TV. Because I've connected other sources the TV MUST be in TV mode. And then it only accepts 1080i or 720p. With EDID enabled the driver always uses 1280x1024, wich is the best PC resolution.
spitzb is offline   Reply With Quote
Old 04-18-09, 03:05 AM   #4
BitJam
Registered User
 
Join Date: Apr 2006
Posts: 47
Default Re: Need help with HDTV output

Quote:
Originally Posted by spitzb View Post
No, the monitor is connected to the HDMI output
But HDMI is equivalent to DVI. The Wikipedia says:
Quote:
A Digital Visual Interface (DVI) signal is electrically compatible with an HDMI video signal; no signal conversion needs to take place when an adapter is used, and consequently no loss in video quality occurs.
So as far as the Nvidia board is concerned, it is sending a digital DVI signal not an analog "TV" signal.

Quote:
I've disabled EDID, because the driver reads the PC modes from my TV. Because I've connected other sources the TV MUST be in TV mode. And then it only accepts 1080i or 720p.
The xorg.conf settings are for the Nvidia board NOT the TV. It does not matter what mode the TV is in. If you are using the HDMI connector, the driver treats it as a DFP device as clearly shown in your log file.

Please READ the Nvidia README about this. The TV* options are for the signal coming out of the TV-OUT connector. Those options do not affect the signal from the DVI/HDMI connectors.

Appendix D of the README explains device naming. If a display is connected via HDMI/DVI it is called a DFP device. If it is connect through the VGA connector it is called a CRT device and if it is connected to the TV-Out connector it is called a TV device. As you have noticed, the TV* options have no effect on the HDMI/DVI signal.

Quote:
With EDID enabled the driver always uses 1280x1024, wich is the best PC resolution.
Sigh. EDID should also tell the driver all of the resolutions available for the device. You can then use the nvdia-settings program to change the resolution by going th "X Server Display Properties" and clicking on the box showing your current resolution. Of course, if EDID is disabled and you don't specify any modes in your xorg.conf then you are probably SOL.

Again, I suggest that you enable EDID even if enabling it does not instantly give you the resolution that you want. Then use nvidia-settings to select your desired resolution and finally have nvidia-settings create an xorg.conf file for you with your desired resolution.
BitJam is offline   Reply With Quote
Old 04-18-09, 10:14 AM   #5
spitzb
Registered User
 
Join Date: Mar 2009
Posts: 4
Default Re: Need help with HDTV output

I think you misundstood me. Probably my fault.

My graphics card does not have a TV out. I have a Plasma TV connected to the HDMI output.

My Plasma Screen knows two states for it's digital Input: PC and STM (whis means TV resolutions). Through EDID it only reports the PC mode resolutions. So, when i set it to PC Mode, i can use it with the NVidia Card. The NVidia setting do not allow me to set it to 1080i (1920x1080 interlace at 50 Hz), because the screen does not report this mode as a valid mode. So there is no way to use the creen with the nvidia card when the Screen is in TV mode.

That's why i tried to disable EDID and describe the Screen with the TV standards. Unfortunately the nvidia driver didn't understand my intention very well. In the meantime, i found a way to get it at least set to 1080i, but i had not time yet to test it with my Plasma Screen, to make sure the mode fits it's needs.

Anyways thanks for your answers.
Falk
spitzb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
$254.99 - Magnavox 26" 720p LCD HDTV 26MF301B/F7 News Archived News Items 0 06-20-12 09:00 PM
$254.99 - Westinghouse 32" 720p 60Hz LED-LCD HDTV LD-3237 News Archived News Items 0 06-18-12 09:50 PM
$229.99 - HANNspree 32" Class (31.5" Diag.) 720p 60Hz LED-Backlit LCD HDTV SV32AMUB News Archived News Items 0 06-18-12 05:00 AM
Blu-ray 3D Movie Playback With PC on a 3D HDTV Using HDMI 1.4 News Archived News Items 0 05-16-12 03:30 AM
HDTV support - computer to HDTV set porksoda NVIDIA GeForce 7, 8, And 9 Series 10 10-27-05 06:30 PM

All times are GMT -5. The time now is 02:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.