Go Back   nV News Forums > Software Forums > Gaming Central

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-24-09, 06:24 PM   #1
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default BioShock Mouse Acceleration Fix

* Locate Bioshock.ini and User.ini
Windows XP
C:\Documents and Settings\[Username]\Application Data\Bioshock
C:\Documents and Settings\[Username]\Application Data\Bioshock2
Windows Vista or Windows 7
C:\Users\[Username]\AppData\Roaming\Bioshock
C:\Users\[Username]\AppData\Roaming\Bioshock2


Disabling Mouse Acceleration & Smoothing

In User.ini with Notepad Go to Edit>Replace and search for the two MOUSEX and MOUSEY acceleration speeds and change them from their default 2500 speed to 750 or any other value that feels comfortable. You will need to "Replace All" the following two lines since they repeat.

MouseX=IF_MOUSE_LOOK_ENABLED Count bXAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseX Speed=2500.0
MouseY=IF_MOUSE_LOOK_ENABLED Count bYAxis | IF_MOUSE_LOOK_ENABLED Axis aMouseY Speed=2500.0

And the final step is to bind a key to disable Mouse Smoothing. In the 2K forums, someone suggested F10. I came up with a slightly more invisible way of doing this...

W=MoveForward | set Engine.PlayerInput MouseAccelThreshold 0.0 | set Engine.PlayerInput MouseSmoothingMode 0

Now as soon as you hit the forward key W your mouse is good to go, you don't have to do a separate key bind for it.

Last edited by AngelGraves13; 02-12-10 at 11:25 PM.
AngelGraves13 is offline   Reply With Quote
Old 04-24-09, 08:04 PM   #2
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: BioShock Mouse Acceleration Fix

I've never noticed mouselag in this game, anyone else?
JasonPC is offline   Reply With Quote
Old 04-24-09, 08:51 PM   #3
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default Re: BioShock Mouse Acceleration Fix

Quote:
Originally Posted by JasonPC View Post
I've never noticed mouselag in this game, anyone else?
You probably don't use high dpi mice with 1ms delay.
AngelGraves13 is offline   Reply With Quote
Old 04-24-09, 09:57 PM   #4
JasonPC
Registered User
 
Join Date: Feb 2007
Posts: 2,103
Default Re: BioShock Mouse Acceleration Fix

I had a Logitech G7 though I'm not sure what the delay time was on it.
JasonPC is offline   Reply With Quote
Old 04-24-09, 10:10 PM   #5
Alaa
Peace
 
Alaa's Avatar
 
Join Date: Apr 2005
Location: Cairo
Posts: 431
Default Re: BioShock Mouse Acceleration Fix

Mouse control felt weird to me.
Alaa is offline   Reply With Quote
Old 04-24-09, 10:45 PM   #6
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default Re: BioShock Mouse Acceleration Fix

This fixes it almost completely. Mouse Acceleration still cannot be disabled during cut scenes, but during the rest of the game it is fine as long as you bind the command to a key and press it after a game/level load.
AngelGraves13 is offline   Reply With Quote
Old 04-25-09, 03:57 PM   #7
skank
Smeg Head
 
Join Date: Jan 2005
Location: Leeds, UK
Posts: 158
Default Re: BioShock Mouse Acceleration Fix

I tried this and I still get wierd movement in game and I can still move my mouse really slowly without it registering movement, G9 with latest drivers.
__________________
System: Core i5 2500k | 8Gb G.Skill Sniper LV | ASRock z68 Extreme 4 | Sapphire Radeon HD5870 1GB | Creative X-Fi | Thermaltake Toughpower 700W | Windows 7 x64
skank is offline   Reply With Quote
Old 04-25-09, 08:14 PM   #8
SH64
MAXIMUM TECH
 
SH64's Avatar
 
Join Date: Jul 2003
Location: Indiana
Posts: 12,202
Default Re: BioShock Mouse Acceleration Fix

Too late
__________________


- "My name is RAM and my tank is full"

http://warhawk64nv.mybrute.com/ <-- pupils go thaarrr! Or,
http://silenthunter64.mybrute.com
SH64 is offline   Reply With Quote

Old 04-26-09, 05:29 AM   #9
AngelGraves13
Registered User
 
Join Date: Aug 2002
Posts: 2,383
Default Re: BioShock Mouse Acceleration Fix

Quote:
Originally Posted by skank View Post
I tried this and I still get wierd movement in game and I can still move my mouse really slowly without it registering movement, G9 with latest drivers.
You need to hit F10 after every level/saved game load.

Load a saved game, hit F10 and move around. Make sure your sensitivity isn't at 1.
AngelGraves13 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Doh, M$ Optical Intellimouse Explorer not good for games Creole General Hardware 18 09-28-02 10:55 PM
Microsoft Mouse NeoGeo General Hardware 13 09-16-02 02:47 PM
QIII engines & Dets 40.41 "darkness" fix... sisi NVIDIA Windows Graphics Drivers 6 09-03-02 05:55 AM
windows 98/xp mouse screw'up's ThoriN General Software 3 08-24-02 10:45 PM
Can I use 3-D acceleration in the framebuffer coredumped NVIDIA Linux 3 08-24-02 02:20 PM

All times are GMT -5. The time now is 04:56 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.