Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-18-09, 08:04 AM   #1
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

I have been trying to install a driver on a new PC which has a 512MB GEFORCE 9400GT PCI Express graphics card and runs the Ubuntu 9.04 64 bit OS.

The driver (I have tried several versions, up to 185.19) always appears to install correctly, whether I use the command line or Hardware Drivers utility in Ubuntu.

The problem is that after installation the display resolution is set at 800x600 4:3 instead of 1440x900 16:10. When I go into Nvidia X Server Settings, the only resolutions available in the drop-down box are 800x600 4:3 or 640x480 4:3. It also appears that the plug-and-play monitor (a 19" Edge10) is not recognised.

If I reset Xorg back to its defaults, then the system boots up with the VESA driver and the correct resolution, although the monitor is still not showing up as recognised in the Ubuntu Display settings utility.

I just ran through a command line installation of 185.19 again, using the instructions listed below, which come from a 'How To' posting on the Ubuntu Tutorials forum:

Reset Xorg back to Failsafe Defaults
Before doing anything, it's time to say goodbye to nvidia for the moment and bring back the original Xorg configuration. This is done by opening a terminal and running:
Code:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.original
sudo dpkg-reconfigure -phigh xserver-xorg

It is not required, but you can logout and log back in again after running this. Doing so means you are now on the default VESA drivers, so Composite features (compiz) will be disabled.

Also, we won't be needing the xorg.conf.orginal file, but it serves:
1) As a backup incase you wish to reinstall the NViDIA drivers through the 'Hardware Drivers' utility.
2) As a reference for those who have specially tweaked xorg.conf files (such as dual-monitor, etc).

Installing Build Deps
Next, we need to be ensured that we have all build-essential programs and our current kernel headers.
Code:

sudo apt-get install build-essential linux-headers-`uname -r`

Ubuntu and Hardware Drivers
If you run Ubuntu and have an NViDIA card, you more than likely used the 'Hardware Drivers' utility to install them. This can lead to conflicts later down the line, as New drivers/Old drivers will cause API conflicts that will prevent X from starting.
So you are required to uninstall/remove any nvidia modules and references before beginning.
Code:

sudo apt-get --purge remove $(dpkg -l | grep nvidia | awk '{print $2}')

As an optional step, for some people who may find a conflict during installation, removing the xorg-nv drivers beforehand appears to work for them.
Code:

sudo apt-get --purge remove $(dpkg -l | grep xorg | grep nv | awk '{print $2}')

Note: doing this means that the next time you restart X, you will have a 800x600 screen resolution, so do not be alarmed.

Downloading the Drivers
Depending on your OS architechture and kernel version, you will need to get the right one for your kernel.
There have also been updates in the beta drivers which you may prefer to use instead, that support new features and fix odd bugs here or there.

For the 185.19 drivers (Recommended OS's are: Hardy, Intrepid or Jaunty or a 2.6.28 or earlier kernel):

If you are on 64bit, run:
Code:

wget ftp://download.nvidia.com/XFree86/Li...85.19-pkg2.run -O NVIDIA-Linux-185.pkg.run


For the 185.18.04 drivers (Recommended if you are on a 2.6.29 or later kernel):
If you are on a 32bit OS, run:
Code:

wget ftp://download.nvidia.com/XFree86/Li...18.04-pkg1.run -O NVIDIA-Linux-185.pkg.run

If you are on a 64bit OS, run:
Code:

wget ftp://download.nvidia.com/XFree86/Li...18.04-pkg2.run -O NVIDIA-Linux-185.pkg.run

Now, move the installer to the /usr/src folder and make a link to the file.
Code:

sudo install NVIDIA-Linux-185.pkg.run /usr/src
sudo ln -s /usr/src/NVIDIA-Linux-185.pkg.run /usr/src/nvidia-driver

The nvidia-driver symlink will be needed for later + post installation configuration.

Now, it's time to stop X and the gdm (or kdm for Kubuntu Users)
This requires that you logout and switch to another tty console ( Ctrl+Alt+F1 ).

Login to the shell, and kill gdm:
Code:

sudo /etc/init.d/gdm stop

This may take a while to complete.

In some rare instances, stopping gdm won't stop Xorg, due to the Xsession being busy with whatever error has occurred (Ubuntu goes into Low Resolution mode, X failed to start, etc).
In these instances, it is required that you run a kill of Xorg before you can continue with the installation of the driver.
Code:

sudo killall Xorg

Installing NViDIA
Afterwards, its time to install the drivers.
Code:

sudo sh /usr/src/nvidia-driver

Follow the instructions, and everything should run smoothly. A few points that I'd like to reassure first though:

* Don't worry about pre-compiled binaries, just let the script compile the drivers itself.
* If you run a 64bit OS, then let NViDIA install the 32bit backward compatibility modules.
* When asked, double check to ensure you select 'NO' when the NViDIA installer asks to reconfigure the xorg.conf file.
We don't want to change the xorg.conf file just yet, at least not until we are back in X.


Once finished, it is now time to reboot:
Code:

sudo reboot

Before you Initiate the Driver
Now, since NViDIA didn't reconfigure the xorg.conf file, you will boot into the VESA drivers. To setup the xorg.conf file for nvidia, login, open a terminal, and run:
Code:

sudo nvidia-xconfig

Note: You may see this being outputted into the console
Quote:
Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'
Ubuntu uses an automagically configured xorg.conf file, and nvidia-xconfig flags it only as a parser warning, and serves only as a warning. This does not affect the outputted xorg.conf file generated by the nvidia script, and you blissfully ignore it.

Now, not everyone may experience a smooth transition, and there are a number of small problems that you may run into that need addressing first. The most common one being a non-existent module listed in the xorg.conf file.

And if you have had a successful transition, and everything works. The first thing you'll notice is a nice new NViDIA splash logo that you probably want to be removed too.

So I recommend - as a failsafe - that you patch the xorg.conf file as so:
Code:

sudo sed -i '/^\s*Load\s*"type1"\s*$/d' /etc/X11/xorg.conf
sudo sed -i '/^\s*Load\s*"freetype"\s*$/d' /etc/X11/xorg.conf
sudo sed -i '/Driver\s*.nvidia./a\ Option "NoLogo" "True"' /etc/X11/xorg.conf

Restart X
And that is it! To reload into your new nvidia drivers, close all running applications and logout/login again. Or press Ctrl+Alt+Backspace.


I have also attached a copy of the nvidia-bug-report.log, which was created immediately after I did the last install of 185.19.

So, in summary, I can get the driver installed and working (screen effects such as Compiz are active), but screen resolution goes no higher than 800x600 4:3, OR I can have a correct screen resolution of 1440x900 16:10, but with no Nvidia driver working (VESA only).

I have also tried making a manual change to the resolution settings in Xorg.conf, but this has no effect either.

Can anyone suggest what may be causing the problem and how it might be fixed?
Attached Files
File Type: gz nvidia-bug-report.log.gz (42.9 KB, 136 views)

Last edited by Gewitty; 05-22-09 at 05:00 AM. Reason: Problem unresolved
Gewitty is offline   Reply With Quote
Old 05-22-09, 05:03 AM   #2
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

No-one got any ideas about this problem? I've run out of places to look and forums to query, so my expensive Nvidia board is just sitting there doing nothing.
Gewitty is offline   Reply With Quote
Old 05-22-09, 05:25 AM   #3
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Hi Gwitty
I am not surprised and am pleased to see your post.
Try reducing your RAM to 2G, it may or may not be related however I would be interested to see if it is a bus or chip problem. (search the forum for my posts.)
I have several of the PCI version of these cards, they are a great idea, however I have also not managed to get any stable yet - like e.g. a 8500GT is although I've not ventured into the 185.xx driver series. I am also intrigued that the PCI card is recognised in the NVIDIA dirver software as PCI-E x 1, which I understood to be different to PCI. (!)
I think the driver support for these particular 9400GT chipped cards may not yet be stable. Please keep us informed.
Dragorep is offline   Reply With Quote
Old 05-22-09, 06:37 AM   #4
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Hello.

The nvidia driver is unable to interpret the EDID from your monitor.

(WW) NVIDIA(GPU-0): The EDID read for display device DFP-0 is invalid: the
(WW) NVIDIA(GPU-0): checksum for EDID version 1 extension is invalid.


You have the following possibilities:

1) Get a valid EDID file for your monitor and pass it to the driver as described in Appendix B of the nvidia Readme

2) Overwrite the EDID data with manual specified values (resolutions, frequencies, dpi) and by disabling edid based modes. You find the options needed for that as well in the Appendix B of the readme.

Kind regards

Fuchs
NvFuchs is offline   Reply With Quote
Old 05-22-09, 06:43 AM   #5
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

I just spoke to the people who supplied the hardware (this is a new system, only a few weeks old). Their tech support is excellent, although they don't have much Linux experience.

They say that while there used to be a problem with systems running more than 3Gb RAM, this is no longer the case. However, they are noting quite a number of problems where people are using Ubuntu 9.04 and believe that this is where the fault lies. The machine was fully tested with a Vista installation and the 8400GT card performed perfectly.

The suggestion was that I try loading the driver in Ubuntu 8.10, which they believe will solve the problem. I ran an 8.10 live disk session and installed the recommended driver (170), but this did not cure the fault, I still got low res graphics.

I have also come across references (http://tinyurl.com/6ztgse) to an alternative driver, called Nouveau. This is an Open Source project and is allegedly available via the repositories, although it doesn't appear when I do a Synaptic search. Has anyone heard of, or used this?
Gewitty is offline   Reply With Quote
Old 05-22-09, 06:57 AM   #6
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by Gewitty View Post
I just spoke to the people who supplied the hardware (this is a new system, only a few weeks old). Their tech support is excellent, although they don't have much Linux experience.

They say that while there used to be a problem with systems running more than 3Gb RAM, this is no longer the case. However, they are noting quite a number of problems where people are using Ubuntu 9.04 and believe that this is where the fault lies.
Wrong. The log states exactly where the fault lies, the driver is unable to interpret the EDID provided by your monitor. Therefore it cannot compute / read valid modes, including resolutions, out of it.

However, the Linux driver seems to be more restrictive regarding EDIDs than the Windows counterpart, which in fact reads and interprets some EDID date the linux driver has problems with.

Quote:
The suggestion was that I try loading the driver in Ubuntu 8.10, which they believe will solve the problem. I ran an 8.10 live disk session and installed the recommended driver (170), but this did not cure the fault, I still got low res graphics.
The solution would be one of the two solutions I proposed, which are, when applied correctly, guaranteed to work.

Quote:
I have also come across references (http://tinyurl.com/6ztgse) to an alternative driver, called Nouveau. This is an Open Source project and is allegedly available via the repositories, although it doesn't appear when I do a Synaptic search. Has anyone heard of, or used this?
It has limited 3D support, no powersaving features and is missing other things as well. Even though it is on a good way, I would never recommend it to a standard user as a nvidia replacement. Maybe as a nv replacement, yes.

Fuchs
NvFuchs is offline   Reply With Quote
Old 05-22-09, 06:57 AM   #7
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Since posting I realise you are running 64 bit, which I understand does not have the 32 bit RAM limitation so I think NVFuchs may well be closer to the mark.
Dragorep is offline   Reply With Quote
Old 05-22-09, 07:16 AM   #8
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Any chance of diagnosing why my PCI 9400GT is unstable?
Attached Files
File Type: gz nvidia-bug-report.log.gz (25.0 KB, 101 views)
Dragorep is offline   Reply With Quote

Old 05-22-09, 07:24 AM   #9
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by Dragorep View Post
Any chance of diagnosing why my PCI 9400GT is unstable?
Please open a new thread with your problem.

Having multiple problems from multiple people in one single thread makes it difficult to keep track of the progress.

You have some

[ 64.089049] NVRM: Xid (0002:00): 6, PE0001
[ 65.993611] NVRM: Xid (0002:00): 6, PE0001
[ 66.173872] NVRM: Xid (0002:00): 6, PE0001
[ 66.591321] NVRM: Xid (0002:00): 6, PE0001
[ 68.823141] NVRM: Xid (0002:00): 6, PE0001
[ 82.634963] NVRM: Xid (0002:00): 6, PE0001
[ 83.979711] NVRM: Xid (0002:00): 6, PE0001
[ 84.735160] NVRM: Xid (0002:00): 6, PE0001

which you might want to pass over to nvidia.

Stability problems are not always caused by the GPU or driver, but also by insufficient power supplies, temperature problems, broken (V)RAM and other hardware.

I recommend you

1) Open a new thread for this
2) Send the bug report to the e-mail address noted after running nvidia-bug-report.sh

Kind regards

Fuchs
NvFuchs is offline   Reply With Quote
Old 05-22-09, 08:04 AM   #10
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by NvFuchs View Post
Hello.

The nvidia driver is unable to interpret the EDID from your monitor.

(WW) NVIDIA(GPU-0): The EDID read for display device DFP-0 is invalid: the
(WW) NVIDIA(GPU-0): checksum for EDID version 1 extension is invalid.


You have the following possibilities:

1) Get a valid EDID file for your monitor and pass it to the driver as described in Appendix B of the nvidia Readme

2) Overwrite the EDID data with manual specified values (resolutions, frequencies, dpi) and by disabling edid based modes. You find the options needed for that as well in the Appendix B of the readme.

Kind regards

Fuchs
That makes a lot of sense. I took a look at the appendix mentioned and it seems pretty daunting. However, I'll see if I can figure out which settings to alter and let you know what happens.
Gewitty is offline   Reply With Quote
Old 05-22-09, 08:13 AM   #11
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by Gewitty View Post
That makes a lot of sense. I took a look at the appendix mentioned and it seems pretty daunting. However, I'll see if I can figure out which settings to alter and let you know what happens.

In fact, using a correct EDID file is usually a lot easier, even though you find a lot of how tos regarding this problem (as it is well known). Googling for nvidia edid linux (or similar) should give you lots of results.

So the first options to try would be, at least I recommend it that way, to

1) read out the EDID in Windows (if available)
2) look for matching EDIDs on the web
3) Use tools like the phoenix EDID editor (or similar) to create an EDID

The only option you would need then is

Option "CustomEDID" "string"

where "string" should be replaced with a full path to the file (e.g. "/home/myuser/myedid.bin"

The other way round you want to take a look at the options to disable the EDID or parts of it, and then either modelines or options like the HorizSync and VertRefresh etc.

Fuchs
NvFuchs is offline   Reply With Quote
Old 05-22-09, 08:34 AM   #12
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by NvFuchs View Post
In fact, using a correct EDID file is usually a lot easier, even though you find a lot of how tos regarding this problem (as it is well known). Googling for nvidia edid linux (or similar) should give you lots of results.

So the first options to try would be, at least I recommend it that way, to

1) read out the EDID in Windows (if available)
2) look for matching EDIDs on the web
3) Use tools like the phoenix EDID editor (or similar) to create an EDID

The only option you would need then is

Option "CustomEDID" "string"

where "string" should be replaced with a full path to the file (e.g. "/home/myuser/myedid.bin"

The other way round you want to take a look at the options to disable the EDID or parts of it, and then either modelines or options like the HorizSync and VertRefresh etc.

Fuchs
I am in touch with the manufacturer (Edge10) of the screen, so I have asked if they can send me the correct EDID file. I'll let you know how it works, if and when I get it.
Gewitty is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM

All times are GMT -5. The time now is 08:59 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.