Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-07-09, 02:02 PM   #1
wck555
Registered User
 
Join Date: Apr 2009
Posts: 9
Default HDMI Audio Disabled on GeForce 7300 with newer drivers

I running the latest nvidia driver (180.51) on an Apple TV which has a nVidia G72M [Quadro NVS 110M/GeForce Go 7300] GPU. The Apple TV uses a Silicon Image SiI 1930 to drive the HDMI output.

The SiI 1930 is connected to a Realtek ALC885 codec chip using the HD-Audio interface. It shows up as an ALSA audio device. By default the SiI 1930 embeds audio packets in the HDMI data stream. When I use the open-source nv driver I am able to play audio via HDMI using aplay. I hear the audio from my TV:
Code:
aplay -Dplughw:0,3 /usr/share/sounds/question.wav
As soon as I start the nVidia driver, the driver disables the HDMI audio data. aplay still reports the wav file is playing, but there are no audio packets in the HDMI data stream and no audio comes out of my TV.

It appears the nVidia driver started disabling the HMDI audio after version 100.14.19. HDMI audio works with version 100.14.19 of the nVidia driver.

Many people have the opposite problem. The newer nVidia drivers enable HDMI audio by default. I assume they are using other GPUs (8000 series, 9000 series). On the GeForce Go 7300 GPU, HDMI audio appears to now be disabled by default.

I would like a way to re-enable HDMI audio. I have posted more information on this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=124536
wck555 is offline   Reply With Quote
Old 05-22-09, 04:35 PM   #2
wck555
Registered User
 
Join Date: Apr 2009
Posts: 9
Default Re: HDMI Audio Disabled on GeForce 7300 with newer drivers

To work around the problem I have been using an older Linux kernel with version 100.14.23 of the driver. Everything works great for HDMI audio. However it's apparently not possible to control the clock speed of the 7300 GPU with version 100.14.23 of the driver. The clock speed controls are there, but I guess they are ignored for the 7300 GPU.

I need to under clock the GPU to prevent nvidia xvmc related hangs/video corruption when doing xvmc assisted mpeg2 decode/display:

http://code.google.com/p/atv-bootloa...MythbuntuHardy

I'm in a bind. I need Version 100.14.23 for HDMI audio. But I need a newer version of the driver to stop hangs with the video playback.

HELP!

It would be great to have an xorg.conf parameter to disable/enable HDMI audio manually and override what the driver does by default. Any chance this can happen? Are there any other work-arounds?

Thanks for any help.
wck555 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
GeForce R304 Beta Drivers Get You Ready For Summer Gaming News Archived News Items 0 06-18-12 09:50 PM
Upgrade from 290.10 to 295.49 on GeForce 8300 = no hdmi audio + overscan tbubel NVIDIA Linux 2 06-15-12 03:55 AM
Enhance Max Payne 3, Diablo III with GeForce R300 Drivers News Archived News Items 0 05-22-12 06:30 PM
New GPU from Nvidia Announced Today, the GeForce GTX 670 News Archived News Items 0 05-10-12 01:50 PM
Gainward Unleashes the Sexy GeForce GTX 670 Phantom Graphics Card, Also launches the News Archived News Items 0 05-10-12 09:28 AM

All times are GMT -5. The time now is 07:18 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.