Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-18-09, 09:18 AM   #1
karimb
Registered User
 
Join Date: May 2009
Posts: 3
Question Help needed for installing riva-tnt drivers for Debian lenny

Hi

Afther couple of days trying im still having problems with my driver installation.
I have tried many tips from net with not so much luck

I would appreciate a simple begining to end guid how to do it as
I think i have messed already too much

I have Debian lenny installation and and .. this what i have done.


lspci |grep VGA
01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15)

stop the gnome
/etc/init.d/gdm stop

Run the driver installation
sh NVIDIA-Linux-x86-71.86.09-pkg1.runaccpet LICENSES


accpet LICENSES
-->YES

No precompiled kernel interface was found to match your kernel;
--> No

The CC version check failed:
The compiler used to compile the kernel (gcc 4.1) does not exactly match the
current compiler (gcc 4.3). The Linux 2.6 kernel module loader rejects
kernel modules built with a version of gcc that does not exactly match that
of the compiler used to build the running kernel.

If you know what you are doing and want to ignore the gcc version check,
select "No" to continue installation. Otherwise, select "Yes" to abort
installation, set the CC environment variable to the name of the compiler
used to compile your kernel, and restart installation. Abort now?

--> NO

WARNING: You appear to be using a modular X.Org release, but the X library
installation path, 'X: warning; process set to priority -2 instead
of requested priority 0
/usr/lib', reported by `/usr/bin/X -showDefaultLibPath` does not
exist. Please check your X.Org installation.

-->OK

WARNING: You appear to be using a modular X.Org release, but the X module
installation path, 'X: warning; process set to priority -2 instead
of requested priority 0
/usr/lib/xorg/modules', reported by `/usr/bin/X
-showDefaultModulePath` does not exist. Please check your X.Org
installation.
-->OK


Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 71.86.09) is now complete. Please update your XF86Config or
xorg.conf file as appropriate; see the file
/usr/share/doc/NVIDIA_GLX-1.0/README for details.
-->OK


I Edited xorc.conf and added lines:

Section "Module"
Load "glx"
EndSection


Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection


modprobe nvidia Gives some errors
FATAL: Error inserting nvidia (/lib/modules/2.6.26-2-686/nvidia/nvidia.ko): No such device

And also Xorg fails to start.

(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)


(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)



Do i miss something important ..or
what should i try to fix or do next

Kari
karimb is offline   Reply With Quote
Old 05-18-09, 02:39 PM   #2
a7v
Registered User
 
Join Date: Jun 2005
Posts: 67
Default Re: Help needed for installing riva-tnt drivers for Debian lenny

Hmm, something went very wrong while installing the Xorg parts of the nvidia-driver.
Quote:
/usr/lib', reported by `/usr/bin/X -showDefaultLibPath` does not exist.
Obviously the installer is wrong here otherwise your system would be almost totally messed up.

Can you run a 'nvidia-bugreport', gzip it and then post it here as an attachment?
__________________
Computer stuff I've owned at one time or another:
CPUs: K6-3 400, Duron 600, Thunderbird 1400, Barton 2500, Duron 1800, A-64 3700+, C2D E7200
Motherboards: Shuttle Via MVP, Asus A7V, Asus A7V133, Asus N8X-VM400, Abit NF7, Abit UL8, Asus P5Q Pro
Graphics Cards: TNT2, GF 2 MX, GF 2 Pro, GF4 MX, GF FX 5500, GF 6600, GF 7600 GT, GF 9800GT
a7v is offline   Reply With Quote
Old 05-18-09, 03:33 PM   #3
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Help needed for installing riva-tnt drivers for Debian lenny

The problem here is not that the installer thinks that "/usr/lib" doesn't exist, but that the X server is saying that the default library path is "X: warning; process set to priority -2 instead of requested priority 0<newline>/usr/lib" and no such directory with that name exists. That's an X server bug.
AaronP is offline   Reply With Quote
Old 05-19-09, 01:42 PM   #4
karimb
Registered User
 
Join Date: May 2009
Posts: 3
Default Re: Help needed for installing riva-tnt drivers for Debian lenny

Hi again ..

I re-installed my debian and managed to install nvidia drivers to gnome by
using inch newer file NVIDIA-Linux-x86-71.86.09-pkg1.run.
At as least i think the driver installation went well ..and gnome was happy and running.

But the glx was still missing.. so i tried to install it by typing

apt-get install nvidia-glx nvidia-glx-dev nvidia-xconfig

And afther that i ended to same again.

Gnome dount start and re-running driver installation gives errors.

sh NVIDIA-Linux-x86-71.86.09-pkg1.run gives tha fancy error

WARNING: You appear to be using a modular X.Org release, but the X library
installation path, 'X: warning; process set to priority -2 instead
of requested priority 0
/usr/lib', reported by `/usr/bin/X -showDefaultLibPath` does not
exist. Please check your X.Org installation.
OK
WARNING: You appear to be using a modular X.Org release, but the X module
installation path, 'X: warning; process set to priority -2 instead
of requested priority 0
/usr/lib/xorg/modules', reported by `/usr/bin/X
-showDefaultModulePath` does not exist. Please check your X.Org
installation.
OK

Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86
(version: 71.86.09) is now complete. Please update your XF86Config or
xorg.conf file as appropriate; see the file
/usr/share/doc/NVIDIA_GLX-1.0/README for details.
OK


if i but line Driver "nvidia" to xorg.conf the gnome dount start anymore .
/var/log/Xorg.log gives erros like
(II) LoadModule: "nvidia"
(WW) Warning, couldn't open module nvidia
(II) UnloadModule: "nvidia"
(EE) Failed to load module "nvidia" (module does not exist, 0)
aand(EE) No drivers available.

Fatal server error:
no screens found


I also tried to
remove those glx packets and re install the gnome ..with no luck
Attached Files
File Type: gz nvidia-bug-report.log.tar.gz (27.0 KB, 86 views)
karimb is offline   Reply With Quote
Old 05-19-09, 03:11 PM   #5
engin
Registered User
 
Join Date: May 2009
Posts: 1
Default Re: Help needed for installing riva-tnt drivers for Debian lenny

You should compile the driver with the same gcc version as compiled your kernel.

Code:
apt-get install gcc-4.1
cd /usr/bin
rm gcc
ln -s gcc-4.1 gcc
this commands would install gcc-4.1 than remove the shortcut gcc pointing to your gcc-4.3 and creates a link to newly installed gcc-4.1 version. I see you insisted on installing with the wrong version.

uninstall what you installed first.
Code:
nvidia-installer --uninstall
sh NVIDIA-yourdriverversionxx
engin is offline   Reply With Quote
Old 05-19-09, 09:14 PM   #6
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Help needed for installing riva-tnt drivers for Debian lenny

Don't do that! You should set the CC environment variable instead, as in
Code:
CC=gcc-4.1 sh NVIDIA-yourdriverversionxx
AaronP is offline   Reply With Quote
Old 05-28-09, 01:49 PM   #7
karimb
Registered User
 
Join Date: May 2009
Posts: 3
Smile Re: Help needed for installing riva-tnt drivers for Debian lenny

Hi and Thanks for usefull tips.

The drivers are in ..only the glx is missing.

How should I install glx without messing gnome as earlier.

Kari
karimb is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
NVidia Drivers HowTo for RedHat 8.0 needed eduardp NVIDIA Linux 10 10-04-02 03:59 AM
Riva TNT 2 - Debian (Woody) chipset problem sindra NVIDIA Linux 4 08-26-02 03:21 AM

All times are GMT -5. The time now is 08:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.