Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-28-09, 02:37 PM   #1
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupts

I recently upgraded to the 185.18.14 drivers, and now Resuming from suspend will not work when MSI interrupts are enabled. My card is a GeForce 8600m GT in a Dell Vostro 1500 running Kubuntu 9.10 (development). With regular interrupts, resume continues to work fine.
Attached Files
File Type: gz nvidia-bug-report.log.gz (39.9 KB, 71 views)
thefirstm is offline   Reply With Quote
Old 05-28-09, 03:07 PM   #2
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

Here are a dmesg and Xorg.0.log taken after the failed resume. (The system still resumes, even though displaying nothing on the screen, so I can SSH in and get the logs.) In the dmesg it says something about uvesafb, which I am using, but even when I use regular textmode the problem still occurs.
Attached Files
File Type: log Xorg.0.log (15.5 KB, 69 views)
File Type: log dmesg.log (123.2 KB, 80 views)
thefirstm is offline   Reply With Quote
Old 05-29-09, 03:56 AM   #3
cthulhu
Great Old One
 
cthulhu's Avatar
 
Join Date: Sep 2002
Posts: 124
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

I think the good folks at nvidia would appreciate a bugreport, as described in the sticky...
__________________
Desktop: Asus P5B Deluxe, Core2Duo E8500, 2GB Corsair 800MHz CL4, Gigabyte GTX460 1024MB
HTPC: Asus P5B-E, Core2Duo 6300, 1GB Corsair 533MHz, Asus 9500GT w/ 512MB DDR3
Server: Gigabyte D510UD, Atom D510, 2GB Corsair 800MHz, Hauppauge NOVA-T500 dual DVB-T tuner, 4x 2TB Samsung F3EG (RAID5)
Laptop: Asus U6V, Core2Duo P8400, 3GB DDR2, 9300M GS
OS on all: Gentoo Linux

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
cthulhu is offline   Reply With Quote
Old 05-29-09, 04:27 AM   #4
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

Already got one. Its in the Original Post. I just added the second post with more diagnostic data I thought might be useful.
thefirstm is offline   Reply With Quote
Old 05-29-09, 07:32 AM   #5
cthulhu
Great Old One
 
cthulhu's Avatar
 
Join Date: Sep 2002
Posts: 124
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

Doh! It is, sorry I missed that.
__________________
Desktop: Asus P5B Deluxe, Core2Duo E8500, 2GB Corsair 800MHz CL4, Gigabyte GTX460 1024MB
HTPC: Asus P5B-E, Core2Duo 6300, 1GB Corsair 533MHz, Asus 9500GT w/ 512MB DDR3
Server: Gigabyte D510UD, Atom D510, 2GB Corsair 800MHz, Hauppauge NOVA-T500 dual DVB-T tuner, 4x 2TB Samsung F3EG (RAID5)
Laptop: Asus U6V, Core2Duo P8400, 3GB DDR2, 9300M GS
OS on all: Gentoo Linux

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
cthulhu is offline   Reply With Quote
Old 05-29-09, 03:27 PM   #6
Haggy
Registered User
 
Join Date: May 2009
Posts: 13
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

Quote:
Originally Posted by thefirstm View Post
With regular interrupts, resume continues to work fine.
I have this since i built my current rig with an nvidia 8300 chipset. on resume sata controller (in ahci mode) spits errors like hell and afterwards all filesystem are mounted readonly. using pci=nomsi fixes this. On recent 2.6.29 kernels, using 180.xx drivers those sata errors even appear after a few minutes i leave the machine running, but ONLY if X is running and ONLY if msi interrupts are used. There's a whole thread dealing with this problem, so nvidia please have a look at this, thanks!
Haggy is offline   Reply With Quote
Old 06-01-09, 06:01 PM   #7
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: [regression] Suspend/resume will not work when using 185.18.14 with MSI interrupt

Thanks for the heads up. Definitely a big NO GO!
ledoc is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.