Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-29-09, 08:13 AM   #13
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: 180.60 & High CPU

Thanks, but I'm running 185.18.10 . This has happened to me every driver rev since 180.29. When I downrev to .29 the problem goes away. But the Myth VDPAU patch now won't let me downrev that far, so I'm in trouble.

After much research I find that a mismatch of framerates can cause this exact problem, and indeed mine are mismatched. nvidia-settings says my laptop monitor hardware (HP 8710w) is 1680x1050 @ 59.88Hz refresh. (nvidia-settings|GPU-0|DFP-0) However X is setting my video output to 1680x1050 @ 50Hz. (K|Settings|Peripherals|Display) The display is fine, but this mismatch is supposed to degrade performance over time.

I have tried many different settings disabling EDID, setting HorizRefresh and Modelines, but I only end up with a blank screen when I restart X. The logfile says, "No valid modes for '1680x1050'; removing", no matter what app I use to generate the modeline. I've tried setting HorizRefresh to 59.88 and 60, always getting a blank screen.

One thing I don't understand is wherefore 1050? This is not divisible by 8. Shouldn't it be 1048, or 1056?

The only way I ever get video is if I allow EDID to take effect and override my settings, which sets me down at 50Hz. And this only happens with nVidia drivers after .29. Apparently I am doing New Science though.
Quantumstate is offline   Reply With Quote
Old 05-29-09, 08:45 AM   #14
Dr. Tyrell
Registered User
 
Dr. Tyrell's Avatar
 
Join Date: Aug 2004
Posts: 100
Default Re: 180.60 & High CPU

No memory or cpu issues with 180 here.
Sadly though I cannot live with the 185 series because of Ubuntu's mplayer patch-level.

The Doctor
__________________
P7811-FX | Nvidia 9800M GTS 512MB DDR3 | 17" 1920x1200 | Centrino2 P8400 | 4GB DDR3 | 2x320Gb 7200RPM RAID 0 | DVD+-/DL
Dr. Tyrell is offline   Reply With Quote
Old 05-29-09, 09:54 AM   #15
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: 180.60 & High CPU

But your framerates likely match.

Please check them as I suggest above.
Quantumstate is offline   Reply With Quote
Old 05-29-09, 10:05 AM   #16
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 180.60 & High CPU

Quote:
Originally Posted by Quantumstate View Post
Thanks, but I'm running 185.18.10 . This has happened to me every driver rev since 180.29. When I downrev to .29 the problem goes away. But the Myth VDPAU patch now won't let me downrev that far, so I'm in trouble.

After much research I find that a mismatch of framerates can cause this exact problem, and indeed mine are mismatched. nvidia-settings says my laptop monitor hardware (HP 8710w) is 1680x1050 @ 59.88Hz refresh. (nvidia-settings|GPU-0|DFP-0) However X is setting my video output to 1680x1050 @ 50Hz. (K|Settings|Peripherals|Display) The display is fine, but this mismatch is supposed to degrade performance over time.
No refresh rates reported via randr are just wrong when dynmictwinview is enabled.

That means nvidia-settings does show you your correct frame rates, while the other tools just read it wrong.

So you are just making things up, whatever your issue is it is unrelated to your displays refresh rate.
Dragoran is offline   Reply With Quote
Old 05-29-09, 03:00 PM   #17
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: 180.60 & High CPU

Quote:
Originally Posted by Dragoran View Post
No refresh rates reported via randr are just wrong when dynmictwinview is enabled.

That means nvidia-settings does show you your correct frame rates, while the other tools just read it wrong.

So you are just making things up, whatever your issue is it is unrelated to your displays refresh rate.
WTH do you mean, 'making things up'?! I am using the tools made available, and while nvidia-settings reports 59.88Hz, KDE reports 50.

Now, if you have a better way, why don't you share it with us all instead of b1tching?
Quantumstate is offline   Reply With Quote
Old 05-29-09, 05:13 PM   #18
rapsure
Registered User
 
Join Date: Oct 2008
Posts: 47
Default Re: 180.60 & High CPU

The performance issue not related to refresh rates. Please refer to the nvidia-driver manual for information regarding twinview. Disabling twinview will correct the refresh rates reported by xrandr.
rapsure is offline   Reply With Quote
Old 05-29-09, 06:18 PM   #19
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: 180.60 & High CPU

Thanks rapsure, but Twinview is off by default. Just the same, I Option "TwinView" "False", but no change. I couldn't find the Twinview-related issue you refer to, in the driver ReadMe.
Quantumstate is offline   Reply With Quote
Old 05-29-09, 08:16 PM   #20
Quantumstate
Registered User
 
Join Date: May 2008
Posts: 166
Default Re: 180.60 & High CPU

OK, now I've found it. Option "DynamicTwinView" "False" and indeed now K|Settings|Peripherals|Display reports 60Hz. nvidia-settings still reports 59.88, which is OK.

Apparently xrandr cannot differentiate between meta-modes of the same size, so the nVidia driver lies about the refresh rate so it can differentiate. Thanks rapsure.

I am still left though with this CPU-hungry X. How to dissect what could be causing this is a Mystery To Science.
Quantumstate is offline   Reply With Quote

Old 05-30-09, 05:41 AM   #21
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 180.60 & High CPU

Quote:
Originally Posted by Quantumstate View Post
WTH do you mean, 'making things up'?! I am using the tools made available, and while nvidia-settings reports 59.88Hz, KDE reports 50.

Now, if you have a better way, why don't you share it with us all instead of b1tching?
"b1tching" - Sorry for trying to help you I just said that when dynamic twinview is enabled randr does not report the correct refresh rate.

With "making things up" I meant that your conclusion is wrong the refreshrate has nothing to do with your performance problem.

Try running sysprof to find out what is eating up your cpu.
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM
Prime95 and CPU stress testing DaveW General Software 2 10-05-02 12:38 PM
CPU limitations abound! PCarr78 NVIDIA GeForce 7, 8, And 9 Series 11 10-03-02 07:49 AM

All times are GMT -5. The time now is 11:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.