Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-09, 09:45 AM   #1
anonmys
sridhar
 
Join Date: Dec 2006
Posts: 14
Default Cannot install the 180.51/60 drivers under 2.6.29.4

I am currently running debian testing (squeeze), kernel 2.6.29.4 (vanilla from kernel.org). My motherboard has an integrated graphics card : GeForce 6150SE nForce 430

The 180.51 driver was working well, and for some strange/unknown reason stopped working since last night. I tried recompiling/reinstalling the driver and failed. Checked the site and found a new driver release (180.60). When I tried installing, I get the same error. I am pasting it here :

<a big snip>
...
-> Driver file installation is complete.
-> Running post-install sanity check:
-> done.
-> Post-install sanity check passed.
-> Shared memory test passed.
-> Running runtime sanity check:
ERROR: The runtime configuration check failed for the library
'libnvidia-tls.so.180.60' (expected: '/usr/lib/tls/libnvidia-tls.so.1',
found: '/usr/lib/libnvidia-tls.so.1'). The most likely reason for this
is that conflicting OpenGL libraries are installed in a location not
inspected by `nvidia-installer`. Please be sure you have uninstalled
any third-party OpenGL and/or third-party graphics driver packages.
-> done.
-> Runtime sanity check failed.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Can someone give me pointers to get this working?

Regards

sridhar
anonmys is offline   Reply With Quote
Old 06-01-09, 04:01 PM   #2
klemperal
Registered User
 
Join Date: May 2009
Posts: 7
Default Re: Cannot install the 180.51/60 drivers under 2.6.29.4

Have you tried purging the old driver?
Code:
Sudo aptitude purge nvidia-glx
klemperal is offline   Reply With Quote
Old 06-01-09, 07:52 PM   #3
anonmys
sridhar
 
Join Date: Dec 2006
Posts: 14
Default Re: Cannot install the 180.51/60 drivers under 2.6.29.4

Quote:
Originally Posted by klemperal View Post
Have you tried purging the old driver?
Code:
Sudo aptitude purge nvidia-glx
Maybe I did not make myself clear. I am not using nvidia-glx from the debian repos. I always use the driver downloaded from the nvidia site and install it.

Regards,
anonmys is offline   Reply With Quote
Old 06-01-09, 09:43 PM   #4
anonmys
sridhar
 
Join Date: Dec 2006
Posts: 14
Default [SOLVED]Re: Cannot install the 180.51/60 drivers under 2.6.29.4

I upgraded the xserver to that in unstable. After that, the compilation/installation went off well and I am able to get back my working X.

Thanks for the help.

Regards,

sridhar
anonmys is offline   Reply With Quote
Old 06-01-09, 10:12 PM   #5
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Re: Cannot install the 180.51/60 drivers under 2.6.29.4

I had that problem not that long ago. I simply removed the library file it was complaining about and all links to it, and reinstalled cleanly.

- Tim
tadawson is offline   Reply With Quote
Old 06-02-09, 01:31 AM   #6
anonmys
sridhar
 
Join Date: Dec 2006
Posts: 14
Default Re: Cannot install the 180.51/60 drivers under 2.6.29.4

Quote:
Originally Posted by tadawson View Post
I had that problem not that long ago. I simply removed the library file it was complaining about and all links to it, and reinstalled cleanly.
I tried that before positing it here :-) It did not work for me. The strange thing is the installer was creating the tls directory and putting the files that it complains about later. Anyway, I am happy that it could be solved bu upgrading to a later version of xorg.

Regards,

sridhar
anonmys is offline   Reply With Quote
Old 06-02-09, 08:45 PM   #7
tadawson
Registered User
 
Join Date: May 2009
Posts: 44
Default Re: Cannot install the 180.51/60 drivers under 2.6.29.4

Quote:
Originally Posted by anonmys View Post
I tried that before positing it here :-) It did not work for me. The strange thing is the installer was creating the tls directory and putting the files that it complains about later. Anyway, I am happy that it could be solved bu upgrading to a later version of xorg.

Regards,

sridhar
Make sure that there aren't any lingering links, either. Basically, if it says "nvidia" in it in the X library area, it probably needs to go bye-bye before you install . . .

- Tim
tadawson is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to quickly Install NVIDIA R302.11 Drivers Under Linux Mint 13 News Archived News Items 0 06-12-12 06:40 AM
Radeon 9700 not all that? sancheuz Other Desktop Graphics Cards 200 10-12-02 09:31 PM
Red Hat null(limbo beta 3), guide to install Nvidia Drivers utiel NVIDIA Linux 21 09-30-02 05:32 PM
NVIDIA drivers won't install... Dnzauker NVIDIA Linux 6 09-12-02 06:47 AM
Nvidia Stereo Drivers Soudontsay NVIDIA Windows Graphics Drivers 2 08-26-02 10:48 AM

All times are GMT -5. The time now is 04:39 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.