Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-26-09, 08:02 AM   #13
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Just got a reply from the manufacturer, but I'm not sure it's the right answer.

I requested a copy of the EDID file for my monitor and they have sent two files:

W193 1440X900-A.ddc
W193 1440X900 -D.ddc

Neither of these is a BIN file, so I'm guessing that this isn't what I'm looking for. As far as I can see from a quick Google search the .ddc suffix indicates that these are Display Data Channel information files, which seems to be a more advanced system than EDID, but, presumably, won't work in this case.
Gewitty is offline   Reply With Quote
Old 06-03-09, 06:14 AM   #14
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

The screen manufacturer have now sent me a couple of different files, which they say are the right EDID info for the Nvidia Xorg config. The two files are:

W193 1440X900-A.dat and W193 1440X900-D.dat

I'm assuming that the A and D suffixes refer to analogue and digital, so I've used the digital file. I put this into my /home/dave/ directory, installed the Nvidia driver, then edited the Device section of the Xorg.conf file to add the line:

Option "CustomEDID" "DFP-0:/home/dave/W193 1440X900-D.dat"

When I rebooted, I got an error saying that the xorg.conf file could not be properly parsed, so I guess I'm either doing something wrong, or the .dat file is not the correct EDID info.

Any thoughts on which it might be?
Gewitty is offline   Reply With Quote
Old 06-08-09, 04:45 AM   #15
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Still no success, but I can't figure out whether this is due to using the wrong EDID file, configuring xorg.conf incorrectly, or just plain stupidity.

I've followed the instructions in Appendix B of the Nvidia driver ReadMe file. This opens up with the statement:

Appendix B. X Config Options

The following driver options are supported by the NVIDIA X driver. They may be
specified either in the Screen or Device sections of the X config file.



In the specific section relating to the use of a custom EDID file, it says:

Option "CustomEDID" "string"

This option forces the X driver to use the EDID specified in a file rather
than the display's EDID. You may specify a semicolon separated list of
display names and filename pairs. The display name is any of "CRT-0",
"CRT-1", "DFP-0", "DFP-1", "TV-0", "TV-1", or one of the generic names
"CRT", "DFP", "TV", which apply the EDID to all devices of the specified
type. The file contains a raw EDID (e.g., a file generated by
nvidia-settings).

For example:

Option "CustomEDID" "CRT-0:/tmp/edid1.bin; DFP-0:/tmp/edid2.bin"

will assign the EDID from the file /tmp/edid1.bin to the display device
CRT-0, and the EDID from the file /tmp/edid2.bin to the display device
DFP-0. Note that a display device name must always be specified even if
only one EDID is specified.


I installed the 185 driver and then edited xorg.conf so it now looks like this:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder62) Sat Apr 4 07:37:37 PST 2009

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 28.0 - 33.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
Option "CustomEDID" "DFP:/home/dave/W193_1440X900-D.dat"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
EndSubSection
EndSection


If I open the W193_1440X900-D.dat file (this is what the screen manufacturer sent me as an EDID file) in a text editor, this is what it contains:

00 FF FF FF FF FF FF 00 1D 65 13 00 0D 00 00 00

03 12 01 03 80 29 1A 78 2E D7 A5 A2 59 4A 96 24

14 50 54 BF EF 00 95 00 81 80 71 8F 00 00 00 00

00 00 00 00 01 01 9A 29 A0 D0 51 84 22 30 50 98

36 00 9A 00 11 00 00 1C 00 00 00 FF 00 31 0A 20

20 20 20 20 20 20 20 20 20 20 00 00 00 FD 00 32

55 1E 52 0E 00 0A 20 20 20 20 20 20 00 00 00 FC

00 57 31 39 33 0A 20 20 20 20 20 20 20 20 00 CA

Can anyone spot the problem here?
Gewitty is offline   Reply With Quote
Old 06-08-09, 05:15 AM   #16
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

From mine (PCI) I have:


Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "UseEvents" "1"
Option "DPI" "100x100"
Option "NoLogo" "1"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 9400 GT"
BusID "PCI:2:0:0"
Screen 1
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Some of this will help. Also can delete the file so the default will be used, then run the config and save the file it writes. Then add the EDID stuff. Let us know.
Dragorep is offline   Reply With Quote
Old 06-08-09, 05:27 AM   #17
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Thanks for the suggestion. Do you have any idea if the EDID file has to a .bin or will the .dat version I received work?
Gewitty is offline   Reply With Quote
Old 06-08-09, 06:09 AM   #18
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

.bin is what the nvidia config saves....so if you haven't tried that one, do so and make sure it can be found too!
Dragorep is offline   Reply With Quote
Old 06-08-09, 07:23 AM   #19
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Not sure I understand that last comment.

The problem (as detailed in earlier posts below) is that Nvidia cannot detect the EDID information coming from my monitor. Therefore, I need to force the use of an EDID file supplied by the monitor manufacturer by including the 'Option' line in the Devices section of xorg.conf.

What I am not clear about is whether the file supplied, which has a .dat extension, will be recognised by Nvidia, which I am told expects a .bin file. With the xorg.conf file shown in my earlier post, the .dat file is not having any effect at all. This may be because Nvidia does not recognise this type of file, or it may be that I have not amended xorg.conf correctly.
Gewitty is offline   Reply With Quote
Old 06-08-09, 01:56 PM   #20
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

The driver needs a raw binary copy of the EDID. It sounds like your ".dat" file contains an ASCII representation of the EDID. Those bytes you pasted in your earlier post were the complete contents of that file, right? I've attached a binary copy of that data that you can try (you'll have to gunzip it first).
Attached Files
File Type: gz edid.bin.gz (125 Bytes, 195 views)
AaronP is offline   Reply With Quote

Old 06-09-09, 05:18 AM   #21
Gewitty
Registered User
 
Join Date: May 2009
Posts: 11
Default SOLVED Re: Unable to set correct resolution for GEFORCE 9400GT in Ubuntu 9.04

Quote:
Originally Posted by AaronP View Post
The driver needs a raw binary copy of the EDID. It sounds like your ".dat" file contains an ASCII representation of the EDID. Those bytes you pasted in your earlier post were the complete contents of that file, right? I've attached a binary copy of that data that you can try (you'll have to gunzip it first).
Aaron, you are a star! Problem solved. I now have a fully working 9400GT.

Many thanks for the help. That one has been bugging me for weeks.
Gewitty is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
8800 GT and Ubuntu - Plymouth low resolution legluondunet NVIDIA Linux 3 06-24-12 03:22 PM
My UT2003 Tweak Guide DXnfiniteFX Gaming Central 48 10-30-02 11:59 PM

All times are GMT -5. The time now is 09:48 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.