Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-09-09, 03:14 AM   #1
RoadRunnr
Registered User
 
Join Date: Jun 2009
Posts: 7
Default black or empty windows on 185.18.14 with many open windows

Hi,

After some uptime with about 12 other windows open any graphics intensive application (e.g. gimp, acrobat reader) will either start with a black window or come up seemingly ok, but appear to be non responsive. Reducing the windows size will redraw the content and show that the application actually did respond, but the window refresh did not make to it to the screen.

Through the 180 and 185 series this has always been a problem for me. Sometimes it took more windows, but with 185.18.14 it has gotten especially bad.

edit: I'm currently running 2.6.30-rc, but the same problem occurs with official 2.6.28 Ubuntu Jaunty kernels.

bug report attached.

Andreas
Attached Files
File Type: gz nvidia-bug-report.log.gz (51.1 KB, 74 views)

Last edited by RoadRunnr; 06-09-09 at 03:17 AM. Reason: add note about kernel version
RoadRunnr is offline   Reply With Quote
Old 06-09-09, 08:02 AM   #2
nevion
Registered User
 
Join Date: Dec 2004
Posts: 74
Default Re: black or empty windows on 185.18.14 with many open windows

Ditto, seems this is still a well known problem. As I recall from nvidia's past responses, this is you running out of video memory. How much ram does your card have? Me? I have 320mB, but it still runs out with a few large windows (I have a 2560x1600 screen) and I have to start kwin --replace to temporarily fix the problem. This happened to me for years on compiz and what caused me to try kde/kwin in the first place ( google black window's bug and compiz, you should get a billion hits).

One thing of importance to ask you is if you are using compositing in kwin or compiz.

@nvidia: howcome kwin --replace or compiz --replace temporarily resolves the problem? It would seem that the same amount of memory is still in use from all non kwin/compiz proceses. Is it just kwin/compiz leaking resources not tracked via normal kernel mechanisms or is this strictly a driver problem? I never see that much real (res)/virtual memory (virt) claimed within my apps change and only kwin (+plasma)/compiz shrinks when restarted as according to htop. xrestop never shows anybody to blame either (there were those plasma leaks of 6 months ago+ but they've all been plugged.. as of this moment I've only got 210 megs in xrestop on a 320 meg 8800gts and I have no problem getting a black fullscreen with mplayer and vo=xv as I type this)

Last edited by nevion; 06-09-09 at 08:06 AM. Reason: fixed wrong url
nevion is offline   Reply With Quote
Old 06-09-09, 11:49 AM   #3
RoadRunnr
Registered User
 
Join Date: Jun 2009
Posts: 7
Default Re: black or empty windows on 185.18.14 with many open windows

well, it finally failed completely:

Code:
Jun  9 18:15:44 ws-aschultz kernel: [115183.766473] Xorg[7002]: segfault at 0 ip 00007fe9a4af34e6 sp 00007fff90c2f040 error 4 in nvidia_drv.so[
7fe9a4a94000+3ac000]
no other messages in any of the logs

My card has 128MB with a 3200x1200 screen (dual monitor).

Andreas
RoadRunnr is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:09 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.