Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-14-09, 12:33 PM   #13
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: proglems with G105M

Somebody please follow the instructions in the sticky posts about how to report a problem and please also attach a photograph of the "six little screens" problem.
AaronP is offline   Reply With Quote
Old 06-14-09, 01:37 PM   #14
kevinttl
Kevin Chen
 
Join Date: Jun 2009
Posts: 4
Default Re: proglems with G105M

Hi,
My Acer5738 jaunty 64 with xorg.conf post before,
2 snapshots in attachments.
Attached Thumbnails
Click image for larger version

Name:	Screenshot.jpg
Views:	880
Size:	100.4 KB
ID:	37209  Click image for larger version

Name:	Screenshot-1.jpg
Views:	714
Size:	100.5 KB
ID:	37210  
kevinttl is offline   Reply With Quote
Old 06-14-09, 03:35 PM   #15
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: proglems with G105M

Quote:
Originally Posted by kevinttl View Post
Hi,
My Acer5738 jaunty 64 with xorg.conf post before,
2 snapshots in attachments.
Whats wrong here?
Both screens look fine to me...
Dragoran is offline   Reply With Quote
Old 06-14-09, 04:35 PM   #16
kevinttl
Kevin Chen
 
Join Date: Jun 2009
Posts: 4
Default Re: proglems with G105M

Quote:
Originally Posted by Dragoran View Post
Whats wrong here?
Both screens look fine to me...
yeah, it's successful snapshots.
I hv encountered 6 screens situation,
and finally make it works.
That's the final result.
Maybe people who sufferred with 6 screens could try my way.
kevinttl is offline   Reply With Quote
Old 06-15-09, 02:01 AM   #17
askb
Registered User
 
Join Date: Jun 2009
Posts: 9
Default Re: proglems with G105M

Hi AaronP, Kevin

Attached log generated from from 'sh nvidia-bug-report.sh'.

lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub [8086:2a40] (rev 07)
00:01.0 PCI bridge [0604]: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port [8086:2a41] (rev 07)
00:1a.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 [8086:2937] (rev 03)
00:1a.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 [8086:2938] (rev 03)
00:1a.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 [8086:293c] (rev 03)
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
00:1c.0 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 [8086:2940] (rev 03)
00:1c.1 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 [8086:2942] (rev 03)
00:1c.2 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 [8086:2944] (rev 03)
00:1c.4 PCI bridge [0604]: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 [8086:2948] (rev 03)
00:1d.0 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 [8086:2934] (rev 03)
00:1d.1 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 [8086:2935] (rev 03)
00:1d.2 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 [8086:2936] (rev 03)
00:1d.3 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 [8086:2939] (rev 03)
00:1d.7 USB Controller [0c03]: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 [8086:293a] (rev 03)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev 93)
00:1f.0 ISA bridge [0601]: Intel Corporation ICH9M LPC Interface Controller [8086:2919] (rev 03)
00:1f.2 SATA controller [0106]: Intel Corporation ICH9M/M-E SATA AHCI Controller [8086:2929] (rev 03)
00:1f.3 SMBus [0c05]: Intel Corporation 82801I (ICH9 Family) SMBus Controller [8086:2930] (rev 03)
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:06ec] (rev a1)
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM5784M Gigabit Ethernet PCIe [14e4:1698] (rev 10)
04:00.0 Network controller [0280]: Intel Corporation Wireless WiFi Link 5100 [8086:4232]
Appologize, I dont have any experience with X11/xorg.conf, but here is my xorg.conf which is displays "six little screens". Also, I am using opensuse 11.1 and not Ubuntu 9.04 for the movement and following are the kernel rpms installed.
kernel-pae-extra-2.6.27.23-0.1.1
kernel-pae-2.6.27.23-0.1.1
linux-kernel-headers-2.6.27-2.28
kernel-pae-base-2.6.27.23-0.1.1
kernel-source-2.6.27.23-0.1.1
# /.../
# SaX generated X11 config file
# Created on: 2009-06-10T12:36:41+0530.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [ISaX] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "Files"
FontPath "/usr/share/fonts/misc:unscaled"
FontPath "/usr/share/fonts/local"
FontPath "/usr/share/fonts/75dpi:unscaled"
FontPath "/usr/share/fonts/100dpi:unscaled"
FontPath "/usr/share/fonts/Type1"
FontPath "/usr/share/fonts/URW"
FontPath "/usr/share/fonts/Speedo"
FontPath "/usr/share/fonts/PEX"
FontPath "/usr/share/fonts/cyrillic"
FontPath "/usr/share/fonts/latin2/misc:unscaled"
FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
FontPath "/usr/share/fonts/latin2/Type1"
FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
FontPath "/usr/share/fonts/baekmuk:unscaled"
FontPath "/usr/share/fonts/japanese:unscaled"
FontPath "/usr/share/fonts/kwintv"
FontPath "/usr/share/fonts/truetype"
FontPath "/usr/share/fonts/uni:unscaled"
FontPath "/usr/share/fonts/CID"
FontPath "/usr/share/fonts/ucs/misc:unscaled"
FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/misc:unscaled"
FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
FontPath "/usr/share/fonts/hellas/Type1"
FontPath "/usr/share/fonts/misc/sgi:unscaled"
FontPath "/usr/share/fonts/xtest"
FontPath "/opt/kde3/share/fonts"
InputDevices "/dev/gpmdata"
InputDevices "/dev/input/mice"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
Option "ZapWarning" "on"
EndSection

Section "Module"
Load "dri"
Load "dbe"
Load "freetype"
Load "extmod"
Load "glx"
EndSection

Section "InputDevice"
Driver "kbd"
Identifier "Keyboard[0]"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "microsoftpro"
Option "XkbRules" "xfree86"
EndSection


Section "InputDevice"
Driver "mouse"
Identifier "Mouse[1]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Name" "SIGMACH1P U+P Mouse"
Option "Protocol" "explorerps/2"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "Mouse[3]"
Option "Buttons" "5"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "on"
Option "HorizScrollDelta" "0"
Option "InputFashion" "Mouse"
Option "Name" "Synaptics;Touchpad"
Option "Protocol" "explorerps/2"
Option "SHMConfig" "on"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection


Section "Monitor"
Option "CalcAlgorithm" "XServerPool"
HorizSync 30-38
Identifier "Monitor[0]"
ModelName "800X600@60HZ"
Option "DPMS"
Option "PreferredMode" "800x600"
VendorName "--> LCD"
VertRefresh 30-61
UseModes "Modes[0]"
EndSection


Section "Modes"
Identifier "Modes[0]"
EndSection


Section "Screen"
SubSection "Display"
Depth 16
Modes "default"
EndSubSection
Device "Device[0]"
Identifier "Screen[0]"
Monitor "Monitor[0]"
EndSection


Section "Device"
BoardName "Framebuffer Graphics"
Driver "fbdev"
Identifier "Device[0]"
VendorName "VESA"
EndSection



Section "ServerLayout"
Identifier "Layout[all]"
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
InputDevice "Mouse[3]" "SendCoreEvents"
Option "Clone" "off"
Option "Xinerama" "off"
Screen "Screen[0]"
EndSection


Section "DRI"
Group "video"
Mode 0660
EndSection

Section "Extensions"
EndSection

Later, I tried the xorg.conf posted be kevinttl, but i only got a garbled screen (not actually garbled, but only 1/4 of sax configuration screen being visible).

Can you please let me know, if there are only some specific changes which i need to appled on my xorg.conf? kindly note i am an linux newbie.


Thanks in advance,
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.4 KB, 186 views)
askb is offline   Reply With Quote
Old 06-15-09, 05:15 AM   #18
askb
Registered User
 
Join Date: Jun 2009
Posts: 9
Default Re: proglems with G105M

I am unable to get the screen shot of the "6 little screen", every time i hit the print scr button this only give one of the screens, instead of 6. The only thing i could do is get a shot from my cam!!
askb is offline   Reply With Quote
Old 06-15-09, 10:51 AM   #19
szamaniak
Registered User
 
Join Date: Apr 2009
Posts: 12
Default Re: proglems with G105M

Quote:
Originally Posted by kevinttl View Post
Hi,
My notebook is Acer 5738G(G105m) with jaunty 64.
I downloaded 185.18.14 and installed, then i got 6 screens as some guys said.
After some try-n-errors, i think i've made it works.
Here is my xorg.conf:

Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
	Identifier	"TouchPad"
	Driver "synaptics"
	Option "device" "/dev/input/event8"
#	Option "TapButton1" "0"
#	Option "TapButton2" "0"
	Option "HorizEdgeScroll" "False"
	Option "VertTwoFingerScroll" "True"
	Option "HorizTowFingerScroll" "True"
#	Option "TouchpadOff" "2"
	Option "SHMConfig" "False"
EndSection

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
#    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "TouchPad" "CorePinter"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
#    HorizSync       30.0 - 100.0
#    VertRefresh     55.0 - 110.0
#    DisplaySize	344 193
#    Mode	"1366x768"
#	DotClock	69.5MHz
#	HTimings	1366 1414 1446 1437
#	VTimings	768 771 775 806
#    EndMode
# Modeline "1366x768"   69.50  1366 1414 1446 1437  768 771 775 806
 Modeline "1366x768"   69.50  1366 1414 1446 1473  768 771 775 806 -hsync -vsync
# Modeline "1366x768q"   72.00  1366 1414 1446 1494  768 771 777 803 -hsync -vsync
#    Option "DPMS" "True"
EndSection

#Section "Device"
#    Identifier     "Configured Video Device"
#    Driver         "nvidia"
#EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce G 105M"
    Option "NvAGP" "0"
#    Option "UseInt10Module" "True"
#    Option "UseEDID" "False"
    Option "ExactModeTimingsDVI" "True"
    Option "ModeValidation" "NoHorizSyncCheck,NoDFPNativeResolutionCheck,NoExtendedGpuCapabilitiesCheck,NoWidthAlignmentCheck,NoVertRefreshCheck"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    SubSection     "Display"
	Modes	"1366x768"
        Depth       24
    EndSubSection
EndSection
Maybe there's still something need to be modified and/or optimized.

Good luck.
Hello,
following this xorg.conf the '6 screens problem' dissapeared, but the stability and performance problems started so I had to go back to the nv driver (my system was hunging for few times).
szamaniak is offline   Reply With Quote
Old 06-15-09, 12:33 PM   #20
kevinttl
Kevin Chen
 
Join Date: Jun 2009
Posts: 4
Default Re: proglems with G105M

ok, revised one, should be stable... (I hv tested under some sort of heavy loading conditions)
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
	Identifier	"TouchPad"
	Driver "synaptics"
	Option "device" "/dev/input/event8"
#	Option "TapButton1" "0"
#	Option "TapButton2" "0"
	Option "HorizEdgeScroll" "False"
	Option "VertTwoFingerScroll" "True"
	Option "HorizTowFingerScroll" "True"
#	Option "TouchpadOff" "2"
	Option "SHMConfig" "False"
EndSection

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
#    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "TouchPad" "CorePinter"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
    Option	"AIGLX"	"False"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

#Section "InputDevice"
#    # generated from default
#    Identifier     "Mouse0"
#    Driver         "mouse"
#    Option         "Protocol" "auto"
#    Option         "Device" "/dev/psaux"
#    Option         "Emulate3Buttons" "no"
#    Option         "ZAxisMapping" "4 5"
#EndSection

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AUO"
#    HorizSync       30.0 - 100.0
#    VertRefresh     55.0 - 110.0
    DisplaySize	344 193
#    Mode	"1366x768"
#	DotClock	69.5MHz
#	HTimings	1366 1414 1446 1437
#	VTimings	768 771 775 806
#    EndMode
# Modeline "1366x768"   69.50  1366 1414 1446 1437  768 771 775 806
 Modeline "1366x768"   69.50  1366 1414 1446 1446  768 771 775 806 -hsync -vsync
# Modeline "1366x768q"   72.00  1366 1414 1446 1494  768 771 777 803 -hsync -vsync
#    Option "DPMS" "True"
EndSection

#Section "Device"
#    Identifier     "Configured Video Device"
#    Driver         "nvidia"
#EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce G 105M"
    Option "NvAGP" "0"
#    Option "UseInt10Module" "True"
    Option "UseEDID" "False"
    Option "AllowSHMPixmaps" "True"
    Option "ExactModeTimingsDVI" "True"
    Option "ModeValidation" "NoHorizSyncCheck,NoDFPNativeResolutionCheck,NoExtendedGpuCapabilitiesCheck,NoWidthAlignmentCheck,NoVertRefreshCheck"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    SubSection     "Display"
	Modes	"1366x768"
        Depth       24
    EndSubSection
EndSection
and, askb, it seems that your X is controlled by "SaX".
Could you make sure that if you replace xorg.conf the "Sax" would not
mess it up?

BTW, I bought this notebook with 2G on board and another 2G for free.
But the problem is that you need two identical DDR3 rams to work well.
You can try to left one 2G DDR3 then test. Maybe two different DDR3 is the stable problem.
kevinttl is offline   Reply With Quote

Old 06-15-09, 02:47 PM   #21
szamaniak
Registered User
 
Join Date: Apr 2009
Posts: 12
Default Re: proglems with G105M

thanks to kevinttl I've changed my xorg.conf and performance now is very good. but something very strange is happening - while using nvidia driver, my internet connection for few times was extremely slow and provided to the halt of the system (it just stopped responding while I was using firefox).
I don't have any idea how to check what is going with that (I am using pppoatm)
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.9 KB, 169 views)
szamaniak is offline   Reply With Quote
Old 06-15-09, 08:24 PM   #22
askb
Registered User
 
Join Date: Jun 2009
Posts: 9
Default Re: proglems with G105M

Quote:
Originally Posted by kevinttl View Post
and, askb, it seems that your X is controlled by "SaX".
Could you make sure that if you replace xorg.conf the "Sax" would not
mess it up?
kevin, thr is a lot of diffirence between xorg.conf you posted and the one i find on my box. Can you let me know what changes I would need to make for my conf file ?

After, I saving the xorg.conf, I usually start it as follows:

'sax2 -r -m 0=nvidia' (0 = ZERO)

can you let me know if its correct
askb is offline   Reply With Quote
Old 06-15-09, 10:24 PM   #23
askb
Registered User
 
Join Date: Jun 2009
Posts: 9
Default Re: proglems with G105M

I can get 1366x766 resolution by setting the driver section to 'nv' instead of nvidia.

Section "Device"
Identifier "Device0"
Driver "nv"

AUO LCD monitor is available in the list of LCD display monitors available ??

However, all the 3D desktop effects and opengl screen savers are disabled or not working ???

I dont know if this is something that has to do as a bug with nvidia driver / kernel or the opensuse configuration ??

attached screenshot
Attached Thumbnails
Click image for larger version

Name:	X11.jpg
Views:	423
Size:	85.1 KB
ID:	37218  
askb is offline   Reply With Quote
Old 06-18-09, 07:38 AM   #24
rabonch
Registered User
 
Join Date: May 2009
Posts: 2
Default Re: proglems with G105M

,,,,copy and paste the xorg.conf of kevinttl ....http://www.nvnews.net/vbulletin/atta...1&d=1245328636
(and my notebook works with no problems)
Attached Thumbnails
Click image for larger version

Name:	Schermata.jpg
Views:	1060
Size:	49.9 KB
ID:	37245  

Last edited by rabonch; 06-24-09 at 04:14 PM.
rabonch is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
nvidia g105m and archlinux svk__wlad NVIDIA Linux 0 06-09-12 07:31 AM

All times are GMT -5. The time now is 05:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.