Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-17-09, 01:33 PM   #1
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

So I've bought a new Zotac IONITX-C-E mainboard, and jerky playback issues are back :-(

I'm currently using 180.60 and jyavenard repository, on Jaunty

I attach here the nvidia bug report. Faulty AVC DVB-T captured stream sample is available at http://www.resolutions.it/jerky.ts (it's the same sample of the previous posting regarding 8400GS)

Bye,
rob
Attached Files
File Type: gz nvidia-bug-report.log.gz (32.0 KB, 76 views)
resoli is offline   Reply With Quote
Old 06-18-09, 06:54 AM   #2
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Some more information:
- mplayer -mc 2 -vo vdpau:deint=2 -vc ffh264vdpau jerky.ts plays the stream quite well.
- I tried also 184.18.14 both installing them manually and from jya "testing" repo, without success.
- mythtv plays very well 1080p AVC files
resoli is offline   Reply With Quote
Old 06-18-09, 08:33 AM   #3
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by resoli View Post
mplayer -vo -mc 2 vdpau:deint=2 -vc ffh264vdpau jerky.ts plays the stream quite well.
So what is your problem (except for posting a non-working command line: -mc 2 get into -vo)?

Carl Eugen
cehoyos is offline   Reply With Quote
Old 06-18-09, 10:07 AM   #4
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by cehoyos View Post
So what is your problem
My problem is that mythtv playback is very bad (really worse than with same driver on 8400GS)

Quote:
Originally Posted by cehoyos View Post
(except for posting a non-working command line: -mc 2 get into -vo)?

Carl Eugen
oops... corrected, thanks.
resoli is offline   Reply With Quote
Old 06-18-09, 10:37 AM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Does MythTV play this clip correctly using SW decoding?
Stephen Warren is offline   Reply With Quote
Old 06-18-09, 11:08 AM   #6
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by Stephen Warren View Post
Does MythTV play this clip correctly using SW decoding?
I have not done a real test, because i guess N230 is too weak for sw decoding, but at least I can tell if at least playback, even with stuttering, is more regular (with vdpau decoding, there is macro blocking, the image seems to go back and forth, or stops for a few secods ...).

I will try and report here.

thanks,
rob
resoli is offline   Reply With Quote
Old 06-18-09, 02:53 PM   #7
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Test in mythtv with sw decoding profile:
As expected, cpu constantly at 100%, but the image is very neat.
Watching right now live footbool match Italy vs Egypt, with vdpau image is completely garbled.

Here i attach the log of mythtv -v playback jerky.ts with

export VDPAU_TRACE=1
export VDPAU_NVIDIA_DEBUG=3
Attached Files
File Type: gz myth-vdpau_debug_playback.log.gz (9.0 KB, 75 views)
resoli is offline   Reply With Quote
Old 06-18-09, 03:22 PM   #8
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Attached the output of :
mplayer -fs -mc 2 -vo vdpau:deint=2 -vc ffh264vdpau jerky.ts
Attached Files
File Type: gz mplayer-vdpau_debug_playback.log.gz (11.2 KB, 77 views)
resoli is offline   Reply With Quote

Old 06-18-09, 08:56 PM   #9
sgriffin
Registered User
 
Join Date: May 2009
Posts: 3
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by resoli View Post
Attached the output of :
mplayer -fs -mc 2 -vo vdpau:deint=2 -vc ffh264vdpau jerky.ts
Looks like you are selecting the wrong output codec. Try:

mplayer -fs -mc 2 -vo vdpau:deint=2 -vc ffmpeg12vdpau jerky.ts

Note this works for most videos, but for very high bitrates you may need to hack your vo_vdpau file to remove the block until idle call (around line 249). From what I can read about beta 185.19, this will be fixed.
sgriffin is offline   Reply With Quote
Old 06-19-09, 05:03 AM   #10
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by sgriffin View Post
Looks like you are selecting the wrong output codec. Try:

mplayer -fs -mc 2 -vo vdpau:deint=2 -vc ffmpeg12vdpau jerky.ts
jerky.ts is AVC/h.264 encoded, not mpeg2 ....

Code:
 mediainfo jerky.ts
General
ID                               : 5
Complete name                    : jerky.ts
Format                           : MPEG-TS
File size                        : 8.00 MiB
Duration                         : 6s 808ms
Overall bit rate                 : 9 857 Kbps

Video
ID                               : 535 (0x217)
Menu ID                          : 1 (0x1)
Format                           : AVC
Format/Info                      : Advanced Video Codec
Format profile                   : High@L4.0
Format settings, CABAC           : Yes
Format settings, ReFrames        : 4 frames
Duration                         : 6s 808ms
Bit rate                         : 8 981 Kbps
Width                            : 1 920 pixels
Height                           : 1 080 pixels
Display aspect ratio             : 16/9
Frame rate                       : 25.000 fps
Resolution                       : 24 bits
Colorimetry                      : 4:2:0
Scan type                        : MBAFF
Bits/(Pixel*Frame)               : 0.173
Stream size                      : 7.29 MiB (91%)

Audio
ID                               : 545 (0x221)
Menu ID                          : 1 (0x1)
Format                           : MPEG Audio
Format version                   : Version 1
Format profile                   : Layer 2
Duration                         : 6s 528ms
Bit rate mode                    : Constant
Bit rate                         : 192 Kbps
Channel(s)                       : 2 channels
Sampling rate                    : 48.0 KHz
Resolution                       : 16 bits
Video delay                      : -956ms
Stream size                      : 153 KiB (2%)
Language                         : Italian

Last edited by resoli; 06-19-09 at 06:11 AM. Reason: typo
resoli is offline   Reply With Quote
Old 06-19-09, 07:12 AM   #11
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Another note:

Powermizer in nvidia-settings reports:

Power Source: Battery
(see attached image)
Attached Thumbnails
Click image for larger version

Name:	Schermata-NVIDIA X Server Settings.jpg
Views:	230
Size:	50.0 KB
ID:	37258  
resoli is offline   Reply With Quote
Old 06-19-09, 10:29 AM   #12
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

What does the PowerMizer page say when actually playing back video? There may be a difference between SD and HD video here. On an ION, I'd expect a high level to be automatically selected for video playback (at least with 185.18.14 and later)

The fact it says "battery" rather than "ac" (or whatever the text is) could affect the performance levels PowerMizer chooses.
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.