Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-01-09, 01:44 PM   #1
cyberf0x
Registered User
 
Join Date: Jun 2004
Posts: 50
Default 185.18.14 complete hang up....

Hello people, I was wondering how's the driver status so I tried the prerelase.

Kernel 2.6.29.4, pat, maxcpus=2, no msi, X.Org X Server 1.6.1.901, Enlightenment, composite disabled

Code:
(--) PCI:*(0@1:0:0) nVidia Corporation GeForce 8700M GT rev 161, Mem @ 0xf6000000/16777216, 0xd0000000/268435456, 0xf4000000/33554432, I/O @ 0x00002000/128
(II) NVIDIA(0): NVIDIA GPU GeForce 8700M GT (G84) at PCI:1:0:0 (GPU-0)
(--) NVIDIA(0): Memory: 524288 kBytes
(--) NVIDIA(0): VideoBIOS: 60.84.51.00.21
(II) NVIDIA(0): Detected PCI Express Link width: 16X
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce 8700M GT at PCI:1:0:0:
(--) NVIDIA(0):     Seiko (DFP-0)
(--) NVIDIA(0): Seiko (DFP-0): 330.0 MHz maximum pixel clock
(--) NVIDIA(0): Seiko (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Assigned Display Device: DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0):     "nvidia-auto-select"
(II) NVIDIA(0): Virtual screen size determined to be 1440 x 900
(--) NVIDIA(0): DPI set to (98, 99); computed from "UseEdidDpi" X config
(--) NVIDIA(0):     option
(==) NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
glxgears after few seconds
NVRM: Xid (0001:00): 28, CCMDs 00000001 00007476 00000184 0000047c 00000000
plus complete hangup, magic sysrq doesn't respond, both coolers for GPU/CPU are full speed, only power button works

Same issue with : kernel 2.6.29.1, pat, maxcpus=2, msi or nomsi, Xorg 1.6.0, enlightenment+glxgears

So for now i'm still sticking with 180.60, it has it's own issues with garbled screen, xorg segfaults and other nice features depending on configuration but at least it doesn't freeze whole system.

Oh and btw. I was worried that only the linux driver doesn't work as it should but then I did fresh install of Vista+ latest WHQL driver and I was so happy to see BSOD so I went back to my 180.60 and the garbled screen looks so nice now
cyberf0x is offline   Reply With Quote
Old 06-01-09, 05:45 PM   #2
jyavenard
MythTV developer
 
Join Date: Mar 2006
Posts: 413
Default Re: 185.18.14 complete hang up....

I've noticed the same thing using VDPAU in mythtv or mplayer.

Every once in a while, I get a complete lock-up. Must hard reset the PC as nothing else respond.

180.60 didn't give me any hard crash like that
jyavenard is offline   Reply With Quote
Old 06-18-09, 10:17 AM   #3
cyberf0x
Registered User
 
Join Date: Jun 2004
Posts: 50
Default Re: 185.18.14 complete hang up....

Hello again

I just wanted to ask if this bug is going to be fixed before 2011?
(not to mention 6 month old screen corruption bug for 180.60)
cyberf0x is offline   Reply With Quote
Old 06-29-09, 01:38 PM   #4
cyberf0x
Registered User
 
Join Date: Jun 2004
Posts: 50
Default Re: 185.18.14 complete hang up....

Heh

I solved at least one thing.
Using 180.60. Added two things.
IgnoreDisplayDevices "CRT,TV", nothing special
"InitializeWindowBackingPixmaps" "False" <- according to readme this shouldn't work for newer xorg servers. Howerver for me it solved at least the damn screen corruption. Now i can have dozen windows open (using gtk or qt) in KDE and it's dead stable for me. No more screen corruption.

So using xorg 1.6.1.901, kernel 2.6.30, MSI enabled for everything, (even forced the nvidia module to use MSI and PAT), plus this experimental DMA remapping and KDE 4.2.x and adding those above options solved the corruption for me. ( i think so, laptop running for 3 days now, still no corruption)

I didn't test 185.x yet. I know that those 190.x are segfaulting whole xorg right after starting any OpenGL app. So no 190.x for me.

One thing that is not yet solved is the complete hang up(185.x) or flicker and segfault(180.60 for some GL apps). Maybe it's a race condition between GL contexts from let's say KDE plasma, some gtk app that i'm running and pure OpenGL app / game. Not sure. but for now no screen corruption for me
cyberf0x is offline   Reply With Quote
Old 06-29-09, 03:41 PM   #5
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: 185.18.14 complete hang up....

Quote:
Originally Posted by jyavenard View Post
I've noticed the same thing using VDPAU in mythtv or mplayer.

Every once in a while, I get a complete lock-up. Must hard reset the PC as nothing else respond.
I get that as well with the 185.18.14 driver and can't begin to tell you how much I HATE that bug! Hopefully the next release will have it fixed since that one has a deinterlace bug fix as well that I reported.
primerib is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Daily Deal - Spore Complete and Darkspore, 75% off! News Gaming Headlines 0 06-13-12 06:30 PM
Daily Deal - Far Cry Complete, 75% off! News Gaming Headlines 0 06-06-12 01:50 PM
Joss Whedon: The Complete Companion: Must-Have for Whedon Fans News Archived News Items 0 05-06-12 11:00 AM
3123 drivers cause system hang kgf NVIDIA Linux 5 09-28-02 07:32 AM
hang up.... sekunda NVIDIA Linux 4 08-07-02 09:24 AM

All times are GMT -5. The time now is 04:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.