Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-05-09, 08:57 AM   #1
apriori
Registered User
 
Join Date: Nov 2008
Posts: 22
Default 185.15.14 - 8800MGTX: Lockup with graphic errors and weird cache collision

Hi NVIDIA,

I got a problem. When e.g. running KDE4 (though that doesn't really matter) I unfortunately often encounter cases in which my LCD turns to pure red and the X server seems to lock up. Sometimes I got about 2-3 seconds to react (meaning e.g. switch to a physical console to restart the X server) but usually this results in a hard lockup, because virtually all input events are ignored. When this happens, the card seems to confuse cache positions and ownerships resulting in e.g. konqueror content drawn on e.g. amarok. I can't make a screenshot, because, as already said, input events are pretty much ignored and the CTRL+ALT+F1 seems the only exit. mouse etc. are not working.
To sum up, the following does occur:
1. LCD turns to pure red for about 1-2 seconds
2: LCD starts flickering between normal image and pure red for several seconds (varying)
3. "Cache confusion" starts
4. Hard lockup if you don't react early.
- its NOT an interrupt lockup, meaning e.g. music played in background continues to play at least for 10 secs. Then crackling starts
5. another thing starting about 2 seconds after point 2 is, that the graphic cards fan starts powering up to maximum, so I assume the gpu is busy doing massive work it shouldnt actually do.

Several more things to mention:
1. Usage of OpenGL seems to increase the probability that this issue occurs - e.g. kwin with composite
2. Sometimes the lockup occurs right after firing up an OpenGL app or game
3. The red picture thingy also occurs for times << 1 sec if a second screen is attached and usually only for the primary display.

I doubt it is a heat problem, because the card actually never even reaches 60°C.

Regards

apriori
Attached Files
File Type: gz nvidia-bug-report.log.gz (27.7 KB, 88 views)
apriori is offline   Reply With Quote
Old 07-05-09, 09:03 AM   #2
apriori
Registered User
 
Join Date: Nov 2008
Posts: 22
Default Re: 185.15.14: Lockup with graphic errors and weird cache collision

The attached bugreport.gz was incomplete, attached a new one. Btw. both were done after a reboot therefore likely to mask the actual issue.
Attached Files
File Type: gz nvidia-bug-report.log.gz (28.2 KB, 87 views)
apriori is offline   Reply With Quote
Old 07-08-09, 08:01 PM   #3
UncleDeadley
Registered User
 
Join Date: Jul 2009
Posts: 3
Default Re: 185.15.14: Lockup with graphic errors and weird cache collision

Hi, I have a problem exhibiting the same issues as OP, only I don't get the red screen. I was, however, fast enough with CTR-ALT-F1 to get to a tty so that I could run the logger after the problem manifested. Also, the 173.14.20 driver works fine, without errors. Is there a particular version of driver I should try to help narrow down the change that induces the problem?

System, which I chose because of nvidia linux support, is ASUS n50vn-a1b notebook with a 9650M GT.
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.1 KB, 76 views)
UncleDeadley is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright İ1998 - 2014, nV News.