Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-04-09, 03:51 PM   #1
David Ronis
Registered User
 
Join Date: Aug 2009
Posts: 16
Default 185.18.31 and 190.18 fail: missing symbol resVgaShared

I just upgraded xorg to the current git master (see below for some version information).
The build went fine, and works with their nv driver. I'd been running the nvidia driver (with xinerama) before upgrading. In any event, (re)installing the drivers mentioned in the title doesn't work; specifically, they fail to load, complaining that the symbol resVgaShared is not defined. Sure enough, running nm on nvidia_drv.so confirms that.

What seems to have happened is that things defined in or related to xf86Resources.h have been deprecated in the last 3-4 months (which is when I last upgraded xorg).

I have filed a bug-report, but was hoping that there would be a "quick" solution here.

David

Here's what Xorg -version gives:

X.Org X Server 1.6.99.1
Release Date: (unreleased)
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30.3 i686
Current Operating System: Linux ronispc 2.6.30.4 #40 SMP PREEMPT Fri Jul 31 17:29:35 EDT 2009 i686
Build Date: 03 August 2009 07:46:19PM
David Ronis is offline   Reply With Quote
Old 08-04-09, 06:04 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

Yes, that stuff has been removed from the server. I modified the driver to make it work with the version of ABI 6 that's in git master, but that support is not in the current releases. I'm hoping to get preliminary support for the RAC removal change in the next (probably beta) release.

Dave Airlie's change was pretty recent. If you don't need the absolutely latest version, you ought to be able to roll back to right before that change to get a server that works with the current driver release.
AaronP is offline   Reply With Quote
Old 08-04-09, 07:21 PM   #3
David Ronis
Registered User
 
Join Date: Aug 2009
Posts: 16
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

Thanks for the reply. Right now I'm using the nv driver, which, with the exception of of xinerama, works. Any idea when the next beta will be out?
David Ronis is offline   Reply With Quote
Old 08-04-09, 07:35 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

No, I can't speculate about release dates, sorry.
AaronP is offline   Reply With Quote
Old 08-05-09, 04:05 PM   #5
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

For those scoring along at home this is the commit before the xserver RAC/resource handling code changes...

http://cgit.freedesktop.org/xorg/xse...a6a387b1f2928d
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 08-21-09, 03:23 PM   #6
David Ronis
Registered User
 
Join Date: Aug 2009
Posts: 16
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

I just tried 185.18.36. I guess aaron meant it when he said it wouldn't be in the next release..
David Ronis is offline   Reply With Quote
Old 08-21-09, 03:49 PM   #7
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

Yeah, that change won't be in 185.18.*, but it should be in the next 190.* release which should hopefully come out soon.
AaronP is offline   Reply With Quote
Old 08-22-09, 02:14 PM   #8
vallimar
Registered User
 
Join Date: Aug 2008
Posts: 22
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

Error is gone in driver release 190.25, out today.
Note that you still need to pass the ignoreABI option though.
vallimar is offline   Reply With Quote

Old 08-22-09, 04:31 PM   #9
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 185.18.31 and 190.18 fail: missing symbol resVgaShared

Quote:
Originally Posted by vallimar View Post
Error is gone in driver release 190.25, out today.
Note that you still need to pass the ignoreABI option though.
ignoreABI will be needed until the ABI is declared stable.
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.