Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-28-09, 11:44 AM   #1
Sky777
Registered User
 
Join Date: May 2007
Posts: 65
Default 190.25 - can't compile XBMC - checking for main in -lGL... no

I can't compile today svn XBMC at all with 190.25

Quote:
checking for main in -lGL... no

configure: error: Could not find a required library. Please see the README for your platform.
I think nvidia drivers should provide that GL lib - right ?

see the comments from XBMC developper
http://xbmc.org/forum/showpost.php?p=392096&postcount=5

Quote:
One thing is, don't use 190.25. Driver is broken and won't allow you to compile XBMC. Stick with 190.18... Works fine.

in attach you can find nvidia-bug-report.log.gz

ps
I could compile xbmc with 190.18 without any problems
Attached Files
File Type: gz nvidia-bug-report.log.gz (60.7 KB, 157 views)
__________________
PCI Sparkle GeForce 8400 GPU G98 A2 512 MB + AMD Sempron(tm) Processor 2800+ + svn Mplayer + xine-vdpau rev. 279 + vdr 1.7.9 & Nvidia 190.25 + XBMC
Sky777 is offline   Reply With Quote
Old 08-28-09, 12:33 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 190.25 - can't compile XBMC - checking for main in -lGL... no

This is probably related to the unresolved symbol problem in /usr/lib/libnvidia-tls.so.1. It will be fixed in the next release, so please try that when it comes out.

Before anyone asks, no, I can't give an estimate of when that will be.
AaronP is offline   Reply With Quote
Old 08-28-09, 01:28 PM   #3
Sky777
Registered User
 
Join Date: May 2007
Posts: 65
Default Re: 190.25 - can't compile XBMC - checking for main in -lGL... no

sure I will try next beta

currently I am using a workaround - I installed 190.18 branch, after that I compiled XBMC, after that I installed 190.25 branch
__________________
PCI Sparkle GeForce 8400 GPU G98 A2 512 MB + AMD Sempron(tm) Processor 2800+ + svn Mplayer + xine-vdpau rev. 279 + vdr 1.7.9 & Nvidia 190.25 + XBMC
Sky777 is offline   Reply With Quote
Old 08-28-09, 02:19 PM   #4
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: 190.25 - can't compile XBMC - checking for main in -lGL... no

Same thing happens compiling 32-bit Wine. With the libGL.so & libGL.so.1 link set to /usr/lib32/libGL.so.190.25 configure says it can't find -lGL or -lGLU. I compiled a 32-bit mesa libGL and it picks up the symbolic link to /usr/lib32/libGL.so.1.2(mesa). So it's just a matter of switching symbolic links for building.
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.