Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-04-09, 05:00 PM   #157
raptorjr
Registered User
 
Join Date: Sep 2009
Posts: 8
Default Re: VDPAU testing tool

Quote:
Originally Posted by Stephen Warren View Post
raptorjr, Double-check any CPU-/bus-throttling settings. Perhaps bad performance correlates with a throttled CPU? Also, open nvidia-settings to the PowerMizer page and make sure it isn't stuck at the lowest setting when playing video.
The cpu was set for "ondemand", and was currently on 2.0Ghz. I now changed to "performance" and the cpu is always on 2.67Ghz. On the first qvdpautest after i changed this i got the same bad numbers as before. Tried several more times, but still bad numbers.
If i understand nvidia-settings correctly i only have one setting for PowerMizer, and that cant be changed?

Attribute 'GPUPerfModes' (tvdator:0.0): perf=0, nvclock=550, memclock=400

But i must say that i really appreciate all the help i'm getting. I really hope that i find what is wrong before everyone get tired of me =)
raptorjr is offline   Reply With Quote
Old 09-10-09, 05:00 AM   #158
raptorjr
Registered User
 
Join Date: Sep 2009
Posts: 8
Default Re: VDPAU testing tool

Quote:
Originally Posted by raptorjr View Post
... before everyone get tired of me =)
That didn't take long =( Well, it would be really nice if it worked but i can always continue with CoreAVC. Will try new versions of the driver when it is available, maybe i'll get lucky to get it to work.
raptorjr is offline   Reply With Quote
Old 09-10-09, 07:08 AM   #159
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: VDPAU testing tool

Quote:
Originally Posted by raptorjr View Post
Code:
Matroska file format detected.
VIDEO:  [avc1]  1920x1080  24bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
==========================================================================
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] XVMC-accelerated MPEG-2.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
==========================================================================
==========================================================================
Opening audio decoder: [liba52] AC3 decoding with liba52
Using SSE optimized IMDCT transform
Using MMX optimized resampler
AUDIO: 48000 Hz, 2 ch, s16le, 448.0 kbit/29.17% (ratio: 56000->192000)
Selected audio codec: [a52] afm: liba52 (AC3-liba52)
==========================================================================
AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
[VD_FFMPEG] XVMC-accelerated MPEG-2.
VDec: vo config request - 1920 x 1080 (preferred colorspace: H.264 VDPAU acceleration)
VDec: using H.264 VDPAU acceleration as output csp (no 0)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration  [fs]
I guess it looks right for VDPAU?
Who can tell (since it is not complete and uncut)?

Carl Eugen
cehoyos is offline   Reply With Quote
Old 09-10-09, 01:48 PM   #160
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: VDPAU testing tool

This is what I get

Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz
27:08 NVIDIA(0): NVIDIA GPU GeForce 8400M GS (G86M) at PCI:1:0:0 (GPU-0) 256MB

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 190.32 Wed Sep 2 03:29:42 PDT 2009

SURFACE GET BITS: 764.71 M/s
SURFACE PUT BITS: 873.086 M/s
MPEG DECODING (1920x1080): 62 frames/s
MPEG DECODING (1280x720): 136 frames/s
H264Decoder: FATAL: Can't create required surfaces!!
Can't initialize H264 decoder!H264 DECODING (1280x720): 86 frames/s
VC1 DECODING (1440x1080): 101 frames/s
MIXER WEAVE (1920x1080): 309 frames/s
MIXER BOB (1920x1080): 434 fields/s
MIXER TEMPORAL (1920x1080): 95 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 129 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 33 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 36 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 123 fields/s

Any clues on the H264 error ?
stecklum is offline   Reply With Quote
Old 09-10-09, 02:51 PM   #161
crisalide
Registered User
 
Join Date: Dec 2008
Posts: 173
Default Re: VDPAU testing tool

Quote:
Originally Posted by stecklum View Post
Any clues on the H264 error ?
Lack video memory ?
Start as few X apps as possible, etc ...
crisalide is offline   Reply With Quote
Old 09-11-09, 08:30 AM   #162
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: VDPAU testing tool

Not sure about that. In fact mplayer plays H264 fine, e.g.

/home/stecklum/System/src/mplayer-vdpau-3532130/mplayer-vdpau/mplayer -noquiet -nofs -nomouseinput -sub-fuzziness 1 -identify -slave -vo vdpau -ao alsa -nokeepaspect -framedrop -dr -double -stop-xscreensaver -ass -embeddedfonts -ass-line-spacing 0 -ass-font-scale 1 -ass-styles /home/stecklum/.config/smplayer/styles.ass -fontconfig -font Arial -subfont-autoscale 0 -subfont-osd-scale 20 -subfont-text-scale 20 -subcp ISO-8859-1 -subpos 100 -volume 100 -cache 2000 -osdlevel 0 -idx -slices -channels 2 -af volnorm=2,scaletempo,equalizer=0:0:0:0:0:0:0:0:0:0 -softvol -softvol-max 300 -vc ffmpeg12vdpau,ffh264vdpau,ffvc1vdpau,ffwmv3vdpau, -mouse-movements -nocache /home/stecklum/Scratch/Serenity - HD DVD Trailer.mp4

MPlayer dev-SVN-r28348-4.3.2 (C) 2000-2009 MPlayer Team
CPU: Intel(R) Core(TM)2 Duo CPU T9300 @ 2.50GHz (Family: 6, Model: 23, Stepping: 6)
CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compiled for x86 CPU with extensions: MMX MMX2 SSE SSE2
Terminal type `unknown' is not defined.

Playing /home/stecklum/Scratch/Serenity - HD DVD Trailer.mp4.
libavformat file format detected.
ID_VIDEO_ID=0
[lavf] Video stream found, -vid 0
ID_AUDIO_ID=1
[lavf] Audio stream found, -aid 1
VIDEO: [avc1] 1280x720 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
Clip info:
name: Serenity - HD DVD Trailer
ID_CLIP_INFO_NAME0=name
ID_CLIP_INFO_VALUE0=Serenity - HD DVD Trailer
author: Universal Pictures
ID_CLIP_INFO_NAME1=author
ID_CLIP_INFO_VALUE1=Universal Pictures
ID_CLIP_INFO_N=2
ID_FILENAME=/home/stecklum/Scratch/Serenity - HD DVD Trailer.mp4
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=avc1
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=1280
ID_VIDEO_HEIGHT=720
ID_VIDEO_FPS=23.976
ID_VIDEO_ASPECT=0.0000
ID_AUDIO_FORMAT=255
ID_AUDIO_BITRATE=0
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_LENGTH=139.71
ID_SEEKABLE=1
ID_CHAPTERS=0
Couldn't open video filter 'ass'.
ASS: cannot add video filter
[ass] Init
[ass] Updating font cache.
================================================== ========================
Forced video codec: ffmpeg12vdpau
Forced video codec: ffh264vdpau
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[VD_FFMPEG] VDPAU accelerated codec.
Selected video codec: [ffh264vdpau] vfm: ffmpeg (FFmpeg H.264 (VDPAU))
================================================== ========================
ID_VIDEO_CODEC=ffh264vdpau
================================================== ========================
Opening audio decoder: [faad] AAC (MPEG2/4 Advanced Audio Coding)
FAAD: compressed input bitrate missing, assuming 128kbit/s!
AUDIO: 48000 Hz, 2 ch, s16le, 128.0 kbit/8.33% (ratio: 16000->192000)
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
Selected audio codec: [faad] afm: faad (FAAD AAC (MPEG-2/MPEG-4 Audio) decoder)
================================================== ========================
AO: [alsa] 48000Hz 2ch floatle (4 bytes per sample)
ID_AUDIO_CODEC=faad
[Mixer] No hardware mixing, inserting volume filter.
Starting playback...
VDec: vo config request - 1280 x 720 (preferred colorspace: H.264 HIGH VDPAU acceleration)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
ID_VIDEO_TRACK=0
VDec: vo config request - 1280 x 720 (preferred colorspace: Unknown 0x0000)
VDec: using H.264 HIGH VDPAU acceleration as output csp (no 2)
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
ID_VIDEO_ASPECT=1.7778
VO: [vdpau] 1280x720 => 1280x720 H.264 HIGH VDPAU acceleration
ID_AUDIO_TRACK=1
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous
pts value <= previous


Exiting... (End of file)
ID_EXIT=EOF
stecklum is offline   Reply With Quote
Old 09-11-09, 11:53 AM   #163
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU testing tool

stecklum, H.264 streams may require a different number of reference frames. Each reference frame requires memory. I don't know how many reference frames are required by qvdpautest or the stream you tested with, but this is the most likely answer. If you need more investigation, please take a look at the VDPAU problem reporting sticky.
Stephen Warren is offline   Reply With Quote
Old 09-13-09, 03:25 AM   #164
tcg42
Registered User
 
Join Date: Sep 2009
Posts: 2
Default Re: VDPAU testing tool

hello,

i have a problem in understanding the following:

here are 2 pcs on which i run qvdpautest:
1) pov-ion atom 330 + onboard 9400m, 1 ram-channel (ddr2-800), gpu uses mainboard ram
2) i7-920 + gtx260, 3 ram-channels (ddr3-1333), gpu has 896 mb own ram
both systems are very similar installed: ubuntu 9.04 + nvidia driver 190.32

i get the following results:

1) (ion) H264 DECODING (1920x1080): 51 frames/s
2) (i7) H264 DECODING (1920x1080): 43 frames/s

what am i doing wrong, any idea anyone ???
tcg42 is offline   Reply With Quote

Old 09-13-09, 10:08 AM   #165
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: VDPAU testing tool

Quote:
Originally Posted by tcg42 View Post
1) (ion) H264 DECODING (1920x1080): 51 frames/s
2) (i7) H264 DECODING (1920x1080): 43 frames/s

what am i doing wrong, any idea anyone ???
Nothing, both will succeed decoding H264 up to level 4.1 in time, both will fail (for example) if you try to decode 60fps 1080p sample.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 09-13-09, 01:34 PM   #166
genady20
Registered User
 
Join Date: Sep 2009
Posts: 1
Default Re: VDPAU testing tool

Code:
Intel(R) Core(TM)2 Duo CPU     E8600  @ 3.33GHz
26:41 NVIDIA(0): NVIDIA GPU GeForce 9600 GT (G94) at PCI:1:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  190.32  Wed Sep  2 03:29:42 PDT 2009

SURFACE GET BITS: 1166.35 M/s
SURFACE PUT BITS: 1231.34 M/s

MPEG DECODING (1920x1080): 78 frames/s
MPEG DECODING (1280x720): 155 frames/s
H264 DECODING (1920x1080): 45 frames/s
H264 DECODING (1280x720): 97 frames/s
VC1 DECODING (1440x1080): 127 frames/s

MIXER WEAVE (1920x1080): 1478 frames/s
MIXER BOB (1920x1080): 2620 fields/s
MIXER TEMPORAL (1920x1080): 521 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 700 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 205 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 227 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 762 fields/s
Running compiz and playing music.
Is it good?
genady20 is offline   Reply With Quote
Old 09-13-09, 02:38 PM   #167
tcg42
Registered User
 
Join Date: Sep 2009
Posts: 2
Default Re: VDPAU testing tool

Quote:
Originally Posted by cehoyos View Post
Nothing, both will succeed decoding H264 up to level 4.1 in time, both will fail (for example) if you try to decode 60fps 1080p sample.
hmmm, for better understanding: that means i can play 1080p (in 50hz) on my ion-board but not on my i7 machine ???
i tested it with vdr and vdr-sxfe and i have very bad results on the ion board...
the i7/gtx260 machine is much better, but not perfect ... maybe vdpau is not enabled ?!?
any idea how i can check if vdr-sxfe is running with vdpau or not ?

here is the complete output if anyone is interested in benchmarks :-)

Code:
Intel(R) Atom(TM) CPU  330   @ 1.60GHz
03:54 NVIDIA(0): NVIDIA GPU ION (C79) at PCI:3:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  190.32  Wed Sep  2 03:46:28 PDT 2009

SURFACE GET BITS: 275.519 M/s
SURFACE PUT BITS: 230.55 M/s

MPEG DECODING (1920x1080): 57 frames/s
MPEG DECODING (1280x720): 135 frames/s
H264 DECODING (1920x1080): 51 frames/s
H264 DECODING (1280x720): 108 frames/s
VC1 DECODING (1440x1080): 68 frames/s

MIXER WEAVE (1920x1080): 277 frames/s
MIXER BOB (1920x1080): 403 fields/s
MIXER TEMPORAL (1920x1080): 93 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 126 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 32 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 35 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 122 fields/s
Code:
Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
58:27 NVIDIA(0): NVIDIA GPU GeForce GTX 260 (GT200) at PCI:2:0:0 (GPU-0)

VDPAU API version : 0
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  190.32  Wed Sep  2 03:46:28 PDT 2009

SURFACE GET BITS: 882.633 M/s
SURFACE PUT BITS: 684.27 M/s

MPEG DECODING (1920x1080): 73 frames/s
MPEG DECODING (1280x720): 149 frames/s
H264 DECODING (1920x1080): 43 frames/s
H264 DECODING (1280x720): 92 frames/s
VC1 DECODING (1440x1080): 118 frames/s

MIXER WEAVE (1920x1080): 3753 frames/s
MIXER BOB (1920x1080): 6834 fields/s
MIXER TEMPORAL (1920x1080): 1589 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 2173 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 566 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 620 fields/s

MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 1837 fields/s
tcg42 is offline   Reply With Quote
Old 09-14-09, 03:43 AM   #168
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: VDPAU testing tool

Quote:
Originally Posted by tcg42 View Post
hmmm, for better understanding: that means i can play 1080p (in 50hz) on my ion-board
No, I don't think so (it is sometimes possible for a certain time, but you will certainly find samples that fail reliably).

Carl Eugen
cehoyos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Valve to release its trailer-making tool: Source Filmmaker dikinher Gaming Central 2 06-28-12 12:28 PM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
Load Testing with the Cloud ' This Week on inside* Publications News Latest Tech And Game Headlines 0 05-20-12 05:30 PM
Portal 2 Perpetual Testing Initiative Starts Now News Latest Tech And Game Headlines 0 05-08-12 05:00 PM
tv tool 6.8 thcdru2k NVIDIA Windows Graphics Drivers 4 10-18-02 01:10 PM

All times are GMT -5. The time now is 12:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.