Go Back   nV News Forums > Graphics Card Forums > NVIDIA Legacy Graphics Cards

Newegg Daily Deals

Reply
 
Thread Tools
Old 03-30-07, 05:23 PM   #1
puterguy
Registered User
 
Join Date: Jan 2003
Posts: 76
Default Xorg cpu usage spikes on even simple 2d apps

Xorg seems to be using an inordinate amount of cpu power for relatively simple 2D graphics ops

For example, moving one text-only gterm over another (back-and-forth) cause Xorg cpu usage to spike from 2.7% to 20%. Running a gterm over the mythfrontend menu page, causes Xorg cpu usage to spike to 50%. Scrolling a google search results page rapidly (text only) in Firefox also spikes Xorg CPU usage to 50%

Of course, situation gets worse when I do more 2D intensive graphics like playing back an HD quality mpeg2 video -- Then cpu usage spikes to 50-60% for Xorg and 40-50% for the player.

Is something wrong here?
While my card is relatively old, I still would think that it shouldn't have that much problem with redrawing simple xterm text windows.

My setup is as follows:
GeForce Ti 4600 with 9633 drivers
Intel P4 2.8 GHz CPU on an ASUS p4pe motherboard
2 GB DDR RAM
Fedora Core 6/Linux 2.6.20 with Gnome

I have tried turning on/off various settings under nvidia-settings including sync-to-blank and cursor shadows.

My Xorg.conf has the following (relevant) settings:

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules/extensions"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "Module"
Load "glx"
Load "extmod"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
# Driver "nv"
VendorName "LeadTek/NVIDIA"
BoardName "NVIDIA GeForce4 (generic)"
#JJK Additions:
Option "NvAGP" "3"
Option "RandRRotation" "True" # Enable rotation via: xrandr
Option "AllowDDCCI" "True"
Option "Cursor Shadow" "True"
EndSection


Any ideas on what might be going on or is this "normal"?
__________________
Fedora Core6/Linux 2.6.x
nVidea driver: 9631
Asus P4PE motherboard
Intel P4 2.8GHz
1.5GB PC2700 DDR Kingston
Leadtek Ultra A250 GF4 4600 128MB with VIVO/TVO
WinFast TV2000XP Deluxe
Dell 1901FP 19" LCD
Antec 400W Power Supply
puterguy is offline   Reply With Quote
Old 09-24-09, 06:37 AM   #2
unimatrix
Registered User
 
Join Date: Mar 2007
Posts: 21
Default Re: Xorg cpu usage spikes on even simple 2d apps

Sorry to revive an old thread, but I must confirm this. 2 years later, the situation has not improved (using nvidia 185.18.36).

On the other hand, this is even worse on ATI cards.
Could this be an Xorg problem?
unimatrix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Maintain Your Privacy by Manually Accepting and Rejecting "Cookies" (nV News) MikeC Open Forum 2 02-02-13 07:15 PM
xorg locks-up with newest nvidia drivers w/ vdpau. theroot NVIDIA Linux 1 06-24-12 11:04 AM
173.14.34 -- Xorg 1.12.1 & 1.11.4, glx module fails to load mereset NVIDIA Linux 17 06-10-12 01:24 AM
295.40 Drivers and Xorg 1:7.6+12 HIGH cpu usage norrland NVIDIA Linux 2 05-13-12 09:11 AM

All times are GMT -5. The time now is 03:11 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.