Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-23-09, 11:27 PM   #13
uOpt
FreeBSD cheering section
 
uOpt's Avatar
 
Join Date: Nov 2004
Location: Boston, MA, USA
Posts: 609
Default Re: Is NVIDIA going to release a working driver before christmas?

Quote:
Originally Posted by AaronP View Post
No, see ftp://download.nvidia.com/XFree86/Li...llowSHMPixmaps

It's a driver option, so it goes in the Device or Screen sections. Also it's AllowSHMPixmaps, not AllowSHMPixmap. I typo'd it in my earlier message.
Ah. That works and it indeed fixes the xine problem.

That's a great relief and it is way before Christmas

Thanks so much.
__________________

My Unix benchmark results
uOpt is offline   Reply With Quote
Old 09-24-09, 12:00 AM   #14
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Is NVIDIA going to release a working driver before christmas?

Thanks, uOpt. That indicates that there's a bug in Xine's handling of SHMPutImage. I'd suggest filing a bug in Xine's bug tracker. FWIW, I would expect to see the same corruption with an EXA-based X driver, since those also disable SHM pixmaps.
AaronP is offline   Reply With Quote
Old 09-24-09, 01:48 AM   #15
cyberf0x
Registered User
 
Join Date: Jun 2004
Posts: 50
Default Re: Is NVIDIA going to release a working driver before christmas?

Did some more testing and It looks like we're getting nowhere. Still flickering espectialy after first start when it's still cold. After restart it gets back to "no-flickering" state, at least for the interface.
cyberf0x is offline   Reply With Quote
Old 09-24-09, 06:04 AM   #16
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Is NVIDIA going to release a working driver before christmas?

Quote:
Originally Posted by cyberf0x View Post
Did some more testing and It looks like we're getting nowhere. Still flickering espectialy after first start when it's still cold. After restart it gets back to "no-flickering" state, at least for the interface.
Are you 100% sure that this is driver related?
It sounds like a hardware problem to me.

Fuchs
NvFuchs is offline   Reply With Quote
Old 09-24-09, 08:49 AM   #17
uOpt
FreeBSD cheering section
 
uOpt's Avatar
 
Join Date: Nov 2004
Location: Boston, MA, USA
Posts: 609
Default Re: Is NVIDIA going to release a working driver before christmas?

Quote:
Originally Posted by AaronP View Post
Thanks, uOpt. That indicates that there's a bug in Xine's handling of SHMPutImage. I'd suggest filing a bug in Xine's bug tracker. FWIW, I would expect to see the same corruption with an EXA-based X driver, since those also disable SHM pixmaps.
Well, since the chrooted 32 bit xine works I am more thinking along the lines of some library being broken. Unfortunately the deep dependencies on random junk nowadays made me unable to just use the shared libs from the chroot outside the chroot, it just segfaults. I guess my next step is to build my non-chroot xine32 into the chroot and then try it there.

Thanks again for you help.
__________________

My Unix benchmark results
uOpt is offline   Reply With Quote
Old 09-24-09, 01:55 PM   #18
cyberf0x
Registered User
 
Join Date: Jun 2004
Posts: 50
Default Re: Is NVIDIA going to release a working driver before christmas?

Quote:
Originally Posted by NvFuchs View Post
Are you 100% sure that this is driver related?
It sounds like a hardware problem to me.

Fuchs
Works under Windows without ANY issues. Both the old driver and the updated driver for my laptop from toshiba site.

EDIT: It looks like the only driver that works ok is the official 7.15.11.5664. The updated driver for win7 (186.xx) works almost like 185.xx series under linux(some glitches in GL apps) but it doesn't hang up like the linux driver.

So.... Now I don't really know what's going on.
cyberf0x is offline   Reply With Quote
Old 09-25-09, 06:43 AM   #19
Lithorus
Registered User
 
Lithorus's Avatar
 
Join Date: Sep 2004
Posts: 783
Default Re: Is NVIDIA going to release a working driver before christmas?

Quote:
Originally Posted by cyberf0x View Post
Works under Windows without ANY issues. Both the old driver and the updated driver for my laptop from toshiba site.

EDIT: It looks like the only driver that works ok is the official 7.15.11.5664. The updated driver for win7 (186.xx) works almost like 185.xx series under linux(some glitches in GL apps) but it doesn't hang up like the linux driver.

So.... Now I don't really know what's going on.
I remember having something similar with a Sony laptop. The sony provided driver worked fine, but nvidia's latest driver ended up with weird flickering. It all went down to the PerfLvlSrc thing mentioned earlier in this thread, which was "embeded" in the sony provided driver, but not in vanilla nvidia drivers.
Lithorus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.