Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-05-09, 02:06 PM   #1
democles
Registered User
 
Join Date: Oct 2009
Posts: 2
Default Nvidia 190.36 - arch changed

Hi,

I'm trying to compile the 190.36 nvidia-drivers on a gentoo-box using latest git-sources (2.6.32-rc1-git5)

I've got the following error, but i did not change my arch... who can help me ?

some info: snippet from emerge nvidia-drivers

* Preparing nvidia module
make -j3 HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.32-rc1-git5/build HOST_CC=i686-pc-linux-gnu-gcc clean module
NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.32-rc1-git5/build KBUILD_VERBOSE=1 -C /usr/src/linux M=/var/tmp/portage/x11-drivers/nvidia-drivers-190.36/work/NVIDIA-Linux-x86-190.36-pkg0/usr/src/nv modules
make[2]: warning: jobserver unavailable: using -j1. Add `+' to parent make rule.
make -C /lib/modules/2.6.32-rc1-git5/build \
KBUILD_SRC=/usr/src/linux-2.6.32-rc1-git5 \
KBUILD_EXTMOD="/var/tmp/portage/x11-drivers/nvidia-drivers-190.36/work/NVIDIA-Linux-x86-190.36-pkg0/usr/src/nv" -f /usr/src/linux-2.6.32-rc1-git5/Makefile \
modules
/usr/src/linux-2.6.32-rc1-git5/Makefile:210: *** ARCH changed from "i386" to "x86". Use "make mrproper" to fix it up. Stop.
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
*
* ERROR: x11-drivers/nvidia-drivers-190.36 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3881: Called linux-mod_src_compile
* environment, line 2869: Called die
* The specific snippet of code:
* eval "emake HOSTCC=\"$(tc-getBUILD_CC)\" CROSS_COMPILE=${CHOST}- LDFLAGS=\"$(get_abi_LDFLAGS)\" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS} " || die "Unable to emake HOSTCC="$(tc-getBUILD_CC)" CROSS_COMPILE=${CHOST}- LDFLAGS="$(get_abi_LDFLAGS)" ${BUILD_FIXES} ${BUILD_PARAMS} ${BUILD_TARGETS}";
* The die message:
* Unable to emake HOSTCC=i686-pc-linux-gnu-gcc CROSS_COMPILE=i686-pc-linux-gnu- LDFLAGS= IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/2.6.32-rc1-git5/build HOST_CC=i686-pc-linux-gnu-gcc clean module

make.conf:
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
ACCEPT_KEYWORDS="~x86"
MAKEOPTS="-j3"
AUTOCLEAN="yes"
PORTAGE_NICENESS="3"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ ftp://ftp.snt.utwen$
USE="X opengl nvidia gtk gnome avahi pdf pulseaudio gstreamer jack alsa ogg oggvorbis vorbis mp3 pda bash-completion dvd dvdr dvd$
FEATURES="ccache parallel-fetch -sandbox"
CCACHE_SIZE="2G"
ALSA_CARDS="intel8x0"
LINGUAS="en_UK nl"
VIDEO_CARDS="nv nvidia"
INPUT_DEVICES="evdev"
source /usr/local/portage/layman/make.conf

emerge --info
Portage 2.1.6.13 (default/linux/x86/2008.0, gcc-4.4.1, glibc-2.10.1-r0, 2.6.32-rc1-git5 i686)
================================================== ===============
System uname: Linux-2.6.32-rc1-git5-i686-Intel-R-_Core-TM-2_Duo_CPU_E8500_@_3.16GHz-with-gentoo-2.0.1
Timestamp of tree: Mon, 05 Oct 2009 17:45:01 +0000
ccache version 2.4 [enabled]
app-shells/bash: 4.0_p33
dev-lang/python: 2.5.2-r7, 2.6.3, 3.1.1-r1
dev-python/pycrypto: 2.0.1-r8
dev-util/ccache: 2.4-r8
dev-util/cmake: 2.6.4-r2
sys-apps/baselayout: 2.0.1
sys-apps/openrc: 0.4.3-r3
sys-apps/sandbox: 2.1
sys-devel/autoconf: 2.13, 2.63-r1
sys-devel/automake: 1.5, 1.9.6-r2, 1.10.2, 1.11
sys-devel/binutils: 2.19.1-r1
sys-devel/gcc-config: 1.4.1
sys-devel/libtool: 2.2.6a
virtual/os-headers: 2.6.30-r1
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks fixpackages parallel-fetch protect-owned sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://mirror.muntinternet.net/pub/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo/"
LANG="C"
LDFLAGS="-Wl,-O1"
LINGUAS="en_UK nl"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/layman/berkano /usr/local/portage/layman/desktop-effects /usr/local/portage/layman/otih"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X acl alsa avahi bash-completion berkdb bzip2 cairo cli cracklib crypt cups dbus dri dvd dvdr dvdread gdbm gnome gpm gstreamer gtk hal iconv isdnlog jack jpeg modules mp3 mudflap ncurses nls nptl nptlonly nsplugin nvidia ogg oggvorbis opengl openmp pam pcre pda pdf perl png pppd pulseaudio python readline reflection session spl ssl svg sysfs tcpd tiff unicode vorbis webkit x86 xcb xorg zlib" ALSA_CARDS="intel8x0" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_UK nl" USERLAND="GNU" VIDEO_CARDS="nv nvidia"
Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Kernel config-file attached

same error with 185 driver series
Attached Files
File Type: txt config.txt (58.9 KB, 82 views)
democles is offline   Reply With Quote
Old 10-05-09, 05:56 PM   #2
Stendall
Registered User
 
Join Date: Oct 2004
Posts: 25
Default Re: Nvidia 190.36 - arch changed

I think you even have posted the solution in bold.

/usr/src/linux-2.6.32-rc1-git5/Makefile:210: *** ARCH changed from "i386" to "x86". Use "make mrproper" to fix it up. Stop.

Seems that in the kernel tree you are using, have changed the literal used to refer the PC 32bits architecture
It makes sense because i386 ends to referring a particular processor and not a family or architecture.

Use "make mrproper" to fix it up.

That way -hopefully- will fix the problem, but you will lost any customization that you have make to the kernel config.
Stendall is offline   Reply With Quote
Old 10-07-09, 02:36 AM   #3
democles
Registered User
 
Join Date: Oct 2009
Posts: 2
Default Re: Nvidia 190.36 - arch changed

Thx for your quick reply,

I did a make mrproper but this action didn't solve the problem. I took a view at the indicated location in the Makefile and at line 210 tests are performed to verify the arch. By changing the /usr/src/linux/include/generated/kernel.arch content to x86 I was able to compile the nvidia-drivers. I don't understand where the i386 came from (working since the beginning with the provided make.conf settings).

I'll have to study the Makefile to find out why the kernel.arch was set to i386.
democles is offline   Reply With Quote
Old 10-07-09, 04:23 AM   #4
mlauss
Registered User
 
Join Date: Aug 2007
Posts: 43
Default Re: Nvidia 190.36 - arch changed

Quote:
Originally Posted by democles View Post
Thx for your quick reply,

I did a make mrproper but this action didn't solve the problem. I took a view at the indicated location in the Makefile and at line 210 tests are performed to verify the arch. By changing the /usr/src/linux/include/generated/kernel.arch content to x86 I was able to compile the nvidia-drivers. I don't understand where the i386 came from (working since the beginning with the provided make.conf settings).

I'll have to study the Makefile to find out why the kernel.arch was set to i386.
This is a problem with the ebuild; it changes a few things in the nvidia module Makefile
which break starting with 2.6.31++. The pristine nvidia makefile still works on recent
-git sources.
mlauss is offline   Reply With Quote
Old 10-10-09, 02:39 AM   #5
PrakashP
gentoo ~x86_64 user
 
PrakashP's Avatar
 
Join Date: Jul 2004
Location: Germania
Posts: 213
Default Re: Nvidia 190.36 - arch changed

See here
PrakashP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:55 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.