Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-29-09, 05:32 AM   #1
ildella
Registered User
 
Join Date: Feb 2008
Posts: 5
Angry Powermizer Perf level stucked to 2, cpu boiling

Hi everyone.

Despite many tentatives, I cannot configure xorg to make PowerMizer change the level to 0 or 1. It is stucked to 2, clock at maximum, temperature close to 100 Celsius and fan always at maximum.
Note that nvidia-settings says that adaptative clocking is enabled.
I would like that to be true but I would be happyu also in forcing level 1, for now.

Actually I have this line in xorg.conf

Option "RegistryDwords" "PowerMizerEnable=0x1; PowerMizerLevel=0x2; PowerMizerLevelAC=0x2; "

that means mode 2, level 1, if I have understood. Anyway, changing those values does not change anything. There is some other place I can change something?
I am actually using latest 190 under ubuntu 9.10. Same problem with latest 185.

Here is a grep of nvidia-settings.

ildella@ildella-laptop:~$ nvidia-settings -q all | grep Power
Attribute 'GPUPowerSource' (ildella-laptop:0.0): 0.
'GPUPowerSource' is an integer attribute.
'GPUPowerSource' is a read-only attribute.
'GPUPowerSource' can use the following target types: X Screen, GPU.
ildella@ildella-laptop:~$ nvidia-settings -q all | grep Perf
Attribute 'GPUCurrentPerfMode' (ildella-laptop:0.0): 1.
'GPUCurrentPerfMode' is an integer attribute.
'GPUCurrentPerfMode' is a read-only attribute.
'GPUCurrentPerfMode' can use the following target types: X Screen, GPU.
Attribute 'GPUCurrentPerfLevel' (ildella-laptop:0.0): 2.
'GPUCurrentPerfLevel' is an integer attribute.
'GPUCurrentPerfLevel' is a read-only attribute.
'GPUCurrentPerfLevel' can use the following target types: X Screen, GPU.
Attribute 'GPUPerfModes' (ildella-laptop:0.0): perf=0, nvclock=169, memclock=100 ; perf=1, nvclock=275, memclock=301 ; perf=2, nvclock=475
ildella is offline   Reply With Quote
Old 10-29-09, 03:32 PM   #2
lgolebio
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Powermizer Perf level stucked to 2, cpu boiling

Same problem here as well. My laptop is just overheating at the moment. It stucks to level 2, which is maximum frequency for my graphic card, and adding values to xorg.conf doesn't work. WHY ??
lgolebio is offline   Reply With Quote
Old 10-29-09, 06:33 PM   #3
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Powermizer Perf level stucked to 2, cpu boiling

Just a workaround, but you should be able to underclock the clocks of the highest performance level with the 'Clock Frequencies' panel in nvidia-settings (or with nvclock).
ledoc is offline   Reply With Quote
Old 10-29-09, 11:01 PM   #4
hl_
Registered User
 
Join Date: Feb 2009
Posts: 138
Default Re: Powermizer Perf level stucked to 2, cpu boiling

It looks like GPUs do not downclock as much not due to bandwidth issues (after all, even at very low clock, modern DDR2+ RAM offers plenty of bandwidth) but because frequency transitions can cause screen flicker in dual-screen configurations. Interestingly, AMD's GPUs have the same issue.
hl_ is offline   Reply With Quote
Old 10-30-09, 01:06 AM   #5
artem
Registered User
 
Join Date: Jun 2006
Posts: 711
Default Re: Powermizer Perf level stucked to 2, cpu boiling

Use nvclock until NVDIA solves this issue.
artem is offline   Reply With Quote
Old 10-30-09, 08:28 AM   #6
ildella
Registered User
 
Join Date: Feb 2008
Posts: 5
Default Re: Powermizer Perf level stucked to 2, cpu boiling

I was already using clock frequency in nvidia-settings panel. And even forcing to 2D CLock frequency settings, temperature still raises up and PowerMizer secion in the panel continue to report higher values for clocking.
Actually temperature started from 65 degress after a short suspension period and despite bveing set to 169Mhz, while I have written this, temperature is 77 and growing.
ildella is offline   Reply With Quote
Old 10-30-09, 12:57 PM   #7
lgolebio
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Re: Powermizer Perf level stucked to 2, cpu boiling

The same is on my notebook's 8600M GT. Even if i set with nvclock or nvidia-settings, it still uses the fastest mode, and the temperature is rising fast.
lgolebio is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:06 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.