Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-01-09, 03:17 AM   #1
SamiK
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

Yesterday I upgraded my Linux Kubuntu 9.04 to 9.10. I left upgrade running during night but apparently it went without any errors. Computer was ready to reboot this morning.

But now computer stops to error message when booting:

Ubuntu is running in low-graphics mode
The following error was encountered. You may need to update your configuration to solve this.
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.

There is just OK-button and after that several choices to display logs or edit configurations etc. But I can basicly only go to console, no graphical user interface anywhere.

I've tried several things found from net, like "sudo dpkg-reconfigure xserver-xorg" or booting in recovery mode and choose repair. No help.

I've done several distribution upgrades before, this is never happened before. I've never manually installed any nvidia drivers, I've used my Linux pretty much with "default options" always.
SamiK is offline   Reply With Quote
Old 11-01-09, 03:19 AM   #2
SamiK
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

Second try to attach bug report log:
Attached Files
File Type: gz nvidia-bug-report.log.gz (23.1 KB, 246 views)
SamiK is offline   Reply With Quote
Old 11-01-09, 06:32 AM   #3
thefirstm
Registered User
 
Join Date: Feb 2009
Posts: 226
Default Re: Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

After looking through your logs, I have found your problem. The problem is that the kernel module is at version 173.14.16 (from Jaunty) but the userspace part of the driver was upgraded to 173.14.20 (with the Karmic upgrade.) My recommendation would be to execute the following commands:

"sudo dkms remove -m nvidia -v 173.14.16 --all"
"sudo dkms remove -m nvidia -v 173.14.20 --all"
"sudo aptitude reinstall nvidia-173-kernel-source"

One of the DKMS commands will probably fail, but executing them both will ensure that all kernel modules are removed from your system before reinstalling the kernel modules source. This will cause DKMS to build the latest version of the module, which should start your system working again after a reboot.
thefirstm is offline   Reply With Quote
Old 11-01-09, 10:41 AM   #4
SamiK
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

First remove command failed, second worked.

Reinstall command (after long amount of texts) said:

driver version= 173.14.20
Doing initial module build
Error! Your kernel source for kernel 2.6.31-14-386 cannot be found at /lib/modules/2.6.31-14-386/build or /lib/modules/2.6.31-14-386/source.
Installing initial module
Error! Could not locate nvidia.ko for module nvidia in the DKMS tree. You must run a dkms build for kernel 2.6.31-14-386 (i686) first.

After booting same Ubuntu is running in low-graphics mode -message appears.
SamiK is offline   Reply With Quote
Old 11-01-09, 01:51 PM   #5
romane
Registered User
 
Join Date: Aug 2008
Location: Cairns, Queensland, Australia
Posts: 6
Default Re: Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

Good morning Samik

My first thoughts were the same as those of @thefirstsm. Now, not much up on Ubuntu - run Debian (stable on two, testing on one desktop and the laptop). Have looked at "the Debian way" and opted for downloading and installing directly from the nVidia drivers (available elsewhere on this site). If all else fails, you may be forced to try this method. The install process will usually (in my own experience) uninstall any previous drivers before installing itself.

Now, if you do go down this track, you will need to install the correct headers (the headers are what your last message is complaining about) Just aptitude or apt-get them and try again. Getting the headers will, if you do not already have it, install the correct version of gcc as well, which will help to stop another complaint from the installer.

apt-get install linux-headers-`uname -r`

(edit : easier to copy/paste that line - those are `, not ' )

With greetings

Romane

Edit : Reading your last post again, actually, once you get the headers, the process you tried above should work.
romane is offline   Reply With Quote
Old 11-01-09, 03:01 PM   #6
SamiK
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Failed to load the NVIDIA kernel module -error after upgrading to Kubuntu 9.10

Yes, this worked, I'm back using mouse

apt-get install linux-headers-`uname -r`
sudo aptitude reinstall nvidia-173-kernel-source

Thanks all!
SamiK is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.