Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-19-09, 11:32 AM   #13
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Quote:
Originally Posted by Stephen Warren View Post
What does the PowerMizer page say when actually playing back video? There may be a difference between SD and HD video here. On an ION, I'd expect a high level to be automatically selected for video playback (at least with 185.18.14 and later)
When I play a 1080i file the performance level goes almost immediately to the maximum (3), with nv clock 450 Mhz; Memory clock is always 0 (zero)

Quote:
Originally Posted by Stephen Warren View Post
The fact it says "battery" rather than "ac" (or whatever the text is) could affect the performance levels PowerMizer chooses.
Is there a way to override this?

thanks,
rob
resoli is offline   Reply With Quote
Old 06-19-09, 11:58 AM   #14
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

I don't know if you can override the battery/ac detection. It's probably not relevant given the level is jumping to 3 for video playback. I suspect the memory clock readout is just a bug in nvidia-settings, or the data source it uses.
Stephen Warren is offline   Reply With Quote
Old 06-19-09, 12:46 PM   #15
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

I noted also this:
Code:
2009-06-19 19:43:38.517 nVidiaVideoSync: VBlank ioctl did not work, unimplemented in this driver?
2009-06-19 19:43:38.517 DRMVideoSync: Could not open device /dev/dri/card0, Nessun file o directory
in the mythtv playback log; is it important? (the wording "Nessun file o directory" means "No file or directory")
resoli is offline   Reply With Quote
Old 06-22-09, 12:35 AM   #16
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Answering to myself, I guess it's not relevant, the same two lines are present in my 8400GS playback, which is very good.
resoli is offline   Reply With Quote
Old 06-23-09, 11:47 AM   #17
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Yesterday there were both a Jaunty kerrnel update (which triggered a nvidia kernel module rebuild), and a mythtv update from avenard.com.

I don't know which was decisive, but mythtv playback problems were solved.
Now mythtv playback of jerky.ts and similar recorded 1080i DVB-T streams is on par with mplayer one. (not perfect, but definitely watchable)

bye,
rob

Last edited by resoli; 06-28-09 at 11:17 AM.
resoli is offline   Reply With Quote
Old 11-03-09, 07:27 AM   #18
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: jerky playback of 1080i under mythtv with vdpau and 9400M (ION)

Update: driver 190.42 improved playback of problematic streams even more.

bye,
rob
resoli is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:57 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.