Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-03-09, 09:03 AM   #1
thecsapprentice
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX 260

First a little history:

I built a brand new i7 computer at the end of summer with a EVGA GTX 260, the 1700 meg version. Almost immediately after trying to use the card with linux, I began experiencing all kinds of problems - most of which are the form from the thread title. Namely the screen would flicker black for several seconds, very quick like a screen refresh, and if it didn't crash from it, all the textures in the video memory would be scrambled. I'd see images on the screen, like my desktop and program icons, replaced with bits and pieces of other images. And of course there would be NVRM messages in the syslog. So I fought with it for weeks, and even emailed Nvidia with a bug report - no solution and no response. So I RMAed it. The replacement worked fine so I figured it was a bad card - no big deal.

Till this morning that is. I wake up, start a game that I've been playing with no problem for 2 months and guess what I see - black screen flicker. I managed to shut the game down and just like before, all my textures were corrupted all over my desktop.

So my problem is that this new card is past RMA time and I still have no solution to this problem. My experience from before is the flicker/crash/corrupt problem is seemingly unprovoked, as it occurred several times when I was doing nothing, and so it leads to a very unproductive system. I've looked for others with my symptoms, but so far nothing looks similar. So I'm attaching the latest bug report and hopefully this forum has suggestions - I'm not in the mood to buy a new card.
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.1 KB, 96 views)
thecsapprentice is offline   Reply With Quote
Old 11-03-09, 11:11 AM   #2
hl_
Registered User
 
Join Date: Feb 2009
Posts: 138
Default Re: Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX

What makes you think a serious hardware fault can be fixed with software?
hl_ is offline   Reply With Quote
Old 11-03-09, 08:03 PM   #3
thecsapprentice
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX

Well, I suppose thats my question: Is this definitely a hardware problem? I mean if I could, one way or another, confirm this then sure - software isn't going to fix it. But this new card worked fine for two months and without any other visible signs it now starts to behave oddly? I don't know whats worse here: either Nvidia makes really unreliable drivers or they make really unreliable hardware. The first means it might never work, the second means that I have to spend lots of money till it works.

--------------

Also, I'm using the 185.18.31 version of the driver.
thecsapprentice is offline   Reply With Quote
Old 11-03-09, 09:05 PM   #4
thecsapprentice
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX

Okay, more news from the front lines:

On a whim I downgraded my kernel to 2.6.28-15-generic from 2.6.28-16-generic due to the fact that I had recently updated it. Preliminary tests ( read played the game that made it flicker) are positive. No flicker or corruption detected. I'll post again after a while of use to see if my idea is faulty - but perhaps the new kernel version has a conflict with it?

Anyone else have experience with a GTX2xx , 2.6.28-16, and version 185.18.31 driver?
thecsapprentice is offline   Reply With Quote
Old 11-03-09, 10:36 PM   #5
xianthax
Registered User
 
Join Date: Dec 2008
Posts: 38
Default Re: Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX

update the driver.

i've been using a GTX260 for months and had no real issues other than it getting "pissy" after being run for a long time, 2ish months seems to be the point where i need to log out and log back in to regain performance. Sometimes shorter depending on work load, VMs and eve online seem to be the apps that push up the logout/login time.

i also use jaunty, which i assume you do given the kernel versions you mentioned. I do keep the driver up to date though.
xianthax is offline   Reply With Quote
Old 11-04-09, 08:02 AM   #6
thecsapprentice
Registered User
 
Join Date: Nov 2009
Posts: 4
Default Re: Ubuntu 9.04 2.6.28-16-generic has black flickers and texture corruption with GTX

Interesting. Thanks for your ideas.

I'll consider updating if my kernel idea falls through. I'm a strong believer of don't fix what works.

It is curious that the driver/hardware gets 'pissy', as you call it, after long uptime. I wonder what causes that behavior.
thecsapprentice is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.