Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-25-02, 06:35 PM   #1
kwaz
Guest
 
Posts: n/a
Question kswapd kernel problem and the NVdriver

hi

I have RH7.3 , kernel 2.4.18-3 version. I have gforce2, and currently use NVdirver 2960. My box crashes, hangs/ freezes, keyboard stop responding, and so reboot follows this. Yeah, and the kswapd seems to go zombie prior to it, and occasionally it is possible to see the kswapd error message in the kernel log.

In the kernel mailings, there is a notable coincidence b/n people reporting this problem, and them using the NVdriver. I've seen that kernel developers ask people to be able to reproduce the error without the NVdriver used.

So, i was wondering if anyone here also has this problem. It is quite annoying having your system crashing every now and again. Also would be interesting what people at nvidia think about it.

Anyway, i will try the new driver, and see what that will do. And, then i guess i would have to switch back to the linux nv, if crashes will go on...

cheers
  Reply With Quote
Old 09-25-02, 08:01 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

If the NVdriver kernel module is the problem, then the crashes will most likely continue as long as the NVdriver is being used or loaded. If you load it on every boot, then (again, assuming the problem with kswapd zombieing is the fault of it) it will most likely happen regardless of which driver you're using.

However, I have seen the same problem a while back, and I don't know what was causing it then either. But that was on kernels 2.4.16, 2.4.17, and 2.4.18 (at least... possibly also on 2.4.14). 2.4.19-pre8 doesn't do it any more (my firewall running that kernel has an uptime of like three weeks now), but then again, this firewall isn't running X. And the NVdriver isn't loading.

On my main-use machine, X and the 3123 drivers are loading, and it's using kernel 2.4.19. I haven't seen that problem yet. *crosses fingers*

Perhaps an upgrade to 2.4.19 might be in order, at least for testing?
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote
Old 09-25-02, 08:33 PM   #3
kwaz
Guest
 
Posts: n/a
Default

Thanks for reply. My upgrade to 2.4.19 is on the way.
Was not sure exactly what you meant there about loadint at boot. Yes, i do insert the NVdriver when i start X, but i boot into init 3, and then startx and it loads the NVdriver.
I was referring to falling back to the builtin nv driver that you get with every linux (i think so, i have redhat). Thats what its called in the xf86* config? Thats ofcoure if the NVdriver is the cause... [ but for some reason i actually cant get the nv driver to work after i installed the NV one]
In any case,
a buddy of mine just told me that he has same card, uses the new NVdriver, and has no problem. Also , he says that kswapd zombieing is a good reason to update the kernel.

So, thanks
  Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:54 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.