Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-09, 06:07 PM   #1
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default glxgears is 5 fps

Seems like glxgears and 3D screensavers are not accelerated after installing the 190.42 driver. Everything else is working great (rotated twinview, compositing). 6600GT that was properly accelerated on Mandriva 2008 + 180.60. Not properly 3D accelerated under Mandriva 2010 + 190.42

Is there something obviously incorrect below?

# ldd /usr/bin/glxgears
linux-vdso.so.1 => (0x00007ffffe7ff000)
libGL.so.1 => /usr/lib64/nvidia-current/libGL.so.1 (0x00007fb2b4c88000)
libm.so.6 => /lib64/libm.so.6 (0x00007fb2b4a06000)
libc.so.6 => /lib64/libc.so.6 (0x00007fb2b46a8000)
libX11.so.6 => /usr/lib64/libX11.so.6 (0x00007fb2b436e000)
libGLcore.so.1 => /usr/lib64/nvidia-current/libGLcore.so.1 (0x00007fb2b2f11000)
libnvidia-tls.so.1 => /usr/lib64/nvidia-current/tls/libnvidia-tls.so.1 (0x00007fb2b4f7b000)
libXext.so.6 => /usr/lib64/libXext.so.6 (0x00007fb2b2cff000)
libdl.so.2 => /lib64/libdl.so.2 (0x00007fb2b2afb000)
/lib64/ld-linux-x86-64.so.2 (0x00007fb2b4e80000)
libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00007fb2b28df000)
libXau.so.6 => /usr/lib64/libXau.so.6 (0x00007fb2b26dc000)
libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00007fb2b24d6000)
#
xorbe is offline   Reply With Quote
Old 11-20-09, 06:10 PM   #2
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: glxgears is 5 fps

nevermind, it goes quite fast with effects/compositing off, I guess the card doesn't have enough memory or something.
xorbe is offline   Reply With Quote
Old 11-21-09, 08:10 AM   #3
th0rgal
Registered User
 
Join Date: Nov 2004
Posts: 31
Default Re: glxgears is 5 fps

I had the same issue when upgrading the driver.

With 190.xxx, I had to add

Code:
Option   "UseEvents" "false"
in the Screen section of /etc/X11/xorg.conf

with 185.xxx, that was the opposite (!)
th0rgal is offline   Reply With Quote
Old 11-23-09, 04:15 PM   #4
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: glxgears is 5 fps

That's not an nvidia driver option (at least not documented in the README), and it didn't improve my composite glxgears performance at all ...
xorbe is offline   Reply With Quote
Old 11-23-09, 04:19 PM   #5
Nephyrin
Registered User
 
Join Date: Apr 2007
Location: Simi Valley, CA
Posts: 45
Send a message via AIM to Nephyrin Send a message via MSN to Nephyrin Send a message via Skype™ to Nephyrin
Default Re: glxgears is 5 fps

Quote:
Originally Posted by xorbe View Post
That's not an nvidia driver option (at least not documented in the README), and it didn't improve my composite glxgears performance at all ...
http://us.download.nvidia.com/XFree8...ppendix-b.html

Quote:
Enables the use of system events in some cases when the X driver is waiting for the hardware. The X driver can briefly spin through a tight loop when waiting for the hardware. With this option the X driver instead sets an event handler and waits for the hardware through the poll() system call. Default: the use of the events is disabled.
For a while it was providing better performance, now it seems to be breaking things.
Nephyrin is offline   Reply With Quote
Old 11-23-09, 04:19 PM   #6
th0rgal
Registered User
 
Join Date: Nov 2004
Posts: 31
Default Re: glxgears is 5 fps

it is in the README:

Code:
~$ less /usr/share/doc/NVIDIA_GLX-1.0/README.txt
...

Option "UseEvents" "boolean"

    Enables the use of system events in some cases when the X driver is
    waiting for the hardware. The X driver can briefly spin through a tight
    loop when waiting for the hardware. With this option the X driver instead
    sets an event handler and waits for the hardware through the 'poll()'
    system call. Default: the use of the events is disabled.

...
too bad it does not do it for you. For me, this option changes things a lot!
th0rgal is offline   Reply With Quote
Old 11-24-09, 01:42 AM   #7
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: glxgears is 5 fps

I don't think you meant the Screen section. I will try again tomorrow with it in the other section. I will double check my README ... that's really weird. Maybe I mistyped my grep.
xorbe is offline   Reply With Quote
Old 11-24-09, 03:05 PM   #8
xorbe
Unbuffered User
 
Join Date: Jun 2005
Posts: 388
Default Re: glxgears is 5 fps

yup, it's in the README so I messed up my original grep. I moved the option into section Driver but it still did nothing ... sorry, I guess we have different issues here!
xorbe is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.