Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-11-03, 05:38 AM   #1
jaspin
Registered User
 
Join Date: Oct 2003
Location: UK
Posts: 10
Unhappy Monitor dies when I log on to Linux

I hope that someone out there can help me. I picked up my computer yesterday after having my disk partition and configured to dual boot Windows xp and Linux. In the shop it was working great however having go it home and reconnected to my monitor... I can boot into XP and the monitor works but when select Linux it dies (its as if the monitor isn't aware that linux is running)
I have an plug and play LG Flatron 782 LE monitor and nVidia GeForce Ti 4200 card, ASUS motherboard and AMD Atholon XP 2200 processor.
I have read just enough to be confused by this and was hoping it was a common problem that someone could advise me on pretty easily.

P.S. if the solution to this means entering something at the command line just note that I have tried, from the selection screen /dual boot screen to input c, but i end up at the grub command line and I don't know how to get to the linux command prompt from there.
Sorry if this is confusing but I am a novice at this (as I said I know enough to be really dangerous)

Thanks
jaspin
jaspin is offline   Reply With Quote
Old 10-11-03, 07:07 AM   #2
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default

The shop configured your system at a too high resolution or frequency for your monitor.
Your monitor turns off to protect itself after Linux switches to graphic mode.

Try typing a 3 (digit 3) in the command line, or if that does not work "linux 3" (no quotes).

Does that get you a text screen?
pe1chl is offline   Reply With Quote
Old 10-11-03, 07:30 AM   #3
jaspin
Registered User
 
Join Date: Oct 2003
Location: UK
Posts: 10
Smile Monitor and Command Line

pe1chl,

I tried using 3 and Linux 3 at the grub prompt and nothing happened. I assume that if i can somehow get to the linux prompt I can use the xconfigurator to configure my monitor? Do you know if thats the case?

I will have a look through some online manuals to see if i can figure out how to get to the prompt.

Thanks, and if you come up with any other ideas let me know.

Jasp
jaspin is offline   Reply With Quote
Old 10-11-03, 09:02 AM   #4
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default

Yes, once you have a text screen you can edit the configuration or start a graphic configurator tool and correct the problem.

Normally, starting Linux with runlevel 3 should get you a text screen.
You can try single-user mode (using the keyword "single") but it may make things more difficult than necessary.
pe1chl is offline   Reply With Quote
Old 10-11-03, 09:18 AM   #5
jaspin
Registered User
 
Join Date: Oct 2003
Location: UK
Posts: 10
Default Thanks

Thanks,

I'll try that and see what happens. I have tried everything except that, from trying to boot in dos but I can't even boot up into Dos mode with a boot disk. Crazy

I'll let you know if it works. Or not.

Cheers
jaspin is offline   Reply With Quote
Old 10-11-03, 12:01 PM   #6
jaspin
Registered User
 
Join Date: Oct 2003
Location: UK
Posts: 10
Default Still no joy

Hi Pe1chl,

Still cant get anywhere with this command prompt even. I seem to be stuck in GRUB. I have a friend who said they installed Red Hat Linux 9 and the same thing happened.

Thought maybe it was this nVidia thing too and I have downloaded the driver just in case, but I'm stuck in GRUB. May just give up soon.

Cheers
Jasp
jaspin is offline   Reply With Quote
Old 10-12-03, 03:43 AM   #7
pe1chl
Registered User
 
Join Date: Aug 2003
Posts: 1,026
Default

I have no idea what distribution you are running and I do not use GRUB myself, so I cannot give further help.

You need to get the system in runlevel 3, and it should come up in textmode.
This is normally done from the bootprompt but apparently not with your system.

What you have done (installing on a different monitor) is not good. It would kill Windows as well.
This week I installed a Windows system with a PS/2 keyboard and it had to be used with a USB keyboard. It did not work because Windows detects new hardware after you log in, and you cannot log in because the keyboard does not work.

The same thing would happen with the monitor, I presume.
You are only lucky that the resolution Windows chose on the store monitor also worked on your monitor.

Next time, install on the monitor you are going to actually use. That will solve this problem for sure.
pe1chl is offline   Reply With Quote
Old 10-13-03, 02:29 AM   #8
Gibbylinks
Registered User
 
Gibbylinks's Avatar
 
Join Date: Sep 2003
Location: Manchester, UK
Posts: 7
Default

Are you sure your at the GRUB screen ?

I had the same problem, but with me it was when X started. I had to press CTRL+ALT and Backspace, which got me out of X and let me edit my xfree86 for the correct drivers.

Maybe worth a try
__________________
Linux (Ubuntu - Intrepid Ibis)/Win XP Pro
Gigabyte GA7N400 Pro
AMD XP3000+
Inno3D 6600GT 128mb
3x 512mb DDR400 PC3200 RAM
80gb Barracuda (SATA 0)
160b Maxtor (SATA 1)
60gb WD600AB(IDE 3)
Sony CRX230ED(IDE 1)
Gibbylinks is offline   Reply With Quote

Old 10-13-03, 03:23 AM   #9
Moled
cheese
 
Join Date: Aug 2003
Posts: 137
Default

you just need to disable the framebuffer


I dont use grub so cant tell you how

if you have a "vga=xxx" in there somewhere change it to "vga=normal" I guess
Moled is offline   Reply With Quote
Old 10-13-03, 03:27 AM   #10
jaspin
Registered User
 
Join Date: Oct 2003
Location: UK
Posts: 10
Default Monitor probs

I am pretty sure I am in Grub because when I select linux I can edit the kernal.. etc from there and when I press 'e' it comes up at grub>prompt

I think I need to get ahold of the people who installed it for me and see it they can resolve it.

I am too new to this OS to mess with it.

Thanks for responding.

Jasp
jaspin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Samsung becomes Linux Foundation platinum member, takes a seat on board News Archived News Items 0 06-05-12 06:10 PM
nVidia Linux drivers with Linux on Mac, help? Thetargos NVIDIA Linux 0 05-13-12 12:52 PM
302.07 (beta) for Linux x86/x86_64 released AaronP NVIDIA Linux 0 05-02-12 09:55 AM
Mandrake Linux 9.0 (Dolphin) now available | comments? volt General Linux 10 10-19-02 10:13 PM
Linux VS. Windows XP! XP wins! dostler NVIDIA Linux 20 09-15-02 03:47 PM

All times are GMT -5. The time now is 06:05 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.