Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-09-09, 05:18 AM   #1
Mawerick
Registered User
 
Join Date: Dec 2009
Posts: 2
Default Help On Nvidia Drivers

Hi all,
I've already installed new fedora distribution (fedora 12) on my acer aspire 1363 wlmi. Everything went just fine except for nvidia driver.
Video card is an nVidia GeForce Fx Go 5200. Searching on nvidia website I found that a suitable driver package.
First I tried using:
Quote:
NVIDIA-Linux-x86-173.14.22-pkg1
package as root and runlevel 3. But it gave following error:
Quote:
include/linux/highmem.h:149: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:149: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:149: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:149: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:152: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:152: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:152: warning: pointer of type ‘void *’ used in a
rithmetic
include/linux/highmem.h:152: warning: pointer of type ‘void *’ used in a
rithmetic
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c: In function
‘nvos_proc_create’:
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:610: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:611: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:612: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:632: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:645: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:656: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:666: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:676: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:687: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:694: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c: In function
‘nvos_proc_add_warning_file’:
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:721: error:
‘struct proc_dir_entry’ has no member named ‘owner’
make[4]: *** [/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.
o] Error 1
make[3]: *** [_module_/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/sr
c/nv] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
Then I tried using yum.
Quote:
yum install kmod-nvidia173xx-PAE
Everything was ok but after rebooting screen was smaller and I'd to uninstall all nvida files and drivers.

So, please, could anyone tell me if exists a suitable driver for my Fx Go 5200 card? Then could anyone tell me, step by step, how to install it?

Thanks in advance for any help.
Mawerick is offline   Reply With Quote
Old 12-09-09, 07:59 AM   #2
leigh123linux
Registered User
 
leigh123linux's Avatar
 
Join Date: Feb 2008
Posts: 163
Default Re: Help On Nvidia Drivers

Quote:
Originally Posted by Mawerick View Post
Hi all,
I've already installed new fedora distribution (fedora 12) on my acer aspire 1363 wlmi. Everything went just fine except for nvidia driver.
Video card is an nVidia GeForce Fx Go 5200. Searching on nvidia website I found that a suitable driver package.
First I tried using:

package as root and runlevel 3. But it gave following error:

Then I tried using yum.

Everything was ok but after rebooting screen was smaller and I'd to uninstall all nvida files and drivers.

So, please, could anyone tell me if exists a suitable driver for my Fx Go 5200 card? Then could anyone tell me, step by step, how to install it?

Thanks in advance for any help.

You tried to install a old version

Code:
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c: In function
‘nvos_proc_create’:
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:610: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:611: error:
‘struct proc_dir_entry’ has no member named ‘owner’
/tmp/selfgz4664/NVIDIA-Linux-x86-173.14.18-pkg1/usr/src/nv/nv.c:612: error:
‘struct proc_dir_entry’ has no member named ‘owner’
__________________
leigh123linux
leigh123linux is offline   Reply With Quote
Old 12-09-09, 08:01 AM   #3
tier
Registered User
 
Join Date: Sep 2007
Posts: 118
Default Re: Help On Nvidia Drivers

Since you were able to use yum, did you install the rpmfusion repositories?
http://rpmfusion.org/Configuration
Did you then follow http://rpmfusion.org/Howto/nVidia ? If yes (and that means every single step!) what do you mean by "screen was smaller"? Did you have a small resolution? Check this with nvidia-settings.
tier is offline   Reply With Quote
Old 12-10-09, 07:49 AM   #4
Mawerick
Registered User
 
Join Date: Dec 2009
Posts: 2
Default Re: Help On Nvidia Drivers

Hi all,
first of all thanks for your quickly replies.
I'm sorry to have post a wrong log. Anyway error was the same except for 22 instead 18.

Talking about yum it was correctly installed and configured and enabled with rpmfusion repos.
After installation via yum my displayed screen was smaller in terms of area displayed. I have a 15.4" monitor but used area was about 2/3 of the available. In other words I'd got a black area on right taking about 1/3 of the monitor. There was also a bad resolution.

Installing, either via yum and package "NVIDIA-Linux-x86-173.14.18-pkg1.run", I followed step by step and very carefully instructions reported on site http://rpmfusion.org/Howto/nVidia. As result I had a black screen with a blinking cursor on top left.

As usually thanks in advance for any help.
Mawerick
Mawerick is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.