Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-16-09, 07:52 AM   #1
overac
Registered User
 
Join Date: Dec 2009
Posts: 3
Default x86-96.43.14 Driver under Debian Sid

Hello,
yesterday i have updated my old laptop, a dell inspiron 8200 with Geforce Go2 graphics-card.

This system is running Debian unstable for some years now.
The kernel updated to version 2.6.32.
I have downloaded the NVIDIA-Linux-x86-96.43.14-pkg1.run driver package
and installed it the usual way.
The installation process did finish without any errors.
But when starting X with startx or xinit I now get the folling error.


Backtrace:
0: X(xorg_backtrace+0x3b) [0x81314cb]
1: X(xf86SigHandler+0x51) [0x80c1df1]
2: [0xb779a400]

Fatal server error:
Caught signal 11. Server aborting


Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.



Before that I was running a 2.6.25 kernel with the NVIDIA-Linux-x86-96.43.05-pkg1.run driver without any problems
Any hints ?
overac is offline   Reply With Quote
Old 12-16-09, 08:26 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: x86-96.43.14 Driver under Debian Sid

If you have another computer you can connect from, could you please log in with ssh and try starting X with "gdb Xorg" as root and then running the "backtrace" command when it catches the crash? The backtrace produced by X itself is not useful.

Last edited by AaronP; 12-16-09 at 08:26 AM. Reason: Mention SSH
AaronP is offline   Reply With Quote
Old 12-16-09, 09:19 AM   #3
overac
Registered User
 
Join Date: Dec 2009
Posts: 3
Default Re: x86-96.43.14 Driver under Debian Sid

Hi,
this is what i got when I logged in via ssh and use gdb:

>>> gdb Xorg
GNU gdb (GDB) 7.0-debian
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/bin/Xorg...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/Xorg
[Thread debugging using libthread_db enabled]

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.30.8-dsa-ia32 i686 Debian
Current Operating System: Linux debian 2.6.32-trunk-686 #1 SMP Mon Dec 7 21:35:21 UTC 2009 i686
Build Date: 13 October 2009 11:25:51AM
xorg-server 2:1.6.5-1 (buildd@murphy.debian.org)
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Dec 16 16:09:38 2009
(==) Using config file: "/etc/X11/xorg.conf"
[tcsetpgrp failed in terminal_inferior: Die Operation ist nicht erlaubt]

Program received signal SIGSEGV, Segmentation fault.
0xb6f3a4d8 in ?? () from /usr/lib/xorg/modules/drivers//nvidia_drv.so
(gdb) backtrace
#0 0xb6f3a4d8 in ?? () from /usr/lib/xorg/modules/drivers//nvidia_drv.so
Cannot access memory at address 0x5

thanks in advance for any hints
overac is offline   Reply With Quote
Old 12-20-09, 11:31 AM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: x86-96.43.14 Driver under Debian Sid

Hmm, that's not particularly helpful either, I'm afraid. I'll have to see if I can reproduce the problem.
AaronP is offline   Reply With Quote
Old 12-20-09, 10:23 PM   #5
utanja
Debian All the Way
 
Join Date: May 2004
Location: Salzburg Austria & Orlando Florida
Posts: 59
Default Re: x86-96.43.14 Driver under Debian Sid

I am running the same driver with the same kernel under Debian Sid.. but Ihave the M440 nvidia card......no problems with the install and runs perfectly...
__________________
utanja
i am female and i don't do windows.. and i don't do macs ..i fly a Lear Jet
"Wer fremde Sprachen nicht kennt, weiss nichts von seiner eigenen."
- Goethe, Maximen und Reflexionen
Intel 3I-core 2d.gen -3.1GHz;8 gig ram;PureDebian SID[3.2[custom kernel] 8 Debian workstations
plus HP Win7 64bit Wireless Laptop Network/Citrix/NX/VMware
Mozilla/Firebird browsers
my american friends call me tonya
utanja is offline   Reply With Quote
Old 12-21-09, 05:58 AM   #6
overac
Registered User
 
Join Date: Dec 2009
Posts: 3
Default Re: x86-96.43.14 Driver under Debian Sid

Hi,
after trying several possibilities starting from compiling a new kernel ( vanilla and debian sources ) or using an older version of the driver ( and combinations of that ) I am
now using an older kernel from Lenny ( 2.6.26 ) and use the
module-assistant approach from here .
It is an older kernel, but my card and 3D work.
Maybe it's a problem with the driver in combination with my card and the new kernel ?
Is this worth a bug ticket and where would I post that ?

Kind Regards
overac is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:28 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.