Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-18-09, 05:04 PM   #13
gio___
Registered User
 
Join Date: Nov 2009
Posts: 44
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Even here one time a sudden crash happened (maybe twice) with battery power but I had given it no importance. If I'll get more trouble I will post my dmesg.

I can say that even if ACPI notice the transition from battery power to AC, it is not the same for nvidia-settings that continue to recognize the power present at boot but may be is a problem not directly related to nvidia-drivers... I will investigate

gio
gio___ is offline   Reply With Quote
Old 11-18-09, 05:15 PM   #14
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Hi Stephen,

Exactly the same story with 180.60. I downgraded to xorg-server 1.6.5 and kernel 2.6.30.9

By default card stays on lowest clocks settings (despite reporting maximum performance) - (powermizer2.png)

Running "nvidia-settings -q all" clocks jump to level 1 (powermizer3.png).

If there's anything else I can do to help - please let me know.
Attached Thumbnails
Click image for larger version

Name:	powermizer2.jpg
Views:	266
Size:	88.8 KB
ID:	38689  Click image for larger version

Name:	powermizer3.jpg
Views:	252
Size:	87.6 KB
ID:	38690  
queen6 is offline   Reply With Quote
Old 11-18-09, 07:00 PM   #15
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

queen6, thanks for the information re: PowerMizer. I'll add it to our bug reports.

For the X crash, it's probably best to start a new thread. it might be useful if you could:
a) Switch to text console
b) As root, run "gdb X"
c) At the gdb prompt, type "r" to run
d) When X crashes, type "bt"
e) Paste the information to the new thread, and re-attach your bug report there too.

Thanks.
Stephen Warren is offline   Reply With Quote
Old 11-19-09, 03:08 AM   #16
queen6
Registered User
 
Join Date: Dec 2007
Posts: 64
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Hi Stephen,

When I get home, I'll recompile X with -ggdb and post a backtrace.

Thanks,
Rob
queen6 is offline   Reply With Quote
Old 11-29-09, 08:14 PM   #17
gio___
Registered User
 
Join Date: Nov 2009
Posts: 44
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Not fixed in 195.22 beta.

gio
gio___ is offline   Reply With Quote
Old 12-06-09, 01:02 PM   #18
iSpy
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

GT 240 DDR5, Powermizer show "Maximum perfomance", but clocks not change.
Tested on 190.42 and 195.22
My 3d frequencies on this card 575/1800, but work always 405/324.
Please fix it.
iSpy is offline   Reply With Quote
Old 12-08-09, 01:56 PM   #19
pootle
Registered User
 
Join Date: May 2009
Posts: 13
Default 9300m GS nvidia-drivers-190.42 - powermizer issue

yup, on my laptop with this version on battery it seems to drop to perf level 0, wind up correctly (for example glxgears bumps it up to level 3 correctly.

on mains power, once it has wound up to level 3, it just stays there (and my knees get toasted )

Oops, wrong, it does wind down, but after running Cuda apps, it seems to take a little longer...
pootle is offline   Reply With Quote
Old 12-17-09, 05:06 PM   #20
gio___
Registered User
 
Join Date: Nov 2009
Posts: 44
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Not fixed in 190.53
Attached Files
File Type: gz nvidia-bug-report.log.gz (47.2 KB, 128 views)
gio___ is offline   Reply With Quote

Old 12-20-09, 12:42 AM   #21
mrn
Registered User
 
Join Date: Dec 2004
Posts: 254
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Signing up to this.
mrn is offline   Reply With Quote
Old 12-20-09, 06:14 AM   #22
ttsiodras
Registered User
 
Join Date: Dec 2009
Posts: 11
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Same thing happens to me - my card is a GT240/GDDR5 - I realized it after I found out that my GPL CUDA Mandelbrot zoomer run at double speed under Windows (I blogged about it here: http://users.softlab.ece.ntua.gr/~ttsiod/mandelSSE.html )

Code:
bash$ nvidia-settings -q all | grep -A 1 PerfModes
  Attribute 'GPUPerfModes' (home:0.0): perf=0, nvclock=135, memclock=135 ;
  perf=1, nvclock=405, memclock=324 ; perf=2, nvclock=550, memclock=1700 

bash$ nvidia-settings -q all | grep  GPUCurrent | grep Attr
  Attribute 'GPUCurrentClockFreqs' (home:0.0): 405,324.
  Attribute 'GPUCurrentPerfMode' (home:0.0): 1.
  Attribute 'GPUCurrentPerfLevel' (home:0.0): 1.
The level doesn't change no matter what I tried (including setting the registry flags in xorg.conf, to disable powermizer, or hardcode levels...

Code:
Option "RegistryDwords" "PowerMizerEnable=0x0; PerfLevelSrc=0x2222; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
The bug exists in both 190.53 and 195.22.

Please fix this in the next driver release...

Thanassis Tsiodras, Dr.-Ing.
ttsiodras is offline   Reply With Quote
Old 12-23-09, 04:02 AM   #23
iSpy
Registered User
 
Join Date: Oct 2008
Posts: 8
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Not fixed in 195.30
iSpy is offline   Reply With Quote
Old 12-30-09, 04:07 AM   #24
ttsiodras
Registered User
 
Join Date: Dec 2009
Posts: 11
Default Re: 260GTX nvidia-drivers-190.42-r3 - powermizer issue

Here's a screenshot showing the problem:



Notice that my GT240/GDDR5 runs glxgears at around 4700 fps (which is very slow for this kind of chip), and that even though I run an OpenGL app, powermizer still doesn't use the 1.7GHz mode...

The same applies to CUDA code, like nbody:

Code:
Under Linux:
./nbody -benchmark -n=30000
Run "nbody -benchmark [-n=<numBodies>]" to measure perfomance.
30000 bodies, total time for 100 iterations: 19701.262 ms
= 4.568 billion interactions per second
= 91.365 GFLOP/s at 20 flops per interaction

Under Windows XP:
Run "nbody -benchmark [-n=<numBodies>]" to measure perfomance.
30000 bodies, total time for 100 iterations: 12137.919 ms
= 7.415 billion interactions per second
= 148.296 GFLOP/s at 20 flops per interaction
I verified (via GPU-Z) that under Windows XP, the card uses the 1.7GHz mode.

This is definitely a Linux driver bug, that affects cards with GT240/GDDR5 - maybe others, too...
ttsiodras is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.