Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-22-09, 03:50 AM   #1
f_m
Registered User
 
Join Date: Dec 2009
Posts: 2
Default 173.14.20/.22 wrong version of kernel module?

I'm running the 173.14.12 driver (64bit) for my Geforce FX 5700 card and tried to upgrade to the latest and recommended driver for this card: 173.14.22, installation using the .run file and compiling the kernel module during the installation worked as always but trying to start the X server resulted in the following a crash because of mismatched module versions

Code:
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.22  Wed Nov 11 05:08:25 PST 2009
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.09  Wed Jun  4 23:40:50 PDT 2008
NVRM: API mismatch: the client has the version 173.14.22, but
NVRM: this kernel module has the version 173.14.09.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.

- i tried it then with the 173.14.20 driver with the same result:

Code:
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.20  Thu Jun 25 18:15:32 PDT 2009
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.09  Wed Jun  4 23:40:50 PDT 2008
NVRM: API mismatch: the client has the version 173.14.20, but
NVRM: this kernel module has the version 173.14.09.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.
so I went back to the 173.14.12 i had installed before and everything is fine and working:
Code:
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.12  Thu Jul 17 18:10:24 PDT 2008
NVRM: loading NVIDIA UNIX x86_64 Kernel Module  173.14.12  Thu Jul 17 18:10:24 PDT 2008
f_m is offline   Reply With Quote
Old 12-22-09, 10:58 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: 173.14.20/.22 wrong version of kernel module?

If you use the .run installer package, please make sure that any driver packages from your distribution are uninstalled first.
AaronP is offline   Reply With Quote
Old 12-23-09, 05:21 AM   #3
f_m
Registered User
 
Join Date: Dec 2009
Posts: 2
Default Re: 173.14.20/.22 wrong version of kernel module?

Thanks, that solved it - i had really still an older rpm of the nvidia driver installed
Just strange that the 173.14.12 (also installed with the .run file) was able to work...
f_m is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.