Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-27-09, 08:04 AM   #1
randomas
Registered User
 
Join Date: Feb 2004
Posts: 11
Default [SOLVED]asus ul30vt hybrid graphics nvidia g210m card not found

Hallo, I have a new asus ul30vt laptop and installed ubuntu karmic, I can't get the discreet g210m nvidia card to work.

I tried the packaged nvidia drivers, but I found that the 185 version does not support this card. I tried the vdpau ppa drivers (both 190 and 195 versions) and still no joy.

The effect of this is to reach a black screen with some white garbage at the top.

I checked the xorg logs and this is the result:
Code:
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
        compiled for 4.0.2, module version = 1.0.0
        Module class: X.Org Video Driver
(II) NVIDIA dlloader X Driver  185.18.36  Fri Aug 14 17:24:40 PDT 2009
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00@00:02:0
(EE) No devices detected.

Fatal server error:
no screens found

Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.2.log" for additional information.

 ddxSigGiveUp: Closing log
This is the result for the 185 drivers, I don't have the 190 and 195 results because I did a clean reinstall, but the results were similar.

In the mean while the intel drivers found their mark and get the visual effects working, but I'd rather have the nvidia working.

Has anyone managed to solve this problem or have any relevant advice?

TIA

Last edited by randomas; 08-25-10 at 10:02 AM. Reason: Solved problem updateing bios
randomas is offline   Reply With Quote
Old 12-27-09, 09:03 AM   #2
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Is there BIOS setting to select external graphics?

On UL50Vg it came with BIOS 214 (and was removed in next 216).. Only 195 series drivers worked properly in my Asus.
P.Kosunen is offline   Reply With Quote
Old 12-27-09, 10:50 AM   #3
randomas
Registered User
 
Join Date: Feb 2004
Posts: 11
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Unfortunately, there is no bios setting for video card choice.
randomas is offline   Reply With Quote
Old 12-28-09, 08:12 AM   #4
boyzonder
Registered User
 
Join Date: Jan 2004
Posts: 3
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Hi P. Kosunen,

Do you have external graphics (NVIDIA G210M) working with the UL50VG and 195 drivers? If so, could you please post your approach and possibly your xorg.conf? I've tried with those drivers in Ubuntu Karmic Koala, setting the BusID option to PCI:1:0:0 and using a custom EDID (as described here: http://www.nvnews.net/vbulletin/showthread.php?t=140482) but I get the "failed to copy vbios to system memory" error, as described here: http://ubuntuforums.org/showthread.php?t=1329821.

Thanks,
boyzonder
boyzonder is offline   Reply With Quote
Old 12-28-09, 08:58 AM   #5
P.Kosunen
Registered User
 
Join Date: Jan 2009
Posts: 57
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Quote:
Originally Posted by boyzonder View Post
I've tried with those drivers in Ubuntu Karmic Koala, setting the BusID option to PCI:1:0:0 and using a custom EDID (as described here: http://www.nvnews.net/vbulletin/showthread.php?t=140482) but I get the "failed to copy vbios to system memory" error, as described here: http://ubuntuforums.org/showthread.php?t=1329821.
You need right BIOS, 214. Then change GPU setting from Advanced page to External graphics.

Code:
Section "Device"
    Identifier     "VideoCard"
    Driver         "nvidia"
    Option         "NoLogo"              "True"
    Option         "FlatPanelProperties" "Scaling = Native"
EndSection
After correct BIOS setting minimal conf will be enough.

(I use Intel currently since Asus removed selection from newest 216 BIOS.)
P.Kosunen is offline   Reply With Quote
Old 12-29-09, 08:56 PM   #6
makeable
Registered User
 
Join Date: Nov 2009
Posts: 13
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

The G210M is no longer a supported device.
makeable is offline   Reply With Quote
Old 01-05-10, 04:48 AM   #7
randomas
Registered User
 
Join Date: Feb 2004
Posts: 11
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Holy Crap!!! You're right! The g210m disappeared from the list of supported cards, then again I may have miss-read the first time round, but I'm pretty sure it was supported.
I doubt they've changed the driver, probably found the there were too many problems with the g210m and withdrew official support.

My question is what do I do now?

Anyone know if there are plans to have the g210m supported, in particular on notebooks with hybrid graphics?

At the moment the notebook works great using the intel chip, but I'd like to use all the hardware I payed for.
randomas is offline   Reply With Quote
Old 03-07-10, 03:05 PM   #8
brynstntn
Registered User
 
Join Date: Mar 2010
Posts: 3
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

I do not think NVIDIA dropped support for the g210m, because this card is working fine on other laptops. If we use the nvidia drivers or the nv drivers over the intel drivers, we set our busid to "PCI:1:0:0" in xorg.conf, we get a black screen. This sounds like it has something to do with Asus's Design. Sounds like the fix will have to come from the opensource side. I'm curious, has anyone tried xorg server 1.8? If so, does it fix it?
brynstntn is offline   Reply With Quote

Old 04-30-10, 04:12 PM   #9
brynstntn
Registered User
 
Join Date: Mar 2010
Posts: 3
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Ive gotten nvidia g210m drivers to work on my gentoo install. I just changed the SATA option in the bios from enhanced to compatibility. Hopes this helps. Im using the ul50vt, but as I understand, the ul30vt is suffering from the same problem. If you are using the proprietary drivers, you will have to turn off kms.
brynstntn is offline   Reply With Quote
Old 05-06-10, 04:23 PM   #10
gille
Registered User
 
Join Date: May 2010
Posts: 1
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

If someone from NVIDIA could please help improve support for the GeForce G210M on the ASUS UL series of computers, it would be greatly appreciated.

I can confirm that changing the BIOS configuration on an ASUS UL30VT makes the G210M graphics card usable, though at the same time it seriously degrades the I/O performance of the hard drive. More to the point, I upgraded to a SSD drive with which Linux will typically boot in less than 4 seconds, but with this BIOS configuration the boot phase increases to a whopping 27 seconds. A similar degradation occurs when awaking from standby.

Again, could someone from NVIDIA provide some input into the matter? At the moment, I have absolutely no idea what causes the problem with the driver when SATA operation is not worsened.

Specific instructions on how to change the BIOS configuration:
  1. Start the computer and press F2 to enter the BIOS Setup Utility
  2. Select Advanced > IDE Configuration > SATA Operation Mode
  3. Change the configuration from Enhanced to Compatible

This is applicable to version 210 (2010/03/11) of the BIOS. The description for this configuration provided by the BIOS Setup Utility is:
Select "Compatible" to set serial ATA channel at IDE mode for OS not supporting NATIVE SATA controller like Windows XP & 2000 or it will run into BSOD when installing WIndows.
All problems are applicable to the nvidia-current Debian package version 195.36.15-0ubuntu2 and 195.36.24-0ubuntu0sarvatt2.

Finally, this was tested on Ubuntu 10.04 LTS, kernel version 2.6.32-22-generic.

Last edited by gille; 05-06-10 at 04:28 PM. Reason: Forgot to provide OS and kernel details.
gille is offline   Reply With Quote
Old 05-08-10, 10:21 PM   #11
brynstntn
Registered User
 
Join Date: Mar 2010
Posts: 3
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

Quote:
Originally Posted by gille View Post
If someone from NVIDIA could please help improve support for the GeForce G210M on the ASUS UL series of computers, it would be greatly appreciated.

I can confirm that changing the BIOS configuration on an ASUS UL30VT makes the G210M graphics card usable, though at the same time it seriously degrades the I/O performance of the hard drive. More to the point, I upgraded to a SSD drive with which Linux will typically boot in less than 4 seconds, but with this BIOS configuration the boot phase increases to a whopping 27 seconds. A similar degradation occurs when awaking from standby.

Again, could someone from NVIDIA provide some input into the matter? At the moment, I have absolutely no idea what causes the problem with the driver when SATA operation is not worsened.

Specific instructions on how to change the BIOS configuration:
  1. Start the computer and press F2 to enter the BIOS Setup Utility
  2. Select Advanced > IDE Configuration > SATA Operation Mode
  3. Change the configuration from Enhanced to Compatible

This is applicable to version 210 (2010/03/11) of the BIOS. The description for this configuration provided by the BIOS Setup Utility is:
Select "Compatible" to set serial ATA channel at IDE mode for OS not supporting NATIVE SATA controller like Windows XP & 2000 or it will run into BSOD when installing WIndows.
All problems are applicable to the nvidia-current Debian package version 195.36.15-0ubuntu2 and 195.36.24-0ubuntu0sarvatt2.

Finally, this was tested on Ubuntu 10.04 LTS, kernel version 2.6.32-22-generic.
The fault lies not in Nvidia, but in Asus. Asus designed the laptop and implemented custom drivers. Linux just does not know how to handle the multiplexer to switch the cards yet.
brynstntn is offline   Reply With Quote
Old 05-09-10, 11:49 AM   #12
Jonlin
Registered User
 
Join Date: May 2010
Posts: 2
Default Re: asus ul30vt hybrid graphics nvidia g210m card not found

With the SATA-controller in compability mode I get the following result with bonnie++, and it would be interesting if someone who is running with default settings and disk could run a benchmark as well?!

Version 1.96 ------Sequential Output------ --Sequential Input- --Random-
Concurrency 1 -Per Chr- --Block-- -Rewrite- -Per Chr- --Block-- --Seeks--
Machine Size K/sec %CP K/sec %CP K/sec %CP K/sec %CP K/sec %CP /sec %CP
jonas-laptop 7928M 69447 16 31745 8 91153 11 106.4 4
Latency 1678ms 1763ms 156ms 1085ms

I ran bonnie++ with -r 3964 so that it actually writes to the disk.

The only thing I have noticed since running it in compability mode for about a week is that it takes perhaps 10 seconds longer for the laptop to wake from suspend than before, but actually thought that had to do with problems in the nVidia-drivers and not decreased disk performance.
Jonlin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:03 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.