Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-07-03, 02:39 AM   #1
phuture
Registered User
 
Join Date: Apr 2003
Posts: 7
Default Problems with Laptop Display / Mandrake 9.1

Hi,

some problems with the nvidia Drivers and Mandrake 9.1 here.

After installing the driver-package and changing the XFree Config-File, the X-Server seems to start. But I only see a blank screen. I have a Toshiba Laptop (Flat Panel @ 1280x1024) and a ‎NV17M GeForce4 440 Go.

Log File attached, Config below.

Regards,
PH

--- Config File ----

# File generated by XFdrake

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "de(nodeadkeys)"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "Flat Panel 1280x1024"
HorizSync 31.5-67
VertRefresh 50-75

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection
Attached Files
File Type: log xfree86.0.log (28.6 KB, 192 views)
phuture is offline   Reply With Quote
Old 10-08-03, 08:38 AM   #2
phuture
Registered User
 
Join Date: Apr 2003
Posts: 7
Default

Does really nobody know an answer?
phuture is offline   Reply With Quote
Old 10-08-03, 09:03 AM   #3
ablaz3r
Registered User
 
Join Date: Oct 2003
Posts: 1
Default

I have exactly the same problem with my Toshiba 2450-S402 notebook and Debian Linux! I installed the NVIDIA driver, the module NVIDIA loads without errors, but when I press "startx" I only see a black screen! Any ideas?
ablaz3r is offline   Reply With Quote
Old 10-14-03, 09:17 AM   #4
phuture
Registered User
 
Join Date: Apr 2003
Posts: 7
Default

Sorry, but I am very disappointed with the support from NVidia.

I hoped to get at least an advice where to search.

:-(
phuture is offline   Reply With Quote
Old 10-17-03, 10:49 PM   #5
pyrest
Registered User
 
Join Date: Oct 2003
Posts: 4
Default

Here are some things you can try:
(Please read the whole post and note where variables are shown my settings are in parentheses)

Edit your /etc/modules.conf file so that it ignores EDID values:

options nvidia NVreg_Mobile=N
(options nvidia NVreg_Mobile=2)

where N is equal to the listing from the README under the Laptop section (since you're using a Toshiba, yours is probably N=2). NOTE: This must be after the aliasing of the device therefore if you install the driver again you need to re-edit this file.
/*********
Tip: You can see the values for N by doing the following - (alternatively just download it)

1. Extract the package from the run script:
% ./NVIDIA-Linux-x86-1.0-xxxx.run --extract-only

(The % is a shell prompt)
where xxxx is the driver batch version

2. Do a grep on the README:
% cat NVIDIA-Linux-x86-1.0-xxxx/usr/share/doc/README | grep laptop

In addition there is a hex value of 0xFFFFFFFF to indicate auto-detect, which is the default value
*********/

Also add this to your XF86Config file:

Under Section Monitor set your HorizSync and VertRefresh:

Section "Monitor"
Identifier "Monitor0"
HorizSync a-b
VertRefresh c-d
EndSection

(HorizSync 35-85
VertRefresh 40-100)

where a and b represent the lower and higher bounds for the Horizontal Sync Rate and c and d represent the lower and higher bounds of the Vertical Refresh Rate

Under Section Device (for the video card):

Section "Device"
Identifier "Nvidia"
Driver "nvidia"
Option "IgnoreEDID" "1"
EndSection

Make sure you use the native res for the screen:

Section "Screen"
Identifier "Screen0"
Device "Nvidia"
Monitor "Monitor0"

DefaultDepth #

SubSection "Display"
Depth #
Modes "NATIVE"

EndSubSection
EndSection

(DefaultDepth 16

SubSection "Display"
Depth 16
Modes "1280x1024"

EndSubSection
EndSection)

Where # is equal to your desired color bpp and NATIVE is equal to your native resolution.

It should also be noted that I personally have problems with the latest drivers (I get a lot of visual tearing and a vertical bar down the center). If you have these kinds of problems consider using the last set of drivers - the 4363 batch.

If you get lots of distortion/tearing check to make sure you have high enough frequencies under the monitor section.

If you get a blank or a "trippy" looking screen make sure you disabled the EDID lookup. NOTE: There is also a kernel module option for SoftEDIDs, I've tried to use this and it fails for me. Instead use the IgnoreEDID setting.

For a convenient way to gather a list of most (if not all) the options do this (Must be run as root):

% XFree86 -configure

(That % is the shell prompt)
It should make a dummy XF86Config file in your /root directory.

Once you have this file edit it accordingly:

1. Change Freqs.
2. Add bool for IgnoreEDID
3. Add DefaultDepth and Modes
4. Change mouse to correct device handle (i.e. /dev/usbmouse or /dev/mouse)
5. Change the protocol to "IMPS/2" (if you are using the X for Linux, *BSDs can ignore this)
6. Add Option "ZAxisMapping" "x y" where x and y correspond to the wheel buttons (usually 4 and 5) (FreeBSD has another directive to do this check the FreeBSD home page).
7. In addition disable Modules dri and GLcore if applicable and ensure that you have Module glx on
8. Do any other modifications you need
9. Move the file to /etc/X11 or as appropriate

Just for your information I have an 1955 Toshiba Series Satellite and the above works for me well enough.

If you need to, always test to make sure you can get X to load up with just a basic driver (i.e. the vesa driver). That way you know that it is the Nvidia configuration giving you problems.
pyrest is offline   Reply With Quote
Old 10-17-03, 10:54 PM   #6
pyrest
Registered User
 
Join Date: Oct 2003
Posts: 4
Default

In addition probably the best way to get the frequency rates would be to call the Toshiba Customer Service. Or if you want you can just fidget with the settings (what I did).

When you startx with the following switches:

% startx -- -logverbose 5

it will put a log file named XFree86.x.log into /var/log/

where x is equal to the X server number (if it's your own machine, it's usually 0)

Look for any warnings that indicate what DefaultModes are supported. You can then adjust your frequency to those values in order to use that specified res.

Also a big warning lies ahead:

There's an option known as IgnoreDisplayDevices which takes CRT, TV , and DFP as it's options. Unless you have read and understood what this does don't enable it. On my system it kills the display altogether and I have to switch to another terminal and reboot.

Last edited by pyrest; 10-17-03 at 11:02 PM.
pyrest is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Glx mrbig1344 NVIDIA Linux 7 09-30-02 06:45 AM
Desperate for help with Display problems!!!!! Petz NVIDIA Linux 12 09-18-02 07:26 PM
Mandrake 8.2 Nvidia src.rpm problems Mr_Malcontent NVIDIA Linux 8 09-11-02 09:53 PM
Getting GeForce 4 Go Card w/h Laptop Display Working eridu NVIDIA Linux 1 09-09-02 05:36 AM
Problems with Mandrake and NVidia drivers..... xMonoxide187x NVIDIA Linux 2 08-22-02 01:55 PM

All times are GMT -5. The time now is 11:52 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.