Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-16-10, 10:50 PM   #1
Steve Cave
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Cannot overclock GPU on Linux

Hello. I'm trying to overclock my nVidia graphics card on Linux. However, the nvidia-settings utility fails to set the new clock frequencies I specify, regardless of the values I choose. Nevertheless, I can overclock my card without any trouble on Windows, on the same computer. I would appreciate help that anyone can provide in solving this problem.
Steve Cave is offline   Reply With Quote
Old 01-17-10, 12:18 AM   #2
Steve Cave
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Cannot overclock GPU on Linux

My apologies - nvidia-settings does seem functional, insofar as it does change my GPU's clock frequencies to the values I choose when I click "Apply" on the utility's "Clock Frequencies" page. My new problem is that these settings are not permanent - the clock speeds revert to their defaults whenever I restart X (for instance, when I reboot my system). How, then, can I make these settings permanent, or, failing that, cause them to be applied automatically upon starting X? My thanks for any help.

P.S. Here are some details about my system:
- GPU: GeForce 7600 GT
- Kernel version: 2.6.31
- nVidia drivers version: 185.18.36
- X server: X.org version 1.6.5
- nvidia-settings version: 180.60
Steve Cave is offline   Reply With Quote
Old 01-17-10, 02:26 AM   #3
simcop2388
Registered User
 
Join Date: Jun 2005
Posts: 15
Default Re: Cannot overclock GPU on Linux

put the following two lines (with whatever speed you need replaced) in a script somewhere to be loaded on boot.

nvidia-settings -a GPU2DClockFreqs=485,480
nvidia-settings -a GPU3DClockFreqs=485,480

see nvidia-settings --help and nvidia-settings -q all; for more information on those settings.
simcop2388 is offline   Reply With Quote
Old 01-17-10, 02:44 PM   #4
Steve Cave
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Cannot overclock GPU on Linux

Thanks for your reply. When I log in with

nvidia-settings -a GPU3DClockFreqs=x,y

in my startup script, the settings are not applied and I get the following message in my .xsession-errors file:

The program 'nvidia-settings' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
(Details: serial 67 error_code 2 request_code 137 minor_code 3)
(Note to programmers: normally, X errors are reported asynchronously;
that is, you will receive the error a while after causing it.
To debug your program, run it with the --sync command line
option to change this behavior. You can then get a meaningful
backtrace from your debugger if you break on the gdk_x_error() function.)

However, the command works if I issue it manually from a terminal, once I have logged in. That being the case, do you have any idea what might be causing the above error and how I may be able to circumvent it?
Steve Cave is offline   Reply With Quote
Old 01-18-10, 03:23 AM   #5
JClosed
Registered User
 
Join Date: Feb 2004
Location: Holland
Posts: 31
Default Re: Cannot overclock GPU on Linux

Hmmm....

It takes a bit work and it's a bit hidden, but enabling over clocking is easy for me.

I just open a terminal, su to root and start up Midnight Commander (you can also use any text editor as long as it is running in root mode). Then I browse to /etc/X11/ and edit (F4) the file xorg.conf. In this file I add the line:

Option "Coolbits" "1"

And save the file.

After that I log out and restart the X server (you can use the menu, reboot or -as last resort- Ctrl + Alt + Backspace), and log back in again.

And ... there it is in Nvidia settings - a whole new section called Clock Frequencies where you can overclock the GPU and memory (after getting a warning this can be harmfull - duh).

I hope this is wat you wanted?

Now - for making this settings permanent I have to know what window manager you are using. In KDE 4 you can use the hidden directory ~/.kde4/Autostart and put a script in it that loads the nvidia settings on start up, but if you are using Gnome ore something else that would be different.
JClosed is offline   Reply With Quote
Old 01-18-10, 02:48 PM   #6
Steve Cave
Registered User
 
Join Date: Apr 2009
Posts: 5
Default Re: Cannot overclock GPU on Linux

JClosed, thanks for your response. I had already enabled nvidia-settings' overclocking controls; my problem is that I must use them to manually overclock every time I log in. Regardless of the settings I have applied before, after I log in, the "Enable Overclocking" option in nvidia-settings is unchecked and all clock frequencies have reverted to their defaults. This is in spite of the fact that I have

nvidia-settings --load-config-only

in my window manager's startup script, which nevertheless restores all of the settings - other than those related to overclocking - that I have previously configured using the utility. simcop suggested that I force the restoration of the overclocking settings by putting

nvidia-settings -a GPU3DClockFreqs=x,y

in my startup script, in addition to the first line above. However, this results in the error I described in my previous post.

In case it is of any help, my window manager is Openbox 3.4.7.2. The "startup script" to which I have referred is ~/.config/openbox/autostart.sh, which is executed upon logging in to X. More specifically, it is sourced by a shell script, /usr/bin/openbox-session, which is run after user authentication and before the window manager is executed. The script is run as the user who authenticated. The relevant contents of autostart.sh are:

nvidia-settings --load-config-only
nvidia-settings -a GPU3DClockFreqs=x,y

Again, the second command works fine if I issue it manually after logging in. It only fails, producing the aforementioned error, when executed in the startup script.
Steve Cave is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.