Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-10-09, 11:06 AM   #1
rob.urban
Registered User
 
Join Date: Sep 2004
Posts: 13
Default quake3 broken after installing new kernel (FC11)

Hi Folks,

on a fedora-11 (x86_64) system I went from

Quote:
kernel-2.6.30.9-90.fc11.x86_64
to

Quote:
kernel-2.6.30.9-96.fc11.x86_64
and now quake3 spits out thousands of errors (see below).

I'm using the nvidia rpm from rpmfusion:

Quote:
rpm -qa | grep nvidia
xorg-x11-drv-nvidia-libs-190.42-1.fc11.x86_64
xorg-x11-drv-nvidia-190.42-1.fc11.x86_64
kmod-nvidia-2.6.30.9-96.fc11.x86_64-190.42-1.fc11.1.x86_64
kmod-nvidia-190.42-1.fc11.1.x86_64

Quote:
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135
Minor opcode of failed request: 16
Serial number of failed request: 220
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135
Minor opcode of failed request: 16
Serial number of failed request: 222
X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 135
Minor opcode of failed request: 16
Serial number of failed request: 226
the quake scene is also recognizably broken, and the speed (due to the errors, presumably) is unplayable.

Anyone else seen this? Anyone have a fix?

cheers,

Rob Urban
rob.urban is offline   Reply With Quote
Old 11-10-09, 04:20 PM   #2
rob.urban
Registered User
 
Join Date: Sep 2004
Posts: 13
Default Re: quake3 broken after installing new kernel (FC11)

as usual, I'll answer my own question.

quake3 requires the 32bit versions of the nvidia-libs, which I had not updated, hence the mismatch between client and kernel-mod.
rob.urban is offline   Reply With Quote
Old 11-10-09, 05:01 PM   #3
kwizart
Registered User
 
Join Date: Feb 2005
Location: Paris, France
Posts: 129
Default Re: quake3 broken after installing new kernel (FC11)

For the completeness: yum install xorg-x11-drv-nvidia-libs.i586 for Fedora 11.
kwizart is offline   Reply With Quote
Old 01-17-10, 10:27 PM   #4
Quickening
Registered User
 
Join Date: May 2003
Location: Dallas, TX
Posts: 14
Default Re: quake3 broken after installing new kernel (FC11)

I also upgraded to FC11, but 32-bit, and quake3 crashes on start up with signal 11. I installed my own kernel - 2.6.33.3 and built NVIDIA module version 190.53. Card is GeForce 9800 GTX.

The last thing printed to console before signal 11 is "GL_SUN_slice_accum"

glxgears and ut2004 still work.
Quickening is offline   Reply With Quote
Old 01-18-10, 05:33 PM   #5
barbara
Registered User
 
Join Date: Oct 2007
Location: Rome, Italy
Posts: 27
Default Re: quake3 broken after installing new kernel (FC11)

If all libs are ok, can you try prepending the command with __GL_ExtensionStringVersion=17700 ?
barbara is offline   Reply With Quote
Old 01-18-10, 10:53 PM   #6
Quickening
Registered User
 
Join Date: May 2003
Location: Dallas, TX
Posts: 14
Default Re: quake3 broken after installing new kernel (FC11)

amazing - that fixes it! what does that do?
Quickening is offline   Reply With Quote
Old 01-19-10, 01:53 AM   #7
barbara
Registered User
 
Join Date: Oct 2007
Location: Rome, Italy
Posts: 27
Default Re: quake3 broken after installing new kernel (FC11)

It generates the string describing the opengl capabilities like you are using the 177.0 driver.
Some apps crash because they don't allocate enough space to hold the string generated by newer driver versions.
barbara is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.